Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » eclipse 3.3 and WTP
eclipse 3.3 and WTP [message #182421] Thu, 09 November 2006 23:06 Go to next message
Eclipse UserFriend
Originally posted by: kevin.hanrahan.clickcommerce.com

I would like to use the enhanced refactoring history capabilities from
eclipse 3.3. I would like to use this on a WTP eclipse project.

How should I install WTP on eclipse 3.3?

The manual approach of copying features/plugins does not work, nor does
it work through the update manager.
Re: eclipse 3.3 and WTP [message #182477 is a reply to message #182421] Fri, 10 November 2006 16:47 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: kosta.bea.com

Kevin,

There is currently no released version of WTP that will work with
Eclipse 3.3. However, you can try the latest build of WTP 2.0 which is
in development right now. You can download it from...

http://download.eclipse.org/webtools/downloads/
Re: eclipse 3.3 and WTP [message #184259 is a reply to message #182477] Fri, 08 December 2006 22:24 Go to previous messageGo to next message
softlogo is currently offline softlogoFriend
Messages: 7
Registered: July 2009
Junior Member
Hello there,

Apparently there is a release 2.0M3 according to download page
http://download.eclipse.org/webtools/downloads/drops/R2.0/S- 2.0M3-200611170109/

but it does not seem to work, it requires eclipse.platform 3.2.0 or
equivalent.

Any ideas?

Haroon
Re: eclipse 3.3 and WTP [message #184262 is a reply to message #184259] Fri, 08 December 2006 23:43 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: kosta.bea.com

The build that you referenced works with Eclipse 3.3M3. You can find the
link to the correct eclipse platform download on the build page. Look
for the "Requirements" section.
Re: eclipse 3.3 and WTP [message #184264 is a reply to message #184262] Sat, 09 December 2006 00:16 Go to previous messageGo to next message
Eugene Kuleshov is currently offline Eugene KuleshovFriend
Messages: 505
Registered: July 2009
Senior Member
Hi,

Is there are an update site for development and milestone builds for
WTP 2.x?

Thanks

Eugene


Konstantin Komissarchik wrote:
> The build that you referenced works with Eclipse 3.3M3. You can find
> the link to the correct eclipse platform download on the build page.
> Look for the "Requirements" section.
Re: eclipse 3.3 and WTP [message #184269 is a reply to message #184262] Sat, 09 December 2006 04:45 Go to previous messageGo to next message
softlogo is currently offline softlogoFriend
Messages: 7
Registered: July 2009
Junior Member
Konstantin Komissarchik wrote:
> The build that you referenced works with Eclipse 3.3M3. You can find the
> link to the correct eclipse platform download on the build page. Look
> for the "Requirements" section.

It "Requirements" section says it requires eclipse 3.3. I am trying to
install it with configuration pasted below.
Requirements installed are
# The EMF driver used in this build is emf-sdo-xsd-SDK-2.3.0M3.zip
# The GEF driver used in this build is GEF-SDK-3.2.1.zip
# Java EMF Model Runtime driver used in this build is JEM-SDK-1.2.1.zip
# Data Tools Platform (DTP) driver used in this build is dtp-sdk_1.0M3.zip

When I installed WTP it was disabled and when I tried to enable it I got
following errors:

Requested operation cannot be performed because it would invalidate the
current configuration. See details for more information.
WST Common Core (1.6.0.v200611161425--AXrVWXdxnEfAsK) requires
feature "org.eclipse.emf (2.2.0)", or equivalent.
WST Server Core (1.6.0.v200611161425------1G955G7777) requires
feature "org.eclipse.rcp (3.2.0)", or equivalent.
WST XML Core (1.6.0.v200609120056--3YIAAYEEEZDNAA) requires feature
"org.eclipse.rcp (3.2.0)", or equivalent.
WST Web Services Core (1.6.0.v200611161425--4hNDDhGWJcJTQc) requires
feature "org.eclipse.platform (3.2.0)", or equivalent.
WST Web Core (1.6.0.v200611161425--4hNDDhHNJeHgIR) requires feature
"org.eclipse.platform (3.2.0)", or equivalent.



*** System properties:
eclipse.buildId=I20061102-1715
eclipse.commands=-os
linux
-ws
gtk
-arch
x86_64
-launcher
/mnt/data/work/eclipse3.3/eclipse/./eclipse
-name
Eclipse
-showsplash
600
-exitdata
8800b
-vm
/mnt/data/work/eclipse3.3/eclipse/./jre/bin/java
eclipse.ee.install.verify=false
eclipse.product=org.eclipse.sdk.ide
eclipse.startTime=1165638847146
eclipse.vm=/mnt/data/work/eclipse3.3/eclipse/./jre/bin/java
eclipse.vmargs=-Xms40m
-Xmx256m
-jar
/mnt/data/work/eclipse3.3/eclipse/./startup.jar
eof=eof
file.encoding=UTF-8
file.encoding.pkg=sun.io
file.separator=/
java.awt.graphicsenv=sun.awt.X11GraphicsEnvironment
java.awt.printerjob=sun.print.PSPrinterJob
java.class.path=/mnt/data/work/eclipse3.3/eclipse/./startup. jar
java.class.version=49.0
java.endorsed.dirs=/mnt/data/work/jdk1.5.0_06/jre/lib/endors ed
java.ext.dirs=/mnt/data/work/jdk1.5.0_06/jre/lib/ext
java.runtime.name=Java(TM) 2 Runtime Environment, Standard Edition
java.runtime.version=1.5.0_06-b05
java.specification.name=Java Platform API Specification
java.specification.vendor=Sun Microsystems Inc.
java.specification.version=1.5
java.vendor=Sun Microsystems Inc.
java.vendor.url=http://java.sun.com/
java.vendor.url.bug=http://java.sun.com/cgi-bin/bugreport.cgi
java.version=1.5.0_06
java.vm.info=mixed mode
java.vm.name=Java HotSpot(TM) 64-Bit Server VM
java.vm.specification.name=Java Virtual Machine Specification
java.vm.specification.vendor=Sun Microsystems Inc.
java.vm.specification.version=1.0
java.vm.vendor=Sun Microsystems Inc.
java.vm.version=1.5.0_06-b05
line.separator=

org.osgi.framework.bootdelegation=*
org.osgi.framework.executionenvironment=OSGi/Minimum-1.0,OSG i/Minimum-1.1,JRE-1.1,J2SE-1.2,J2SE-1.3,J2SE-1.4,J2SE-1.5
org.osgi.framework.language=en
org.osgi.framework.os.name=Linux
org.osgi.framework.os.version=2.6.19
org.osgi.framework.processor=amd64
org.osgi.framework.system.packages=javax.accessibility,javax .activity,javax.crypto,javax.crypto.interfaces,javax.crypto. spec,javax.imageio,javax.imageio.event,javax.imageio.metadat a,javax.imageio.plugins.bmp,javax.imageio.plugins.jpeg,javax .imageio.spi,javax.imageio.stream,javax.management,javax.man agement.loading,javax.management.modelmbean,javax.management .monitor,javax.management.openmbean,javax.management.relatio n,javax.management.remote,javax.management.remote.rmi,javax. management.timer,javax.naming,javax.naming.directory,javax.n aming.event,javax.naming.ldap,javax.naming.spi,javax.net,jav ax.net.ssl,javax.print,javax.print.attribute,javax.print.att ribute.standard,javax.print.event,javax.rmi,javax.rmi.CORBA, javax.rmi.ssl,javax.security.auth,javax.security.auth.callba ck,javax.security.auth.kerberos,javax.security.auth.login,ja vax.security.auth.spi,javax.security.auth.x500,javax.securit y.cert,javax.security.sasl,javax.sound.midi,javax.sound.midi .spi,javax.sound.sampled,javax
..sound.sampled.spi,javax.sql,javax.sql.rowset,javax.sql.row set.serial,javax.sql.rowset.spi,javax.swing,javax.swing.bord er,javax.swing.colorchooser,javax.swing.event,javax.swing.fi lechooser,javax.swing.plaf,javax.swing.plaf.basic,javax.swin g.plaf.metal,javax.swing.plaf.multi,javax.swing.plaf.synth,j avax.swing.table,javax.swing.text,javax.swing.text.html,java x.swing.text.html.parser,javax.swing.text.rtf,javax.swing.tr ee,javax.swing.undo,javax.transaction,javax.transaction.xa,j avax.xml,javax.xml.datatype,javax.xml.namespace,javax.xml.pa rsers,javax.xml.transform,javax.xml.transform.dom,javax.xml. transform.sax,javax.xml.transform.stream,javax.xml.validatio n,javax.xml.xpath,org.ietf.jgss,org.omg.CORBA,org.omg.CORBA_ 2_3,org.omg.CORBA_2_3.portable,org.omg.CORBA.DynAnyPackage,o rg.omg.CORBA.ORBPackage,org.omg.CORBA.portable,org.omg.CORBA .TypeCodePackage,org.omg.CosNaming,org.omg.CosNaming.NamingC ontextExtPackage,org.omg.CosNaming.NamingContextPackage,org. omg.Dynamic,org.omg.DynamicAny,
org.omg.DynamicAny.DynAnyFactoryPackage,org.omg.DynamicAny.D ynAnyPackage,org.omg.IOP,org.omg.IOP.CodecFactoryPackage,org .omg.IOP.CodecPackage,org.omg.Messaging,org.omg.PortableInte rceptor,org.omg.PortableInterceptor.ORBInitInfoPackage,org.o mg.PortableServer,org.omg.PortableServer.CurrentPackage,org. omg.PortableServer.POAManagerPackage,org.omg.PortableServer. POAPackage,org.omg.PortableServer.portable,org.omg.PortableS erver.ServantLocatorPackage,org.omg.SendingContext,org.omg.s tub.java.rmi,org.w3c.dom,org.w3c.dom.bootstrap,org.w3c.dom.e vents,org.w3c.dom.ls,org.xml.sax,org.xml.sax.ext,org.xml.sax .helpers
org.osgi.framework.vendor=Eclipse
org.osgi.framework.version=1.4.0
org.osgi.supports.framework.extension=true
os.arch=amd64
os.name=Linux
os.version=2.6.19
osgi.arch=x86_64
osgi.bundles=org.eclipse.equinox.common@2:start,
org.eclipse.update.configurator@3:start, org.eclipse.core.runtime@start
osgi.bundlestore=/mnt/data/work/eclipse3.3/eclipse/configura tion/org.eclipse.osgi/bundles
osgi.configuration.area=file:/mnt/data/work/eclipse3.3/eclip se/configuration/
osgi.framework=file:/mnt/data/work/eclipse3.3/eclipse/plugin s/org.eclipse.osgi_3.3.0.v20061101.jar
osgi.framework.beginningstartlevel=1
osgi.framework.shape=jar
osgi.framework.version=3.3.0.v20061101
osgi.os=linux
osgi.splashLocation=/mnt/data/work/eclipse3.3/eclipse/plugin s/org.eclipse.platform_3.2.0.v20060829/splash.bmp
osgi.splashPath=platform:/base/plugins/org.eclipse.platform
osgi.syspath=/mnt/data/work/eclipse3.3/eclipse/plugins
sun.arch.data.model=64
sun.io.unicode.encoding=UnicodeLittle
sun.management.compiler=HotSpot 64-Bit Server Compiler
Re: eclipse 3.3 and WTP [message #184397 is a reply to message #184269] Mon, 11 December 2006 16:38 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 2342
Registered: July 2009
Senior Member
haroon wrote:
> Konstantin Komissarchik wrote:
>> The build that you referenced works with Eclipse 3.3M3. You can find
>> the link to the correct eclipse platform download on the build page.
>> Look for the "Requirements" section.
>
> It "Requirements" section says it requires eclipse 3.3. I am trying to
> install it with configuration pasted below.
> Requirements installed are
> # The EMF driver used in this build is emf-sdo-xsd-SDK-2.3.0M3.zip
> # The GEF driver used in this build is GEF-SDK-3.2.1.zip
> # Java EMF Model Runtime driver used in this build is JEM-SDK-1.2.1.zip
> # Data Tools Platform (DTP) driver used in this build is dtp-sdk_1.0M3.zip
>
> When I installed WTP it was disabled and when I tried to enable it I got
> following errors:
>
> Requested operation cannot be performed because it would invalidate the
> current configuration. See details for more information.
> WST Common Core (1.6.0.v200611161425--AXrVWXdxnEfAsK) requires feature
> "org.eclipse.emf (2.2.0)", or equivalent.
> WST Server Core (1.6.0.v200611161425------1G955G7777) requires feature
> "org.eclipse.rcp (3.2.0)", or equivalent.
> WST XML Core (1.6.0.v200609120056--3YIAAYEEEZDNAA) requires feature
> "org.eclipse.rcp (3.2.0)", or equivalent.
> WST Web Services Core (1.6.0.v200611161425--4hNDDhGWJcJTQc) requires
> feature "org.eclipse.platform (3.2.0)", or equivalent.
> WST Web Core (1.6.0.v200611161425--4hNDDhHNJeHgIR) requires feature
> "org.eclipse.platform (3.2.0)", or equivalent.

Did you install (unzip) to a new location, or over a prior installation?

--
Nitin Dahyabhai
Structured Source Editor


---
Nitin Dahyabhai
Eclipse WTP, IBM
Re: eclipse 3.3 and WTP [message #184452 is a reply to message #184397] Tue, 12 December 2006 05:27 Go to previous messageGo to next message
Eugene Kuleshov is currently offline Eugene KuleshovFriend
Messages: 505
Registered: July 2009
Senior Member
Nitin Dahyabhai wrote:
>> Requested operation cannot be performed because it would invalidate
>> the current configuration. See details for more information.
>> WST Common Core (1.6.0.v200611161425--AXrVWXdxnEfAsK) requires
>> feature "org.eclipse.emf (2.2.0)", or equivalent.
>> WST Server Core (1.6.0.v200611161425------1G955G7777) requires
>> feature "org.eclipse.rcp (3.2.0)", or equivalent.
>> WST XML Core (1.6.0.v200609120056--3YIAAYEEEZDNAA) requires feature
>> "org.eclipse.rcp (3.2.0)", or equivalent.
>> WST Web Services Core (1.6.0.v200611161425--4hNDDhGWJcJTQc)
>> requires feature "org.eclipse.platform (3.2.0)", or equivalent.
>> WST Web Core (1.6.0.v200611161425--4hNDDhHNJeHgIR) requires feature
>> "org.eclipse.platform (3.2.0)", or equivalent.
> Did you install (unzip) to a new location, or over a prior installation?
This is exactly the reason why I've been asking for an update site for
new WTP builds.

regards,
Eugene
Re: eclipse 3.3 and WTP [message #184982 is a reply to message #184397] Fri, 15 December 2006 13:49 Go to previous messageGo to next message
Jean Couillaud is currently offline Jean CouillaudFriend
Messages: 11
Registered: July 2009
Junior Member
I installed it on a new location (the 3.3M3 and it does not work.
However, I installed a M3 that seems to be a little newer from the one I
originally got (some days of difference in the build name).
Does wtp2.0M3 verify dependencies in a way that could cause two different
behaviors against two builds of the same version ?

I got the same problem as Eugene (dependency issues message after trying
to enable the wtp feature).

In fact, when I install wtp for the first time, it seems to work, but
there is no trace of the wtp in the menus, actions, and so on.
The feature seems to have no problem, but when I disable it and try to
re-enable it, it shows some dependency errors.
Re: eclipse 3.3 and WTP [message #185403 is a reply to message #184982] Sat, 23 December 2006 08:37 Go to previous message
El Kodus is currently offline El KodusFriend
Messages: 1
Registered: July 2009
Junior Member
I experience the same problem wit WTP 2.0.
Clean (only that bundles which are required by WTP) installation of WTP
looks OK, no problem is reported, but there is almost no functionality of
the bundle (no labels in Preferences, no editors etc.).
Tried disable-enable, it does not work, no warnings, no errors... and no
functions :(

Any suggestions?
Thanks.
Previous Topic:QuickFix proposals for Annotations
Next Topic:JSP search not working
Goto Forum:
  


Current Time: Sat Dec 20 19:24:45 GMT 2014

Powered by FUDForum. Page generated in 0.01909 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software