Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Papyrus » All contents of an activity diagram lost...(...after adding swimlanes...)
All contents of an activity diagram lost... [message #1154756] Fri, 25 October 2013 12:33 Go to next message
Tomas Sandkvist is currently offline Tomas SandkvistFriend
Messages: 108
Registered: October 2013
Senior Member
Yes that's right. After adding swimlanes (activity compartments) and trying to export the diagram, everything in the diagram is gone!

There must be something very wrong with this, but how should a newbie know all these things? Is there a list of the absolute no-no's to read?

EDIT: I know what I did now, I deleted the same compartments from another diagram and then all the diagram contents was deleted from this diagram...I did not realize that there was such a hard connection between the compartment and the elements in it...

Regards,
Tomas Sandkvist

[Updated on: Fri, 25 October 2013 12:37]

Report message to a moderator

Re: All contents of an activity diagram lost... [message #1159565 is a reply to message #1154756] Mon, 28 October 2013 16:22 Go to previous messageGo to next message
Ronan B is currently offline Ronan BFriend
Messages: 249
Registered: July 2009
Senior Member
Hi Tomas,
The diagram is only a view of the model. This means you can have many views (diagrams) of the same model. Of course if you delete an element from the model it will disappear from all diagrams based on that model. This is the normal behaviour for UML based tools.
Regards,
Ronan
Re: All contents of an activity diagram lost... [message #1160507 is a reply to message #1159565] Tue, 29 October 2013 07:03 Go to previous message
Tomas Sandkvist is currently offline Tomas SandkvistFriend
Messages: 108
Registered: October 2013
Senior Member
Hi Ronan!

Yes, I'm aware of that, thing is that I spend a lot of time (under pressure to deliver) to create the diagram, work that had to be redone once more.

And I thought that the swimlanes where not elements that behaved as instances and containers, I thought that those where graphical elements within the diagram only (since I could not see them in the model explorer).

But, the best way to learn is from the mistakes! Very Happy
Previous Topic:Cannot relink control edge
Next Topic:Means to filter out associations from the model explorer
Goto Forum:
  


Current Time: Mon Dec 22 03:02:46 GMT 2014

Powered by FUDForum. Page generated in 0.11755 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software