Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » javax.servlet in tomcat plugin
javax.servlet in tomcat plugin [message #177687] Tue, 22 August 2006 12:11 Go to next message
Eclipse User
Originally posted by: dangeville_n.hotmail.com

I would appreciate if someone could give me an explanation about a problem
that I have when I use org.eclipse.tomcat in my code.

I have created a class that extends javax.servlet.http.HttpServlet

In my code, I have an error when I call getServletContext(). The error says
that GenericServlet is not accessible due to restriction on required library
org.eclipse.tomcat/servlet.jar

I understand that this is beacause servlet.jar is not in the export packages
of org.eclipse.tomcat, but I don't understand why.

Does someone know why the Tomcat plugin does not let you manipulate the
javax.servlet package ?

I am in Eclipse 3.2 and the tomcat plugin version is 4.1.130.v20060601

Thanks a lot

Nicolas
Re: javax.servlet in tomcat plugin [message #177836 is a reply to message #177687] Thu, 24 August 2006 16:30 Go to previous message
Larry Isaacs is currently offline Larry Isaacs
Messages: 1305
Registered: July 2009
Senior Member
The org.eclipse.tomcat plug-in isn't the "Tomcat plug-in" as it relates
to WTP. It is the internal server (Tomcat 4.1.30) that Eclipse uses for
its "help" system. The Tomcat plug-ins are actually
org.eclipse.jst.server.tomcat.core and org.eclipse.jst.server.tomcat.ui.
The Dynamic Web Project supported by WTP can be associated with a Target
Runtime (for Tomcat and other servers) that gives you access to the
javax.servlet classes.

Cheers,
Larry


Nicolas Dangeville wrote:
> I would appreciate if someone could give me an explanation about a problem
> that I have when I use org.eclipse.tomcat in my code.
>
> I have created a class that extends javax.servlet.http.HttpServlet
>
> In my code, I have an error when I call getServletContext(). The error says
> that GenericServlet is not accessible due to restriction on required library
> org.eclipse.tomcat/servlet.jar
>
> I understand that this is beacause servlet.jar is not in the export packages
> of org.eclipse.tomcat, but I don't understand why.
>
> Does someone know why the Tomcat plugin does not let you manipulate the
> javax.servlet package ?
>
> I am in Eclipse 3.2 and the tomcat plugin version is 4.1.130.v20060601
>
> Thanks a lot
>
> Nicolas
>
>
Previous Topic:Jetty server support
Next Topic:Unable to open any non-Eclipse generated WSDLs
Goto Forum:
  


Current Time: Thu Aug 21 19:58:15 EDT 2014

Powered by FUDForum. Page generated in 0.10612 seconds