Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » Tomcat, deploys to system temp directory
Tomcat, deploys to system temp directory [message #173142] Wed, 05 July 2006 15:55 Go to next message
Eclipse User
Originally posted by: tobias.domain.hidden.com

Hi,

My application gets deployed to both
..metadata\.plugins\org.eclipse.wst.server.core\tmp0\
and
C:/DOCUME~1/Tobias/LOCALS~1/Temp/0-

The problem is that tomcat serves content from
C:/DOCUME~1/Tobias/LOCALS~1/Temp/0- while WTP updates changes to
..metadata\.plugins\org.eclipse.wst.server.core\tmp0\

I can't find a reference to C:/DOCUME~1 in any files within eclipse or
the workspace. I've reinstalled both Tomcat and Eclipse with a fresh
workspace, the same problem occurs every time. My project has worked
just fine under WTP0.7 and it appears to have been converted to a WTP1.5
project correctly.

Any tips on how to prevent this?

I'm running eclipse 3.2 WTP 1.5 Tomcat 5.5.17 on Windows XP.
Re: Tomcat, deploys to system temp directory [message #173157 is a reply to message #173142] Wed, 05 July 2006 16:25 Go to previous messageGo to next message
Eclipse User
Originally posted by: tobias.domain.hidden.com

Tobias Mattsson wrote:
> Hi,
>
> My application gets deployed to both
> .metadata\.plugins\org.eclipse.wst.server.core\tmp0\
> and
> C:/DOCUME~1/Tobias/LOCALS~1/Temp/0-
>
> The problem is that tomcat serves content from
> C:/DOCUME~1/Tobias/LOCALS~1/Temp/0- while WTP updates changes to
> .metadata\.plugins\org.eclipse.wst.server.core\tmp0\
>
> I can't find a reference to C:/DOCUME~1 in any files within eclipse or
> the workspace. I've reinstalled both Tomcat and Eclipse with a fresh
> workspace, the same problem occurs every time. My project has worked
> just fine under WTP0.7 and it appears to have been converted to a WTP1.5
> project correctly.
>
> Any tips on how to prevent this?
>
> I'm running eclipse 3.2 WTP 1.5 Tomcat 5.5.17 on Windows XP.

After removing these attributes from my context.xml it deployed
correctly again.

<Context
antiResourceLocking="true"
antiJARLocking="true"
debug="1"
>

I'm still interested to know what caused it. Assuming it's some kind of
locking issue that causes WTP to use a fallback route could it be
possible to have WTP tell me this?
Re: Tomcat, deploys to system temp directory [message #173172 is a reply to message #173142] Wed, 05 July 2006 16:54 Go to previous message
Larry Isaacs is currently offline Larry Isaacs
Messages: 1305
Registered: July 2009
Senior Member
With the Tomcat server stopped, add a new "dummy" file to the
application. With the server still stopped, select the Tomcat server in
the Servers view and then click the "Publish to the server" icon in that
view (the rightmost icon). You should see the new file appear under
".metadata\...". Does it also appear under "C:/DOCUME~1/..." as well?
I'm not aware of any reason it should. If not, try starting Tomcat to
see if it is responsible for making the copy under "C:/DOCUME~1/...".

Cheers,
Larry

Tobias Mattsson wrote:
> Hi,
>
> My application gets deployed to both
> .metadata\.plugins\org.eclipse.wst.server.core\tmp0\
> and
> C:/DOCUME~1/Tobias/LOCALS~1/Temp/0-
>
> The problem is that tomcat serves content from
> C:/DOCUME~1/Tobias/LOCALS~1/Temp/0- while WTP updates changes to
> .metadata\.plugins\org.eclipse.wst.server.core\tmp0\
>
> I can't find a reference to C:/DOCUME~1 in any files within eclipse or
> the workspace. I've reinstalled both Tomcat and Eclipse with a fresh
> workspace, the same problem occurs every time. My project has worked
> just fine under WTP0.7 and it appears to have been converted to a WTP1.5
> project correctly.
>
> Any tips on how to prevent this?
>
> I'm running eclipse 3.2 WTP 1.5 Tomcat 5.5.17 on Windows XP.
Previous Topic:Reference to eMessage in eInput is getting lost
Next Topic:What happened to .deployables ????
Goto Forum:
  


Current Time: Thu Sep 18 22:04:29 GMT 2014

Powered by FUDForum. Page generated in 0.01923 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software