Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » AMP » Problem Occurring While Installation of AMP(Installation Problem)
Problem Occurring While Installation of AMP [message #1130362] Wed, 09 October 2013 09:34 Go to next message
Jayant Rajpurohit is currently offline Jayant Rajpurohit
Messages: 6
Registered: October 2013
Junior Member
Hi,

The Error log reads that the << org.eclipse.amalgam.discovery.ui >> plug in is not there.

Attached are the two screenshots.

Please Advice.

Here is the text of the error log -

org.eclipse.core.runtime.CoreException: Operation details
at org.eclipse.amalgam.discovery.ui.common.internal.PrepareInstallProfileJob.resolve(PrepareInstallProfileJob.java:135)
at org.eclipse.amalgam.discovery.ui.common.internal.PrepareInstallProfileJob.run(PrepareInstallProfileJob.java:98)
at org.eclipse.jface.operation.ModalContext$ModalContextThread.run(ModalContext.java:121)
Contains: Cannot complete the install because one or more required items could not be found.
Contains: Software being installed: AMP All-In-One SDK (Incubation) [w/o AGF3D] 0.9.0.v20110610-0008 (org.eclipse.amp.all.feature.group 0.9.0.v20110610-0008)
Contains: Missing requirement: Agent Graphics Framework Chart (Incubation) 0.9.0.v20110610-0008 (org.eclipse.amp.agf.chart 0.9.0.v20110610-0008) requires 'bundle org.eclipse.birt.chart.ui [3.7.0.v20110331,4.0.0)' but it could not be found
Contains: Cannot satisfy dependency:
Contains: From: AMP AGF Chart (Incubation) 0.9.0.v20110610-0008 (org.eclipse.amp.agf.chart.feature.group 0.9.0.v20110610-0008)
Contains: To: org.eclipse.amp.agf.chart [0.9.0.v20110610-0008]
Contains: Cannot satisfy dependency:
Contains: From: AMP All-In-One SDK (Incubation) [w/o AGF3D] 0.9.0.v20110610-0008 (org.eclipse.amp.all.feature.group 0.9.0.v20110610-0008)
Contains: To: org.eclipse.amp.agf.chart.feature.group [0.9.0.v20110610-0008]
Re: Problem Occurring While Installation of AMP [message #1131144 is a reply to message #1130362] Thu, 10 October 2013 04:34 Go to previous messageGo to next message
Jayant Rajpurohit is currently offline Jayant Rajpurohit
Messages: 6
Registered: October 2013
Junior Member
Hi,

If someone could at least give some opinion or direction of how to get this resolved.

Thanks again !!
Re: Problem Occurring While Installation of AMP [message #1131370 is a reply to message #1131144] Thu, 10 October 2013 09:10 Go to previous messageGo to next message
Jayant Rajpurohit is currently offline Jayant Rajpurohit
Messages: 6
Registered: October 2013
Junior Member
Is this because ... i have not downloaded the eclipse (incubation version) ? ... because that version of Eclipse Modeeling tools incubation version is not present in the list of softwares ...

Please suggest a solution ..
Re: Problem Occurring While Installation of AMP [message #1133187 is a reply to message #1131370] Fri, 11 October 2013 13:21 Go to previous messageGo to next message
Miles Parker is currently offline Miles Parker
Messages: 1338
Registered: July 2009
Senior Member
Hi Jayant,

Please try installing BIRT first from the following update site:

http://download.eclipse.org/birt/update-site/3.7

BIRT has been a real trouble maker with respect to dependencies.

I'll try to take a look at this in more detail this weekend.

cheers,

Miles
Re: Problem Occurring While Installation of AMP [message #1142001 is a reply to message #1133187] Thu, 17 October 2013 06:29 Go to previous messageGo to next message
Francesco Farina is currently offline Francesco Farina
Messages: 4
Registered: September 2013
Junior Member
Hi Jayant,
I'm working on AMP for academic purpose and I made a guide to have it running on Eclipse Kepler. You can find it here: dropbox.com/s/ze5zkl3712oz6cu/AMPBuildFromSourceGuide.pdf
I'd be glad if you and the AMP community would try it out and send me feedbacks about it.

The guide has been tested by me and my collaborator lot of times and it worked.
The only buggy things are the moving camera and the agent selection in the 3D view.
Sometimes happens that the "Execute... with 3D visualization" starts only if you have already run (and stopped) the model with 2D visualization. Rolling Eyes

If you have any questions, send me an email at mail.amff@gmail.com , I'm pleased to answer.

I hope this will be helpful for you. Smile

Edit: the guide has been updated for Eclipse Luna 4.4 M2.
Edit 2: the link has been updated.

Cheers,
Francesco Farina

[Updated on: Fri, 09 May 2014 12:31]

Report message to a moderator

Re: Problem Occurring While Installation of AMP [message #1142422 is a reply to message #1130362] Thu, 17 October 2013 12:10 Go to previous message
Miles Parker is currently offline Miles Parker
Messages: 1338
Registered: July 2009
Senior Member
Wow, thanks Fransesco! Yes, the build is really troublesome. We need to move it over to Tycho, but I have been involved in a number of other projects and haven't had the time to make that move.

I've noticed that same behaviour w/ GEF3D. Very odd, but something to do with registering the graphics. I think there may be an open bug on it.
Previous Topic:Keybinding conflicts ALT+SHIFT+L
Next Topic:Target Platforms Extensions and Eclipse compatibility issues
Goto Forum:
  


Current Time: Sat Jul 26 01:28:33 EDT 2014

Powered by FUDForum. Page generated in 0.02176 seconds