Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Voicetools » Call to deployed openVXML app failing
Call to deployed openVXML app failing [message #15809] Wed, 23 August 2006 19:25 Go to next message
Stan Rivera is currently offline Stan Rivera
Messages: 36
Registered: July 2009
Member
I have created a simple "hello world" openVXML app, deployed the VXML web
application on my weblogic app server successfully. Actually, I am seeing
one error when I first try to export the application. I select export,
then VXML Web App, then I click on "Next>", but I get a dialog box that
says "An error has occurred. See error log for more details.". I click
"Ok" and I'm then asked to enter the name of the WAR file. Don't know of
this is the root cause of my problem below, but thought I'd better mention
it. So, when calling up the application I've deployed on my weblogic app
server, http://<host>/FirstOpenVXMLApp/openVXML, I get the following
traces:

getResourceItem::/WEB-INF/openVXML/application/::true
<Aug 23, 2006 4:43:19 PM MDT> <Error> <HTTP> <BEA-101046>
< [ServletContext(id=1861120,name=FirstOpenVXMLApp,context-pat h=/FirstOpenVXMLApp)]
Failed to process call: null
java.lang.NullPointerException
at
org.eclipse.vtp.framework.kernel.core.DefaultApplicationMana ger.getApplication(DefaultApplicationManager.java:71)
at
org.eclipse.vtp.framework.kernel.core.DefaultCallManager.ini tializeCall(DefaultCallManager.java:135)
at
org.eclipse.vtp.framework.kernel.http.HTTPConnector.service( HTTPConnector.java:139)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:853)
at
weblogic.servlet.internal.ServletStubImpl$ServletInvocationA ction.run(ServletStubImpl.java:996)
at
weblogic.servlet.internal.ServletStubImpl.invokeServlet(Serv letStubImpl.java:419)
at
weblogic.servlet.internal.ServletStubImpl.invokeServlet(Serv letStubImpl.java:315)
at
weblogic.servlet.internal.WebAppServletContext$ServletInvoca tionAction.run(WebAppServletContext.java:6452)
at
weblogic.security.acl.internal.AuthenticatedSubject.doAs(Aut henticatedSubject.java:321)
at
weblogic.security.service.SecurityManager.runAs(SecurityMana ger.java:
118)
at
weblogic.servlet.internal.WebAppServletContext.invokeServlet (WebAppServletContext.java:3661)
at
weblogic.servlet.internal.ServletRequestImpl.execute(Servlet RequestImpl.java:2630)
at weblogic.kernel.ExecuteThread.execute(ExecuteThread.java:219 )
at weblogic.kernel.ExecuteThread.run(ExecuteThread.java:178)
>
<Aug 23, 2006 4:43:19 PM MDT> <Error> <HTTP> <BEA-101020>
< [ServletContext(id=1861120,name=FirstOpenVXMLApp,context-pat h=/FirstOpenVXMLApp)]
Servlet failed with Exception
java.lang.NullPointerException
at
weblogic.servlet.internal.ServletResponseImpl.sendError(Serv letResponseImpl.java:422)
at
org.eclipse.vtp.framework.kernel.http.HTTPConnector.service( HTTPConnector.java:150)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:853)
at
weblogic.servlet.internal.ServletStubImpl$ServletInvocationA ction.run
(ServletStubImpl.java:996)
at
weblogic.servlet.internal.ServletStubImpl.invokeServlet(Serv letStubImpl.java:419)
at
weblogic.servlet.internal.ServletStubImpl.invokeServlet(Serv letStubImpl.java:315)
at
weblogic.servlet.internal.WebAppServletContext$ServletInvoca tionAction.run(WebAppServletContext.java:6452)
at
weblogic.security.acl.internal.AuthenticatedSubject.doAs(Aut henticatedSubject.java:321)
at
weblogic.security.service.SecurityManager.runAs(SecurityMana ger.java:118)
at
weblogic.servlet.internal.WebAppServletContext.invokeServlet (WebAppServletContext.java:3661)
at
weblogic.servlet.internal.ServletRequestImpl.execute(Servlet RequestImpl.java:2630)
at weblogic.kernel.ExecuteThread.execute(ExecuteThread.java:219 )
at weblogic.kernel.ExecuteThread.run(ExecuteThread.java:178)

Thanks,
Stan
Re: Call to deployed openVXML app failing [message #15884 is a reply to message #15809] Thu, 24 August 2006 17:19 Go to previous message
Lonnie Pryor is currently offline Lonnie Pryor
Messages: 10
Registered: July 2009
Junior Member
Hi Stan,

I think don't think the error you are getting while exporting is the
root of the problem. The NullPointerException is occurring because the
runtime cannot find a folder in the WAR file at the path
"/WEB-INF/openVXML/application/". Is this folder present in the exported
WAR? If not, there is a bug in the export process introduced when
migrating to Eclipse 3.2. If the folder is present it may be a problem
running under WebLogic (which we have not tested under).

I have a theory: this exception will occur if WebLogic returns null when
calling ServletContext.getResource(String) with a path that points to a
directory. If this is the case then we can open a bug report and get
this fixed in CVS.

If you open a bug report on this problem and attach the exported WAR
file we can verify the above assumptions.

Thanks for your time,
Lonnie

--
Lonnie Pryor

OpenMethods

4741 Central Street | Suite 285 | Kansas City , MO | 64112-1533

o | +1.816.283.VXML (8965) x111 f | +1.816.817.0643

lonnie@openmethods.com | www.openmethods.com
Re: Call to deployed openVXML app failing [message #575367 is a reply to message #15809] Thu, 24 August 2006 17:19 Go to previous message
Lonnie Pryor is currently offline Lonnie Pryor
Messages: 10
Registered: July 2009
Junior Member
Hi Stan,

I think don't think the error you are getting while exporting is the
root of the problem. The NullPointerException is occurring because the
runtime cannot find a folder in the WAR file at the path
"/WEB-INF/openVXML/application/". Is this folder present in the exported
WAR? If not, there is a bug in the export process introduced when
migrating to Eclipse 3.2. If the folder is present it may be a problem
running under WebLogic (which we have not tested under).

I have a theory: this exception will occur if WebLogic returns null when
calling ServletContext.getResource(String) with a path that points to a
directory. If this is the case then we can open a bug report and get
this fixed in CVS.

If you open a bug report on this problem and attach the exported WAR
file we can verify the above assumptions.

Thanks for your time,
Lonnie

--
Lonnie Pryor

OpenMethods

4741 Central Street | Suite 285 | Kansas City , MO | 64112-1533

o | +1.816.283.VXML (8965) x111 f | +1.816.817.0643

lonnie@openmethods.com | www.openmethods.com
Previous Topic:CVS Repository checkout error
Next Topic:Deploying VTP updates - but need a little direction
Goto Forum:
  


Current Time: Thu Aug 21 06:25:09 EDT 2014

Powered by FUDForum. Page generated in 0.01633 seconds