Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Debuger, cannot connect to VM(Debuger, cannot connect to VM)
Debuger, cannot connect to VM [message #1105833] Tue, 10 September 2013 06:34 Go to next message
andjela zizic is currently offline andjela zizic
Messages: 2
Registered: September 2013
Junior Member
I installed on my machine :

win 7 64 bit
eclips standard 64 bit
jdk-6u26-windows-x64


When I debug java program with command Debuger As > Java Application,
I got next message : Cannot connect to VM.

error log show next exception :

com.sun.jdi.connect.TransportTimeoutException
at org.eclipse.jdi.internal.connect.SocketTransportService.accept(SocketTransportService.java:105)
at org.eclipse.jdi.internal.connect.SocketTransportImpl.accept(SocketTransportImpl.java:59)
at org.eclipse.jdi.internal.connect.SocketListeningConnectorImpl.accept(SocketListeningConnectorImpl.java:153)
at org.eclipse.jdt.internal.launching.StandardVMDebugger$ConnectRunnable.run(StandardVMDebugger.java:110)
at java.lang.Thread.run(Unknown Source)



I do not know what is the proble.

Firewall on my machina is turn off.
Host file has line 127.0.0.1 localhost without '#' at the begining.
I used jdk6 like java library in project and : C:\Program Files\Java\jdk1.6.0_26\bin\java.exe file like VM.

Thanks for help

Angela









Re: Debuger, cannot connect to VM [message #1111098 is a reply to message #1105833] Tue, 17 September 2013 15:45 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin Dahyabhai
Messages: 2237
Registered: July 2009
Senior Member
How sure are you about those firewall settings?

---
Nitin Dahyabhai
Eclipse WTP, IBM
Re: Debuger, cannot connect to VM [message #1111609 is a reply to message #1111098] Wed, 18 September 2013 09:02 Go to previous message
andjela zizic is currently offline andjela zizic
Messages: 2
Registered: September 2013
Junior Member
I solved the problem .

I have instaled Fsecutre program. It is slowed my computer.

After turn off some Fsecure service .

All iz ok.

Thanks

Andjela

Previous Topic:Table under a table in eclipse plugins
Next Topic:Eclipse with Javascript - projects with existing code
Goto Forum:
  


Current Time: Thu Jul 31 01:36:57 EDT 2014

Powered by FUDForum. Page generated in 0.03433 seconds