Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » Java Development Tools (JDT) » Eclipse Missing 20 Jar's??(Im Am having an error saying that its missing required jars)
Eclipse Missing 20 Jar's?? [message #1099304] Sun, 01 September 2013 13:17 Go to next message
Morgan Gallant is currently offline Morgan GallantFriend
Messages: 4
Registered: August 2013
Junior Member
Hello,

I have recently set up eclipse and I keep getting 22 errors:

Description Resource Path Location Type
Project 'Client' is missing required library: 'jars/libraries/com/google/code/gson/gson/2.2.2/gson-2.2.2.jar' Client Build path Build Path Problem
Project 'Client' is missing required library: 'jars/libraries/argo/argo/2.25_fixed/argo-2.25_fixed.jar' Client Build path Build Path Problem
The project cannot be built until build path errors are resolved Server Unknown Java Problem
The project cannot be built until build path errors are resolved Client Unknown Java Problem
Project 'Client' is missing required library: 'jars/versions/1.6.2/1.6.2.jar' Client Build path Build Path Problem
Project 'Client' is missing required library: 'jars/libraries/org/bouncycastle/bcprov-jdk15on/1.47/bcprov-jdk15on-1.47.jar' Client Build path Build Path Problem
Project 'Client' is missing required library: 'jars/libraries/org/lwjgl/lwjgl/lwjgl-platform/2.9.0/lwjgl-platform-2.9.0-natives-windows.jar' Client Build path Build Path Problem
Project 'Client' is missing required library: 'jars/libraries/org/lwjgl/lwjgl/lwjgl_util/2.9.0/lwjgl_util-2.9.0.jar' Client Build path Build Path Problem
Project 'Client' is missing required library: 'jars/libraries/org/lwjgl/lwjgl/lwjgl/2.9.0/lwjgl-2.9.0.jar' Client Build path Build Path Problem
Project 'Server' is missing required library: 'jars/minecraft_server.1.6.2.jar' Server Build path Build Path Problem
Project 'Client' is missing required library: 'jars/libraries/net/java/jinput/jinput-platform/2.0.5/jinput-platform-2.0.5-natives-windows.jar' Client Build path Build Path Problem
Project 'Client' is missing required library: 'jars/libraries/net/java/jutils/jutils/1.0.0/jutils-1.0.0.jar' Client Build path Build Path Problem
Project 'Client' is missing required library: 'jars/libraries/net/sf/jopt-simple/jopt-simple/4.5/jopt-simple-4.5.jar' Client Build path Build Path Problem
Project 'Client' is missing required library: 'jars/libraries/org/apache/commons/commons-lang3/3.1/commons-lang3-3.1.jar' Client Build path Build Path Problem
Project 'Client' is missing required library: 'jars/libraries/com/paulscode/librarylwjglopenal/20100824/librarylwjglopenal-20100824.jar' Client Build path Build Path Problem
Project 'Client' is missing required library: 'jars/libraries/com/paulscode/soundsystem/20120107/soundsystem-20120107.jar' Client Build path Build Path Problem
Project 'Client' is missing required library: 'jars/libraries/commons-io/commons-io/2.4/commons-io-2.4.jar' Client Build path Build Path Problem
Project 'Client' is missing required library: 'jars/libraries/net/java/jinput/jinput/2.0.5/jinput-2.0.5.jar' Client
Project 'Client' is missing required library: 'jars/libraries/com/google/guava/guava/14.0/guava-14.0.jar' Client Build path Build Path Problem
Project 'Client' is missing required library: 'jars/libraries/com/paulscode/codecjorbis/20101023/codecjorbis-20101023.jar' Client Build path Build Path Problem
Project 'Client' is missing required library: 'jars/libraries/com/paulscode/codecwav/20101023/codecwav-20101023.jar' Client Build path Build Path Problem
Project 'Client' is missing required library: 'jars/libraries/com/paulscode/libraryjavasound/20101123/libraryjavasound-20101123.jar' Client Build path Build Path Problem

Its something to do with my build path and I don't know how to fix it. Ive tried deleting everything and starting over twice with no success and I need help asap.

Thanks,
Morgan
Re: Eclipse Missing 20 Jar's?? [message #1099424 is a reply to message #1099304] Sun, 01 September 2013 17:52 Go to previous messageGo to next message
Eclipse UserFriend
Are those jar's in your project? it would appear from the message that its expecting to find them in your project I think.

On 9/1/2013 9:17 AM, Morgan Gallant wrote:
> Hello,
>
> I have recently set up eclipse and I keep getting 22 errors:
>
m
>
> Its something to do with my build path and I don't know how to fix it. Ive tried deleting everything and starting over twice with no success and I need help asap.
>
> Thanks,
> Morgan
>
Re: Eclipse Missing 20 Jar's?? [message #1099576 is a reply to message #1099424] Sun, 01 September 2013 23:51 Go to previous messageGo to next message
Morgan Gallant is currently offline Morgan GallantFriend
Messages: 4
Registered: August 2013
Junior Member
Yes They are all in my project,
Re: Eclipse Missing 20 Jar's?? [message #1099587 is a reply to message #1099576] Mon, 02 September 2013 00:19 Go to previous message
Eclipse UserFriend
On 9/1/2013 7:51 PM, Morgan Gallant wrote:
> Yes They are all in my project,
I assume from your error messages and the fact that you say they are their that you must be pulling in a .project and .classpath as part of your
project in the workspace? It might help if you can provide directory structure of what you have and the contents of the .project and .classpath files

Bill
Previous Topic:Problem with Plugins
Next Topic:cvs check out
Goto Forum:
  


Current Time: Fri Nov 28 00:37:29 GMT 2014

Powered by FUDForum. Page generated in 0.01630 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software