Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » SWTBot » wizard and splash logon before an app runs
wizard and splash logon before an app runs [message #15465] Mon, 19 January 2009 16:29 Go to next message
Marc is currently offline Marc
Messages: 32
Registered: July 2009
Member
Hi all,

This post follows one I sent to the old mailing list, but Ketan has gently
redirected me to the rigth place.

I wasn't able to run swtbot on my app while it was running well on rcpmail
example.
Before the "heart" of my app runs, there is first some configuration
wizard to fill and then a login/password splash screen.

1)
[extract]
org.eclipse.jface.wizard.WizardDialog
WizardDialog dialog = new CustomWizardDialog(null, theWizard);
dialog.open();

In another thread "can SWTBot 2.0 test a wizard?" on this ML, it seems a
wizard can be tested.
But swtbot does not run when the wizard is opened.
May it be a problem that the wizard is launched before anything else in my
app?


2)splash
import org.eclipse.ui.splash.AbstractSplashHandler;
public class SplashHandler extends AbstractSplashHandler

splashHandler is set as an extension for the app
(http://pookzilla.net/wp/2007/01/i-want-to-tell-you-story-i/),
not called from code.


I modified the source code to skip the wizard.
Now, if I launch my app through swtbot...
the splash login popup will not display (?), but my app's main screen
shows up and swtbot is running!
The splashHandler seems not loaded when the app is called from swtbot.
Does it have to do with swtbot?


Thanks for your time,
Marc
Re: wizard and splash logon before an app runs [message #987526 is a reply to message #15465] Mon, 26 November 2012 23:56 Go to previous message
Alexia Allanic is currently offline Alexia Allanic
Messages: 2
Registered: July 2009
Junior Member
Hi,
Did you get an answer to this issue?
Previous Topic:Can't find TitleAreaDialog
Next Topic:Eclipse Juno Reporting
Goto Forum:
  


Current Time: Fri Oct 24 13:45:59 GMT 2014

Powered by FUDForum. Page generated in 0.01449 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software