Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Remote Application Platform (RAP) » Bundles Problem in RAP(Bundles Problem in RAP)
Bundles Problem in RAP [message #1077450] Thu, 01 August 2013 18:23 Go to next message
mu xin is currently offline mu xinFriend
Messages: 4
Registered: July 2013
Junior Member

I want to use the Bundle org.eclipse.ui in RAP Application, and i know that in RAP we use org.eclipse.rap.ui instead of org.eclipse.ui, but i want to use the interface org.eclipse.ui.INewWizard in org.elcipse.ui.

The problem is, if i add the Bundle org.eclipse.ui(option) in "Dependencies" like picture 1, i must do this (Run -> Run Configurations -> Bundles -> Add Required Bundles), because org.eclipse.ui need another Bundles. Then, if i click "Run", there are a lot of conflicts between Bundles like picture 2.

Who can tell me, what is the problem?

Re: Bundles Problem in RAP [message #1078595 is a reply to message #1077450] Sat, 03 August 2013 08:01 Go to previous message
Ralf Sternberg is currently offline Ralf SternbergFriend
Messages: 1309
Registered: July 2009
Senior Member

It seems that you try to run some IDE-bundles like
org.eclipse.core.resources with RAP. Unfortunately, this is currently
not supported.

If you included these bundles by accident, there's a list of the
required bundles in the developer's guide [1] together with some



Ralf Sternberg

Twitter: @EclipseRAP

Professional services for RAP and RCP?
Previous Topic:RWT Standalone and EJB access
Next Topic:Google vizualization
Goto Forum:

Current Time: Tue Oct 06 08:16:28 GMT 2015

Powered by FUDForum. Page generated in 0.10420 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software