Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » GMF (Graphical Modeling Framework) » Invisible Phantom Nodes(Phantom nodes aren't displaying in my GMF diagram)
Invisible Phantom Nodes [message #1070445] Wed, 17 July 2013 21:26 Go to next message
Phillip Drew is currently offline Phillip Drew
Messages: 68
Registered: October 2012
Member
Basically I'm trying to use phantom nodes to visualize the following (simplified) model

A Diagram contains 0...* Tiles
Each Tile contains 0...* Tiles

The Diagram is the GMF diagram element. The containment of the 'sub-tiles' should be represented by phantom nodes not spatial containment.

(I've attached the Emfatic file which describes the model and which is being used with Eugenia to generate the GMF diagram).

I can create tiles in my diagram editor fine however as soon as I associate a tile as a subtile it disappears. The subtile containment is accurately reflected in the underlying EMF model file though. Similarly only the top level tiles are displayed when I load a model containing subtiles.

I'm not sure if this is because of GMF or Eugenia.

Any help would be appreciated

Thanks
  • Attachment: My.emf
    (Size: 0.34KB, Downloaded 22 times)
Re: Invisible Phantom Nodes [message #1071983 is a reply to message #1070445] Sun, 21 July 2013 16:04 Go to previous messageGo to next message
Manuel Hegner is currently offline Manuel Hegner
Messages: 4
Registered: April 2013
Junior Member
I have the exact same problem. It seems liken there is a problem if the phantom node describes a tree structure. I attached all the file (ecore+gmf) I used in my example. How can I fix this?
Re: Invisible Phantom Nodes [message #1072156 is a reply to message #1071983] Mon, 22 July 2013 03:45 Go to previous message
Ralph Gerbig is currently offline Ralph Gerbig
Messages: 695
Registered: November 2009
Senior Member
Hi,

if can you please submit a bug on this. https://bugs.eclipse.org/bugs/ The project is GMF Tooling and the component should be Code Generation.

Ralph
Previous Topic:Creating metamodel object instances without graphical view
Next Topic:SETTING-UP the EDITOR Models by code
Goto Forum:
  


Current Time: Sun Apr 20 02:54:24 EDT 2014

Powered by FUDForum. Page generated in 0.03488 seconds