Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » BIRT » 2.6.2 report failures with BIRT 4.3
2.6.2 report failures with BIRT 4.3 [message #1066156] Mon, 01 July 2013 09:55 Go to next message
Colin Sutton is currently offline Colin Sutton
Messages: 69
Registered: July 2009
Member
I installed the 4.3 all-in-one release on windows xp and windows 7, and
have the same problem on both with reports developed using BIRT 2.6.2: they
work Ok via the 'run' action when run directly, but when called from a
hyperlink in another report, or when run via the 'preview' action, the
parameters, which are used to filter tables, seem to be corrupted.
No errors are shown, but the report tables are showing content that should
be filtered.
The same report files work perfectly ok with v2.6.2 - the rptdesign is not
changed after opening it with 4.3 and saving.
Is there any documentation on the changes in v4.3 that might help?

--
Colin Sutton
Re: 2.6.2 report failures with BIRT 4.3 [message #1066620 is a reply to message #1066156] Wed, 03 July 2013 13:29 Go to previous messageGo to next message
Colin Sutton is currently offline Colin Sutton
Messages: 69
Registered: July 2009
Member
I have raised this with further detail as
https://bugs.eclipse.org/bugs/show_bug.cgi?id=412152
--
Colin
Re: 2.6.2 report failures with BIRT 4.3 [message #1067055 is a reply to message #1066620] Fri, 05 July 2013 15:36 Go to previous messageGo to next message
Michael Williams is currently offline Michael Williams
Messages: 1639
Registered: July 2009
Senior Member

Can you recreate this with the sample database? As in, create a report in 2.6.2 with the sample db that when ran in 4.3 you see no error but it shows improperly? This way I can see exactly what you're talking about. Thanks!

Michael

Add interactivity, scheduling, sharing, live Excel export, and JS integration to your BIRT app with the new, free BIRT server, BIRT iHub F-Type.
Re: 2.6.2 report failures with BIRT 4.3 [message #1067119 is a reply to message #1066620] Sat, 06 July 2013 00:38 Go to previous messageGo to next message
Colin Sutton is currently offline Colin Sutton
Messages: 69
Registered: July 2009
Member
I have attached (in bugzilla) a report that I created with 4.3 based on the
sample database that shows that the problem is not only with reports
created with older versions of BIRT.

Colin <colin_sutton@xxxxxxxx> wrote:
> I have raised this with further detail as
> https://bugs.eclipse.org/bugs/show_bug.cgi?id=412152
Re: 2.6.2 report failures with BIRT 4.3 [message #1068278 is a reply to message #1067119] Fri, 12 July 2013 21:46 Go to previous messageGo to next message
Michael Williams is currently offline Michael Williams
Messages: 1639
Registered: July 2009
Senior Member

If you set a default value for the parameter, the preview of the report shows the correct value. It seems to only happen if you leave the default value setting blank.

Michael

Add interactivity, scheduling, sharing, live Excel export, and JS integration to your BIRT app with the new, free BIRT server, BIRT iHub F-Type.
Re: 2.6.2 report failure s with BIRT 4.3 [message #1068808 is a reply to message #1068278] Sun, 14 July 2013 12:29 Go to previous messageGo to next message
Colin Sutton is currently offline Colin Sutton
Messages: 69
Registered: July 2009
Member
Thanks, Michael,
I have updated bug 412152 with the work-around.

--
Colin Sutton
Re: 2.6.2 report failure s with BIRT 4.3 [message #1071239 is a reply to message #1068808] Fri, 19 July 2013 16:18 Go to previous message
Michael Williams is currently offline Michael Williams
Messages: 1639
Registered: July 2009
Senior Member

Great! Thanks for updating it!

Michael

Add interactivity, scheduling, sharing, live Excel export, and JS integration to your BIRT app with the new, free BIRT server, BIRT iHub F-Type.
Previous Topic:Text with script not working in frameset but working in preview mode
Next Topic:Can't upgrade to BIRT Runtime 4.3
Goto Forum:
  


Current Time: Thu Oct 23 03:59:04 GMT 2014

Powered by FUDForum. Page generated in 0.01812 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software