Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Not able to install M2E - Tycho Configurator in Eclipse Helios
Not able to install M2E - Tycho Configurator in Eclipse Helios [message #1065761] Thu, 27 June 2013 08:18 Go to next message
luis vargas is currently offline luis vargas
Messages: 3
Registered: June 2013
Junior Member
Hi all,

Currently I'm working on a project that requires the use of m2eclipse and additionally tycho. The project was done using Rational Application Developer(RAD 8.0.4) that is based on Eclipse Helios (3.6.0) ... [upgrade in the moment to a newer version is not possible]

When installing m2eclipse everything is fine, I installed the version 1.4.0...

After building the projects some poms are affected to an issue that could be solved installing Tycho Configurator 0.6.0. (I say "it could be solved" because I already fixed this in Eclipse Juno). But when I try to install in my RAD it throws the following error:
Operation details
Cannot complete the install because one or more required items could not be found.
Software being installed: Tycho Project Configurators 0.6.0.201207302152 (org.sonatype.tycho.m2e.feature.feature.group 0.6.0.201207302152)
Missing requirement: Tycho Project Configurators 0.6.0.201207302152 (org.sonatype.tycho.m2e 0.6.0.201207302152) requires 'bundle org.eclipse.debug.core 3.7.0' but it could not be found


After investigating in several pages and "googling" for more than 2 days, I dediced to download the plugins from the site and explored a little bit the files, I found that the restrictions for the plugin are set to use the bundle from 3.7.0... but strangely at the same time there is another bundle: org.eclipse.pde.core which uses 3.6.0.

Does somebody know if using org.eclipse.debug.core 3.6.0 could bring some kind of issues? I already made the changes and installed... but if there was another version probably was for something, right?... OR ... this might be an issue that should be reported?

Thanks in advance for any help or suggestion,


Luis
Re: Not able to install M2E - Tycho Configurator in Eclipse Helios [message #1154884 is a reply to message #1065761] Fri, 25 October 2013 10:28 Go to previous messageGo to next message
Dominic Veit is currently offline Dominic Veit
Messages: 1
Registered: October 2013
Junior Member
Hi, I am also searching for a solution to this problem. Did you ever figure anything out? I think we need to go to sonatype for help, but I saw your post here.
Re: Not able to install M2E - Tycho Configurator in Eclipse Helios [message #1159510 is a reply to message #1154884] Mon, 28 October 2013 11:40 Go to previous message
luis vargas is currently offline luis vargas
Messages: 3
Registered: June 2013
Junior Member
Hi, well yes I found an "ugly" solution. I downloaded the .jar files to install Tycho Configurator and modified manually the content.xml file, I changed all the properties that contains the version 3.7.0 to 3.6.0

Did you post something in sonatype? if you find some other way to solve this please let me know.
If you need some help on this solution I can extend this answer too.


Luis
Previous Topic:Eclipse coolbar always aligned to left
Next Topic:Eclipse Report Deployment Error
Goto Forum:
  


Current Time: Sat Aug 30 12:26:44 EDT 2014

Powered by FUDForum. Page generated in 0.04244 seconds