Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Hudson » Hudson Can't Find Snapshot in Nexus
Hudson Can't Find Snapshot in Nexus [message #1065448] Tue, 25 June 2013 14:13 Go to next message
Shelli Orton is currently offline Shelli Orton
Messages: 73
Registered: September 2009
Member
I'm using Hudson 3.0.0 to do Java builds using Maven.

I have a project that builds a client library jar that is used in another project which builds a war. I made some changes to the jar and built a snapshot in Hudson which pushes the artifact to our Nexus repository. When I tried to build a snapshot of the war (with the jar snapshot as a dependency) I got this error:

[ERROR] Failed to execute goal on project Application: Could not resolve dependencies for project my.Application:war:1.13-SNAPSHOT: Could not find artifact my-client:jar:1.9-SNAPSHOT -> [Help 1]

I checked Nexus and the jar is listed in the snapshot repo. When I do a local build of the app, my machine has no issues downloading the snapshot jar and build the war. I did a release build of the jar via Hudson and updated the war project to use this version and Hudson built it without issue.

So, I'm thinking it may be an issue with Hudson, but I can't think what.

And yes, this is one of those cases where "nothing has changed, but now it's not working". Obviously, somethng has changed but I have no idea where to look for it.

Any suggestions would be greatly appreciated.
Re: Hudson Can't Find Snapshot in Nexus [message #1065475 is a reply to message #1065448] Tue, 25 June 2013 17:03 Go to previous messageGo to next message
Shelli Orton is currently offline Shelli Orton
Messages: 73
Registered: September 2009
Member
I've been trying to find any clue as to what the issue is and have scoured every Hudson/Nexus/Maven log I could find looking for something but so far no luck.

I have another Hudson job that builds a war that depends on one of our library jar files that is a snapshot version. This one is also failing to build because it can't find the snapshot dependency (it worked yesterday).

In both war build jobs, "Private repository" was checked true under the "Invoke Maven 3" build step. However, if I uncheck it for this other war job, the snapshot jar is downloaded from Nexus and the build is successful. I deleted the other job and recreated it by copying the one that works without a private repository. However, it's still unable to resolve the snapshot dependency and continues to fail.

I'm convinced that it is an issue with Hudson but have no idea what.

[Updated on: Wed, 26 June 2013 11:24]

Report message to a moderator

Re: Hudson Can't Find Snapshot in Nexus [message #1065649 is a reply to message #1065475] Wed, 26 June 2013 18:46 Go to previous message
Shelli Orton is currently offline Shelli Orton
Messages: 73
Registered: September 2009
Member
I'm still trying to find an answer to this issue and today my project that was working with a snapshot dependency isn't, even without "Private repository" unchecked. Again, I don't know what changed.

However, I believe I have nailed the issue down to the fact that Maven isn't downloading the "maven-metadata.xml" file and therefore can't resolve the dependency to the timestamp version. For example, in my local build, I see this in my Maven output:

Downloading: http://ip:8080/nexus/content/groups/public/com/company/my-client/1.9-SNAPSHOT/maven-metadata.xml
Downloaded: http://ip:8080/nexus/content/groups/public/com/company/my-client/1.9-SNAPSHOT/maven-metadata.xml (1004 B at 20.0 KB/sec)
Downloading: http://ip:8080/nexus/content/groups/public/com/company/my-client/1.9-SNAPSHOT/my-client-1.9-20130625.202822-1.pom
Downloaded: http://ip:8080/nexus/content/groups/public/com/company/my-client/1.9-SNAPSHOT/my-client-1.9-20130625.202822-1.pom (3 KB at 57.5 KB/sec)
...
Downloading: http://ip:8080/nexus/content/groups/public/com/company/my-client/1.9-SNAPSHOT/my-client-1.9-20130625.202822-1.jar
...
Downloaded: http://ip:8080/nexus/content/groups/public/com/company/my-client/1.9-SNAPSHOT/my-client-1.9-20130625.202822-1.jar (10 KB at 153.9 KB/sec)


The Hudson build output looks like this:

[WARNING] The POM for com.company:my-client:jar:1.9-SNAPSHOT is missing, no dependency information available

I am using the bundled Maven. Is there any logs/config I can look at to determine why it's not downloading the metadata.xml file?
Previous Topic:Build Triggers Updated by Hudson/Maven Integration?
Next Topic:No history entries were found for the item and version combination specified.
Goto Forum:
  


Current Time: Mon Jul 28 18:36:34 EDT 2014

Powered by FUDForum. Page generated in 0.02192 seconds