Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Conversion of RCP plugin based to RCP feature based(Missing requirements problems)
Conversion of RCP plugin based to RCP feature based [message #1064071] Mon, 17 June 2013 13:39 Go to next message
Tanguy Mezzano is currently offline Tanguy Mezzano
Messages: 24
Registered: March 2010
Junior Member
Hello,

Our RCP is composed of several plugin projects.
We want now to set up a P2 update site in order to RCP users to remote update their application.
We've created 3 feature projects, each of them contains the related plug-ins projects.
All plugins have for version: 1.0.0.qualifier, but in the Dependencies tab of all of them, we've suppressed the version info from the properties... button.

When we export, we have the following error kind of messages:

 Cannot complete the install because one or more required items could not be found.
 Software being installed: Workshop 1.0.0.201306171115 (MyosotisWorkshop.product 1.0.0.201306171115)
 Missing requirement: JLibWorkshop Plug-in 1.0.0.201306171115 (JLibWorkshop 1.0.0.201306171115) requires 'bundle org.eclipse.ui.console 3.5.0' but it could not be found
 Cannot satisfy dependency:
 Cannot satisfy dependency:


As if the dependencies of the plugins project were not known by the parent feature.

Running the Feature product works, it's the export that causes problems.

Thanks for your help,

Tanguy Mezzano
Re: Conversion of RCP plugin based to RCP feature based [message #1064192 is a reply to message #1064071] Tue, 18 June 2013 08:03 Go to previous messageGo to next message
Tanguy Mezzano is currently offline Tanguy Mezzano
Messages: 24
Registered: March 2010
Junior Member
In fact, the export works for each feature separately but not from the .product file.
Any ideas?

 Missing requirement: JLibToolBox Plug-in 1.0.0.201306180959 (JLibToolBox 1.0.0.201306180959) requires 'bundle org.eclipse.core.filesystem 1.3.200' but it could not be found


Could I merge the independent exports? I guess that the artifacts.jar and content.jar would be wrong.
Re: Conversion of RCP plugin based to RCP feature based [message #1064709 is a reply to message #1064192] Thu, 20 June 2013 15:27 Go to previous message
Tanguy Mezzano is currently offline Tanguy Mezzano
Messages: 24
Registered: March 2010
Junior Member
How come I get different missing requirement error messages each time I try an export?
What should be the RCP version procedure to follow and avoir those errors?

Anybody?

[Updated on: Thu, 20 June 2013 15:28]

Report message to a moderator

Previous Topic:Newbie plugin development question
Next Topic:Problem Unzipping
Goto Forum:
  


Current Time: Wed Oct 22 09:52:12 GMT 2014

Powered by FUDForum. Page generated in 0.04729 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software