Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » EGit » Connot install Egit on Eclipse
icon4.gif  Connot install Egit on Eclipse [message #1058342] Mon, 13 May 2013 11:39 Go to next message
Fouetieu Herman is currently offline Fouetieu Herman
Messages: 1
Registered: May 2013
Junior Member
Hi,
For over a month I try to install EGIT on eclipse but I do not.
In fact I use eclipse-jee-helios-SR2-win32-x86_64 and http://download.eclipse.org/releases/juno source and each time I have the following message:

  Can not install the full Because of a conflicting dependency.
  Being software installed: Eclipse EGIT 2.2.0.201212191850-r (org.eclipse.egit.feature.group 2.2.0.201212191850-r)
  Software Currently installed: Eclipse IDE for Java EE Developers 1.3.2.20110218-0812 (epp.package.jee 1.3.2.20110218-0812)
  Only one of the Following can be installed at once:
    Common Eclipse Runtime 3.6.0.v20100503 (org.eclipse.equinox.common 3.6.0.v20100503)
    Common Eclipse Runtime 3.6.100.v20120522-1841 (org.eclipse.equinox.common 3.6.100.v20120522-1841)
  Can not Satisfy dependency:
    From: Eclipse IDE for Java EE Developers 1.3.2.20110218-0812 (epp.package.jee 1.3.2.20110218-0812)
    To: org.eclipse.epp.package.jee.feature.feature.group [1.3.2.20110218-0812]
  Can not Satisfy dependency:
    From: Core Runtime 3.8.0.v20120521-2346 (org.eclipse.core.runtime 3.8.0.v20120521-2346)
    To: bundle org.eclipse.equinox.common [3.6.100,4.0.0)
  Can not Satisfy dependency:
    From: Core Runtime 3.8.0.v20120912-155025 (org.eclipse.core.runtime 3.8.0.v20120912-155025)
    To: bundle org.eclipse.equinox.common [3.6.100,4.0.0)
  Can not Satisfy dependency:
    From: Eclipse EGIT 2.2.0.201212191850-r (org.eclipse.egit.feature.group 2.2.0.201212191850-r)
    To: org.eclipse.core.runtime [3.7.0,4.0.0)
  Can not Satisfy dependency:
    From: Java EE IDE Feature 1.3.2.20110218-0812 (org.eclipse.epp.package.jee.feature.feature.group 1.3.2.20110218-0812)
    To: org.eclipse.platform.feature.group [3.6.2.r362_v20110210-9gF78Gs1FrIGnHDHWkEcopoN8AmxeZflGDGKQi]
  Can not Satisfy dependency:
    From: Eclipse Platform 3.6.2.r362_v20110210-9gF78Gs1FrIGnHDHWkEcopoN8AmxeZflGDGKQi (org.eclipse.platform.feature.group 3.6.2.r362_v20110210-9gF78Gs1FrIGnHDHWkEcopoN8AmxeZflGDGKQi)
    To: org.eclipse.rcp.feature.group [3.6.2.r362_v20101104-9SAxFMKFkSAqi8axkv1ZjegmiBLY]
  Can not Satisfy dependency:
    From: Eclipse RCP-3.6.2.r362_v20101104 9SAxFMKFkSAqi8axkv1ZjegmiBLY (org.eclipse.rcp.feature.group 3.6.2.r362_v20101104-9SAxFMKFkSAqi8axkv1ZjegmiBLY)
    To: org.eclipse.equinox.common [3.6.0.v20100503]

please help for the correct version of eclipse JEE to use.

Thank!
Re: Connot install Egit on Eclipse [message #1060207 is a reply to message #1058342] Thu, 23 May 2013 10:04 Go to previous message
Stefan Lay is currently offline Stefan Lay
Messages: 338
Registered: July 2009
Senior Member
Hi,

eclipse 3.6 (helios) is not supported for egit 2.2. You can still install egit 2.1. You can find older releases here: http://wiki.eclipse.org/EGit/FAQ#Where_can_I_find_older_releases_of_EGit.3F

Please have a look here: http://wiki.eclipse.org/EGit/FAQ#Retention_Policy

Stefan
Previous Topic:How to get a file from specific commit (JGit)
Next Topic:Merge Tool
Goto Forum:
  


Current Time: Sun Apr 20 12:35:49 EDT 2014

Powered by FUDForum. Page generated in 0.01443 seconds