Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » C / C++ IDE (CDT) » CDT GCC Build Output Parser - paths(worked fine, now went crazy...)
CDT GCC Build Output Parser - paths [message #1053253] Fri, 03 May 2013 07:57 Go to next message
Freddie Chopin is currently offline Freddie Chopin
Messages: 2
Registered: May 2013
Junior Member
Hi!

To make sure that this is not related to some old/wrong setting I've extracted fresh Eclipse (Juno SR2), created new workspace and created new project from scratch.

So I'm configuring a "CDT GCC Build Output Parser" in "Preprocessor Include Paths, Macros etc." as I always did and it always worked fine, but today it just stopped and went crazy...

I have a build output like this:

Compiling file: main.cpp
arm-none-eabi-g++ -c -mcpu=cortex-m4 -mthumb -mfloat-abi=hard -mfpu=fpv4-sp-d16 -ffast-math -O2 -ffunction-sections -fdata-sections -Wall -Wextra -std=gnu++11 -g -ggdb3 -fno-rtti -fno-exceptions -fverbose-asm -Wa,-ahlms=out/main.lst  -DCORE_M4  -DCMSIS_BITPOSITIONS  -MD -MP -MF out/main.d -I.  -IFreeRTOS/include  -IFreeRTOS/portable/GCC/ARM_CM4F  -Iinc main.cpp -o out/main.o


And somehow all the -Irelative_whatever flags are parsed incorrectly now... So the workspace is located at C:\Users\name\workspace and Eclipse thinks the paths are D:\Users\... If I have the workspace on D:\whatever then Eclipse discovers the paths at C:\whatever... Of course the directories on these "other" disk don't exist, so it causes problems with indexer.

If I uncheck "use heuristics to resolve paths" then the paths are kept relative - so instead of <wrong_disk>:\whatever\path\project it's just "project".

And it was working a few days ago without any tricks... I've installed one additional compiler and it added itself to the path, but I've removed it (including the PATH entry) so everything is as it was, yet this still doesn't work as it used to...

If I open a project which has the paths discovered correctly (these are displayed and discovered as relative) and just rebuild it then most of the paths remain intact, but the one related to "-I." is replaced with "<other_disk>:/<workspace_path>/<project>" and is grayed out (it does not exist).

Any ideas?

4\/3!!
Re: CDT GCC Build Output Parser - paths [message #1245785 is a reply to message #1053253] Fri, 14 February 2014 04:08 Go to previous message
Freddie Chopin is currently offline Freddie Chopin
Messages: 2
Registered: May 2013
Junior Member
OK, I still did not manage to solve this issue... I've posted a bug report, but so far nothing happened...

https://bugs.eclipse.org/bugs/show_bug.cgi?id=423199

Maybe there's a better place to post the report? Thx for any help!
Previous Topic:symbols not recognized Xubuntu 13.10
Next Topic:Logging changes into a file after synchronization
Goto Forum:
  


Current Time: Fri Aug 22 03:56:30 EDT 2014

Powered by FUDForum. Page generated in 0.02457 seconds