Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Remote Application Platform (RAP) » Is it RAP still working with Juno 4.2.2(RAP not working anymore)
Is it RAP still working with Juno 4.2.2 [message #1050019] Fri, 26 April 2013 15:30 Go to next message
Christophe Becavin is currently offline Christophe Becavin
Messages: 18
Registered: April 2011
Location: France
Junior Member
Hello,

Am I the only one who cannot make RAP work ?

I am developping an Eclipse RCP/RAP (single sourcing) application since 2 years. I add to install a new version of Eclipse platform yesterday. My RAP software run, the Jetty server too, but I constantly get error:
HTTP ERROR: 404
Problem accessing /rapdemo/rap. Reason: 

    ProxyServlet: /rapdemo/rap

No message in the Console.

I just did the test. I download the last Eclipse, install RAP target platform, add org.eclipse.rap.demo plugin, and launch it through RAP Workbench Demo launch configuration (so basically I perform the RAP Quick tour) ... and 404 ...

The worst is that I get the same problem on my Windows 7 computer and the Mac Book Pro (Mountain Lion). So my question: Does new RAP build actually works ?

Thanks for your help!
Re: Is it RAP still working with Juno 4.2.2 [message #1050062 is a reply to message #1050019] Fri, 26 April 2013 16:40 Go to previous messageGo to next message
Phill Perryman is currently offline Phill Perryman
Messages: 214
Registered: July 2009
Senior Member
It happens to me a lot, just refresh the browser. i think it is because the browser gets there before jetty is fully up and running. Never happens once it is deployed to tomcat.
Re: Is it RAP still working with Juno 4.2.2 [message #1050079 is a reply to message #1050062] Fri, 26 April 2013 17:15 Go to previous messageGo to next message
Cole Markham is currently offline Cole Markham
Messages: 133
Registered: July 2009
Senior Member
Yes, this happens because the RAP tooling launches the browser faster than the RAP application can start and be ready to accept requests. See bug 282756[1].

[1] https://bugs.eclipse.org/bugs/show_bug.cgi?id=282756

Cole
Re: Is it RAP still working with Juno 4.2.2 [message #1051685 is a reply to message #1050019] Mon, 29 April 2013 05:31 Go to previous messageGo to next message
Vikas K is currently offline Vikas K
Messages: 8
Registered: January 2012
Junior Member
Hi Christophe

If you are getting the same error on refresh also, you can try the below things:

From RAP 2.0,
RAP applications can not be accessed by startup parameter anymore:

http://hostname/webapp/rap?startup=example (OBSOLETE)

Instead of this, every entrypoint must have a dedicated path (servlet name):

http://hostname/webapp/example

If you used to register entrypoints by parameter in your extensions, you have to use the attibute path instead:

<extension point="org.eclipse.rap.ui.entrypoint">
<entrypoint id="example.entrypoint"
class="example.MyEntryPoint"
parameter="example"
path="/example" />
</entrypoint>
</extension>

To make an IApplication available at a certain path, you have to create a separate entrypoint extension and specify the id of the application extension in the new parameter applicationId.

<extension point="org.eclipse.rap.ui.entrypoint">
<entrypoint id="example.application.entrypoint"
applicationId="example.application"
path="/example" />
</entrypoint>
</extension>

for more info, check this http://eclipse.org/rap/noteworthy/2.0/migration-guide/

Please let me know if it helps.
Thanks
Vikas

Re: Is it RAP still working with Juno 4.2.2 [message #1051755 is a reply to message #1050019] Mon, 29 April 2013 07:36 Go to previous messageGo to next message
Ralf Sternberg is currently offline Ralf Sternberg
Messages: 1291
Registered: July 2009
Senior Member

Hi Christophe,

are you using the RAP 1.5 tools (shipped with Eclipse 4.2.2) with RAP
2.0 (the latest release)? Unfortunately, these version don't work
together. You need to upgrade the RAP tools from the RAP update site in
order to develop and launch RAP 2.0 applications:

Help > Install new software > http://download.eclipse.org/rt/rap/tools/2.0

HTH, Ralf

--
Ralf Sternberg

Twitter: @EclipseRAP
Blog: http://eclipsesource.com/blogs/

Professional services for RAP and RCP?
http://eclipsesource.com/services/rap/
Re: Is it RAP still working with Juno 4.2.2 [message #1052034 is a reply to message #1051755] Mon, 29 April 2013 14:37 Go to previous message
Christophe Becavin is currently offline Christophe Becavin
Messages: 18
Registered: April 2011
Location: France
Junior Member
Ok perfect! As soon as I put the RAP tools it works! I thought I was already in RAP 2.0, but I was using old RAP 1.5 tools...

Sadly my problem is not totally solved as now I have a reccurent problem:
I install Eclipse, create a new workspace for RAP only application. Use the RAP tutorial. It runs perfectly. Then when I stop Eclipse. I get a crash if I run it again!
Here is the log:

!SESSION 2013-04-29 16:08:48.647 -----------------------------------------------
eclipse.buildId=M20130204-1200
java.version=1.7.0_05
java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=fr_FR
Framework arguments:  -product org.eclipse.epp.package.rcp.product
Command-line arguments:  -os win32 -ws win32 -arch x86_64 -product org.eclipse.epp.package.rcp.product

!ENTRY org.eclipse.debug.ui 4 0 2013-04-29 16:08:49.819
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Exception in org.eclipse.debug.internal.ui.DebugUIPlugin.start() of bundle org.eclipse.debug.ui.
	at org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:734)
	at org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(BundleContextImpl.java:683)
	at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:381)
	at org.eclipse.osgi.framework.internal.core.AbstractBundle.resume(AbstractBundle.java:390)
	at org.eclipse.osgi.framework.internal.core.Framework.resumeBundle(Framework.java:1176)
	at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:559)
	at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:544)
	at org.eclipse.osgi.framework.internal.core.StartLevelManager.incFWSL(StartLevelManager.java:457)
	at org.eclipse.osgi.framework.internal.core.StartLevelManager.doSetStartLevel(StartLevelManager.java:243)
	at org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:438)
	at org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:1)
	at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
	at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)
Caused by: java.lang.IllegalStateException: Workbench has not been created yet.
	at org.eclipse.ui.PlatformUI.getWorkbench(PlatformUI.java:92)
	at org.eclipse.debug.internal.ui.contextlaunching.LaunchingResourceManager.startup(LaunchingResourceManager.java:546)
	at org.eclipse.debug.internal.ui.DebugUIPlugin.getLaunchingResourceManager(DebugUIPlugin.java:357)
	at org.eclipse.debug.internal.ui.DebugUIPlugin.start(DebugUIPlugin.java:569)
	at org.eclipse.osgi.framework.internal.core.BundleContextImpl$1.run(BundleContextImpl.java:711)
	at java.security.AccessController.doPrivileged(Native Method)
	at org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:702)
	... 12 more
Root exception:
java.lang.IllegalStateException: Workbench has not been created yet.
	at org.eclipse.ui.PlatformUI.getWorkbench(PlatformUI.java:92)
	at org.eclipse.debug.internal.ui.contextlaunching.LaunchingResourceManager.startup(LaunchingResourceManager.java:546)
	at org.eclipse.debug.internal.ui.DebugUIPlugin.getLaunchingResourceManager(DebugUIPlugin.java:357)
	at org.eclipse.debug.internal.ui.DebugUIPlugin.start(DebugUIPlugin.java:569)
	at org.eclipse.osgi.framework.internal.core.BundleContextImpl$1.run(BundleContextImpl.java:711)
	at java.security.AccessController.doPrivileged(Native Method)
	at org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:702)
	at org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(BundleContextImpl.java:683)
	at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:381)
	at org.eclipse.osgi.framework.internal.core.AbstractBundle.resume(AbstractBundle.java:390)
	at org.eclipse.osgi.framework.internal.core.Framework.resumeBundle(Framework.java:1176)
	at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:559)
	at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:544)
	at org.eclipse.osgi.framework.internal.core.StartLevelManager.incFWSL(StartLevelManager.java:457)
	at org.eclipse.osgi.framework.internal.core.StartLevelManager.doSetStartLevel(StartLevelManager.java:243)
	at org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:438)
	at org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:1)
	at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
	at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY org.eclipse.osgi 4 0 2013-04-29 16:08:50.316
!MESSAGE Application error
!STACK 1
org.eclipse.swt.SWTException: Invalid thread access
	at org.eclipse.swt.SWT.error(SWT.java:4361)
	at org.eclipse.swt.SWT.error(SWT.java:4276)
	at org.eclipse.swt.SWT.error(SWT.java:4247)
	at org.eclipse.swt.widgets.Display.error(Display.java:1258)
	at org.eclipse.swt.widgets.Display.checkDevice(Display.java:764)
	at org.eclipse.swt.widgets.Display.addListener(Display.java:626)
	at org.eclipse.ui.internal.ide.application.IDEWorkbenchAdvisor.<init>(IDEWorkbenchAdvisor.java:176)
	at org.eclipse.ui.internal.ide.application.IDEWorkbenchAdvisor.<init>(IDEWorkbenchAdvisor.java:184)
	at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:125)
	at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:353)
	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:180)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
	at java.lang.reflect.Method.invoke(Unknown Source)
	at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:629)
	at org.eclipse.equinox.launcher.Main.basicRun(Main.java:584)
	at org.eclipse.equinox.launcher.Main.run(Main.java:1438)
	at org.eclipse.equinox.launcher.Main.main(Main.java:1414)
Previous Topic:Input validation - decoration / visual feedback - howto
Next Topic:[TableViewer] Busy ColumnViewer
Goto Forum:
  


Current Time: Thu Oct 23 16:08:02 GMT 2014

Powered by FUDForum. Page generated in 0.02106 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software