Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » EGit » Team -> show Annotations is always disabled
Team -> show Annotations is always disabled [message #1048984] Thu, 25 April 2013 07:48 Go to next message
Henning Moll is currently offline Henning Moll
Messages: 2
Registered: April 2013
Junior Member
Hi,

i made a fresh installation of eclipse (juno) SR2 and egit (2.3.1).

i cloned a project via "git bash" and add that working directory to eclipse. Egit shows the repository in the "git repositories" view. The project is also 'connected'. I am able to do actions like "[Java class node] -> Team -> Add to index" or "[Project node] -> Team -> Pull".

Unfortunately, "[Java class node] -> Team -> Show Annotations" is disabled. The same is for "Show in History" and "Show in Repository view".

Any suggestions?

Regards,
Henning
Re: Team -> show Annotations is always disabled [message #1049737 is a reply to message #1048984] Fri, 26 April 2013 07:59 Go to previous messageGo to next message
Henning Moll is currently offline Henning Moll
Messages: 2
Registered: April 2013
Junior Member
I tracked down the problem. Here's how to reproduce:

i' ve checked out a project using something like "git clone ssh://..../myproject.git
This created a workspace directory called 'myproject'.
After setting up my eclipse project i realized that the project name starts with a lower case letter. So i renamed the project's head node by pressing "F2" to "Myproject".
After this step i lost the ability for "Show annotations", "Show history", ...

This seems to be a bug, or?

Regards
Henning

Re: Team -> show Annotations is always disabled [message #1053801 is a reply to message #1049737] Tue, 07 May 2013 16:02 Go to previous message
Stefan Lay is currently offline Stefan Lay
Messages: 340
Registered: July 2009
Senior Member
Yes, sounds like a bug. Do you want to open a bug report at https://bugs.eclipse.org/bugs/?
Previous Topic:How to push a tag to gitgub
Next Topic:"Error: Can't find main class" after clone
Goto Forum:
  


Current Time: Tue Sep 16 01:03:48 GMT 2014

Powered by FUDForum. Page generated in 0.02003 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software