Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » JVM problems on Mac when running Eclipse.app(JLRequestRuntimeInstall: CFMessagePortSendRequest: error -1)
JVM problems on Mac when running Eclipse.app [message #1036632] Mon, 08 April 2013 12:19
Angelo  ülle is currently offline Angelo ülle
Messages: 1
Registered: July 2009
Junior Member
Hi Folks, I am a pretty experienced Eclipse user on Windows and now try to make a switch to MacOS 10.8.3.

When I downloaded and started Eclipse first time it found no JRE on my Computer so it asked me to automatically download and install it. This worked fine but unfortunately it installed a JDK Version 6. I installed a JDK 7 on my own and tried to uninstall the JDK6 (which is somehow creepy on Mac). From that time on I was not able to start the Eclipse.app. The Terminal gives me:

open[3893:707] JLRequestRuntimeInstall: CFMessagePortSendRequest: error -1
LSOpenURLsWithRole() failed with error -10658 for the file /Applications/eclipse/Eclipse.app.


I can still get into the .app directory and open Eclipse by hand but in fact I wanna learn something about my new platform and wanna know whats wrong.

Java -version
gives me a correct working JRE 1.7.0_17.

Uninstalling all Java fragments and Eclipse didn't solve the problem. Since that Eclipse never asked to automatically install Java again, even when there was no JRE.

Any ideas?
Previous Topic:Help indexing never completes
Next Topic:Error reading PNG metadata
Goto Forum:
  


Current Time: Thu Aug 21 14:15:54 EDT 2014

Powered by FUDForum. Page generated in 0.01512 seconds