Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » Apache Derby UI installation exception(Derby nature addition to project throws exception)
Apache Derby UI installation exception [message #1022592] Fri, 22 March 2013 03:39
Patrick Van Laake is currently offline Patrick Van Laake
Messages: 1
Registered: March 2013
Junior Member
Hello developers,

(New to Eclipse, so bear with me)

I have installed Juno SR2 and am trying to integrate Derby for use with a Tomcat server. Tomcat (7.0.37) works just fine from within Eclipse and so does the Derby core (10.8.2). The Derby UI (1.1.3) also installs fine and I do get the context menus. However, when I try to add a Derby nature to a new Eclipse project I get the error message "org.eclipse.ui.internal.WorkbenchWindow cannot be cast to org.eclipse.jface.window.ApplicationWindow". This sounds to me that there is a compatibility issue between Eclipse and Derby. Please note that I am using an older version of Derby core and UI (October 2011), being the latest release in the form of an Eclipse plug-in. Any pointers would be welcome.

If I am to use the latest Derby bin distribution I could use a reference to an up-to-date Eclipse integration instruction. Everything that I referenced - both from Apache and Eclipse - refers to older releases that do not seem to apply to the latest distributions.

Thanks in advance for any help.

Cheers,
Patrick

Previous Topic:JavaScript Inferrer and TypeBinding
Next Topic:generate JPA entities from tables
Goto Forum:
  


Current Time: Tue Sep 02 05:25:18 EDT 2014

Powered by FUDForum. Page generated in 0.02517 seconds