Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Papyrus » Problem creating new Papyrus project within Eclipse
Problem creating new Papyrus project within Eclipse [message #1018465] Wed, 13 March 2013 17:44 Go to next message
Stuart Penberthy is currently offline Stuart Penberthy
Messages: 7
Registered: March 2013
Junior Member
Hi All,

I am new to Papyrus and UML Diagrams.

I am trying to create a new Papyrus project within Eclipse.

I have downloaded the version of Eclipse which includes the modeling components for Papyrus.

It seams to have installed ok and I have added all of the extra Papyrus components.

I have switched to the Papyrus perspective and I am trying to created a new Papyrus project.

I am following the guide below.

http://www.eclipse.org/papyrus/usersTutorials/resources/PapyrusUserGuideSeries_AboutUMLProfile_v1.0.0_d20120606.pdf

I am able to complete steps 1 through to 3.

However when I click next I get a error.

The Papyrus project creation wizard is asking me to select a language but I do not have any to select.

In Step 4 of the above user guide shows 3 languages at this point.

1. SysML
2. UML
3. Profile.

however I have none of them.

Question.

1. Do I need to install some extra components?
2. Is there something else I need to do?

I am tiring to draw UML diagrams within eclipse.

Thanks in advance.

Stuart


Re: Problem creating new Papyrus project within Eclipse [message #1018659 is a reply to message #1018465] Thu, 14 March 2013 05:14 Go to previous messageGo to next message
Camille Letavernier is currently offline Camille Letavernier
Messages: 399
Registered: February 2011
Senior Member
Hello Stuart,


You do no need any extra-component for this guide. The standard installation contains UML, Profiles, and SysML.

What versions of Papyrus/Eclipse are you using?


Camille
Re: Problem creating new Papyrus project within Eclipse [message #1018667 is a reply to message #1018659] Thu, 14 March 2013 05:26 Go to previous messageGo to next message
Stuart Penberthy is currently offline Stuart Penberthy
Messages: 7
Registered: March 2013
Junior Member
Hi Camille,

Thanks for the response.

I am using eclipse-modeling-juno-win32-x86_64
with all updates applied

and I am using Papyrus-Update-incubation-0.9.2


I do not seam to have UML, Profiles, and SysML.

Can you suggest something I could try.

Stuart



  • Attachment: Installed.jpg
    (Size: 263.79KB, Downloaded 40 times)
Re: Problem creating new Papyrus project within Eclipse [message #1018681 is a reply to message #1018667] Thu, 14 March 2013 05:57 Go to previous messageGo to next message
Camille Letavernier is currently offline Camille Letavernier
Messages: 399
Registered: February 2011
Senior Member
UML/Profiles/Sysml are included in the Papyrus Binaries (Under Papyrus SDK Binaries).

The problem is not that they are not installed. Do you have an error message in your error log when you try to use the Papyrus wizard?
Re: Problem creating new Papyrus project within Eclipse [message #1018694 is a reply to message #1018681] Thu, 14 March 2013 06:20 Go to previous messageGo to next message
Stuart Penberthy is currently offline Stuart Penberthy
Messages: 7
Registered: March 2013
Junior Member
From what I can See I am running

Version: Juno Service Release 2
Build id: 20130225-0426

I will look into the Papyrus Binaries now.

Thanks

Let you know shortly

Thanks

Re: Problem creating new Papyrus project within Eclipse [message #1018709 is a reply to message #1018694] Thu, 14 March 2013 06:41 Go to previous messageGo to next message
Stuart Penberthy is currently offline Stuart Penberthy
Messages: 7
Registered: March 2013
Junior Member
Hi Camille,

I found the 'Papyrus SDK Binaries and sources'

but when I try to install it I get the following error.

see attached.

Any Ideas on how to solve this problem?

Thanks for your help so far.

Stuart
  • Attachment: error.txt
    (Size: 19.02KB, Downloaded 75 times)
Re: Problem creating new Papyrus project within Eclipse [message #1018711 is a reply to message #1018709] Thu, 14 March 2013 06:44 Go to previous messageGo to next message
Camille Letavernier is currently offline Camille Letavernier
Messages: 399
Registered: February 2011
Senior Member
Hi Stuart,

You don't need to install the Papyrus sources. You should simply open the error log view in Eclipse, try to create a new Papyrus model with the Papyrus wizard, and see if an errors appears in the log. If so, copy the stack trace and we'll try to see what's wrong.

Regards,
Camille
Re: Problem creating new Papyrus project within Eclipse [message #1018719 is a reply to message #1018711] Thu, 14 March 2013 06:59 Go to previous messageGo to next message
Stuart Penberthy is currently offline Stuart Penberthy
Messages: 7
Registered: March 2013
Junior Member
Hi Camille,

I went into my log and deleted it.

Then closed and opened eclipse.

I then looked in the log.

and saw the following, see attached log.jpg

I then tried to create a papyrus model

I recorded the process. video.avi

no new error were created.


' this is what was in the log file when I opened it.'

see attached log-file.txt

this line looks suspect.
!ENTRY org.eclipse.ui 4 4 2013-03-14 20:48:06.338
!MESSAGE Conflicting handlers for org.eclipse.papyrus.views.properties.model.migration.migrate_0.9: {org.eclipse.papyrus.migration.properties.model.handler.MigrationHandler} vs {org.eclipse.papyrus.migration.properties.model.handler.MigrationHandler}


Any ideas on how to fix that and the other errors?


thanks again for your help


Stuart







  • Attachment: log.jpg
    (Size: 137.61KB, Downloaded 43 times)
  • Attachment: video.avi
    (Size: 1.82MB, Downloaded 47 times)
  • Attachment: log-file.txt
    (Size: 2.13KB, Downloaded 107 times)
Re: Problem creating new Papyrus project within Eclipse [message #1018746 is a reply to message #1018719] Thu, 14 March 2013 08:00 Go to previous messageGo to next message
Stuart Penberthy is currently offline Stuart Penberthy
Messages: 7
Registered: March 2013
Junior Member
Hi Camille,

upon restart there appears to be a few more errors.

see attached.

is there a way to uninstall Papyrus-Update-incubation-0.9.2


and try reinstalling it.

or is there a way to solve the errors?

Re: Problem creating new Papyrus project within Eclipse [message #1018760 is a reply to message #1018746] Thu, 14 March 2013 08:26 Go to previous messageGo to next message
Camille Letavernier is currently offline Camille Letavernier
Messages: 399
Registered: February 2011
Senior Member
There's indeed a problem with your installation, although I couldn't tell what's wrong.

To uninstall Papyrus: Help > About Eclipse > Installation details. In the Installed Software tab, select all "Papyrus" features, then "Uninstall".

I just tried a clean installation of Papyrus 0.9.2 with all extra components, and it works fine (Only the sources cannot be installed, but they are never required).
Re: Problem creating new Papyrus project within Eclipse [message #1019215 is a reply to message #1018760] Fri, 15 March 2013 04:55 Go to previous message
Stuart Penberthy is currently offline Stuart Penberthy
Messages: 7
Registered: March 2013
Junior Member
Hi Camille,

Thanks for your help.

I uninstalled Papyrus 0.9.2 and re-installed it and now it working.

Thanks again.

Stuart
Previous Topic:Problem loading UML file in Papyrus
Next Topic:Create Papyrus Project From UML file Using Java
Goto Forum:
  


Current Time: Mon Apr 21 00:48:25 EDT 2014

Powered by FUDForum. Page generated in 0.08463 seconds