Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » How to configure Apache ODE & Jar & ExtensionAcitivy of WS-BPEL Extensions
How to configure Apache ODE & Jar & ExtensionAcitivy of WS-BPEL Extensions [message #1016931] Fri, 08 March 2013 09:10 Go to next message
Alan Hsu is currently offline Alan HsuFriend
Messages: 1
Registered: March 2013
Junior Member
Hi Guys
I have a big trouble.
I am working on a BPEL process using Apache ODE and ExtensionActivity of WS-BPEL Extensions.
So there are a BPEL process ExtensionActivity.bpel and two java file
ExtensionActivity.bpel


I try to do Installation of extensions (WAR - Axis2 deployable)
Transform two java to a jar and copy the extension jar to /WEB-INF/lib.
Register the extension. Open /WEB-INF/conf/ode-axis2.properties and add the following lines:

ode-axis2.extension.bundles.runtime = org.wso2.bps.samples.extension.B4PExtensionBundle
Start/Restart Apache ODE


In fact , the BPEL process can be executed successfully but the jar seem not be invoked.
how can i do and debug?
Could you give me some suggestion?

Thanks.
Alan
Re: How to configure Apache ODE & Jar & ExtensionAcitivy of WS-BPEL Extensions [message #1017036 is a reply to message #1016931] Fri, 08 March 2013 17:43 Go to previous message
Russell Bateman is currently offline Russell BatemanFriend
Messages: 3268
Registered: July 2009
Location: Provo, Utah, USA
Senior Member

On 3/8/2013 10:35 AM, Alan Hsu wrote:
> Hi Guys
> I have a big trouble.
> I am working on a BPEL process using Apache ODE and ExtensionActivity of
> WS-BPEL Extensions. So there are a BPEL process ExtensionActivity.bpel
> and two java file
> ExtensionActivity.bpel
>
>
> I try to do Installation of extensions (WAR - Axis2 deployable)
> Transform two java to a jar and copy the extension jar to /WEB-INF/lib.
> Register the extension. Open /WEB-INF/conf/ode-axis2.properties and add
> the following lines:
>
> ode-axis2.extension.bundles.runtime =
> org.wso2.bps.samples.extension.B4PExtensionBundle
> Start/Restart Apache ODE
>
>
> In fact , the BPEL process can be executed successfully but the jar seem
> not be invoked. how can i do and debug?
> Could you give me some suggestion?
>
> Thanks.
> Alan

At very least, I'd direct this question to the Eclipse web tools plaform
forum.
Previous Topic:Not able to detect tab controls with the help of SWTBOT
Next Topic:Trouble getting Eclipse to work
Goto Forum:
  


Current Time: Tue Dec 23 03:00:42 GMT 2014

Powered by FUDForum. Page generated in 0.01570 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software