Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Epsilon » EVL-Validating from a node different of root not working until root validation is made
EVL-Validating from a node different of root not working until root validation is made [message #1016223] Tue, 05 March 2013 09:41 Go to next message
oskar saiz is currently offline oskar saiz
Messages: 17
Registered: February 2013
Junior Member
Hi community.

I have a simple model, editor and evl constraints.

1.- If I start the editor and 'Validate' from a node different of the root node, it does not work. (It says 'validation completed successfully')
2.- Later, if I do the validation of the root node it does work.
3.- After that, the validation does work from every node.

I send a minimal example.
Thanks in advance.
Oskar

Pd.- My version:
Epsion Core : 1.0.0.201301242320

I attach the following files:
1.- minimum.zip
The exported eclipse projects

2.- MyProject.zip
The project containint the model

The steps are:
1.- Launch the editor MMOskar2.editor
2.- Open the project, and into it, open folder1/minim.myfirstdsl
3.- Run the validation in any node different from the root node. It says 'validation completed successfully'
3.- Run the validation in the root node. Validation errors appear.
4.- Run the validation in any node different from the root node. Validation errors appear.
  • Attachment: minimum.zip
    (Size: 154.07KB, Downloaded 35 times)
  • Attachment: MyProject.zip
    (Size: 0.64KB, Downloaded 33 times)
Re: EVL-Validating from a node different of root not working until root validation is made [message #1016874 is a reply to message #1016223] Thu, 07 March 2013 20:23 Go to previous messageGo to next message
Dimitris Kolovos is currently offline Dimitris Kolovos
Messages: 803
Registered: July 2009
Senior Member
Hi Oskar,

I've reproduced this and it looks like a bug. Could you please file a bug report [1]? Could I ask if this bug is affecting your work or if it is a minor inconvenience?

Cheers,
Dimitris

[1] https://bugs.eclipse.org/bugs/enter_bug.cgi?product=EMFT.Epsilon
Re: EVL-Validating from a node different of root not working until root validation is made [message #1016895 is a reply to message #1016874] Fri, 08 March 2013 01:37 Go to previous message
oskar saiz is currently offline oskar saiz
Messages: 17
Registered: February 2013
Junior Member
Hi Dimitris.
Actually I'm not using this tool in a real project. I'm evaluating different validation tools.
So I could say it is not affecting my work.
I will file a bug report.
Thanks for your support.
Oskar
Previous Topic: delete from diagram button always Disabled
Next Topic:[ETL] Transforming to herited model
Goto Forum:
  


Current Time: Thu Jul 31 19:46:40 EDT 2014

Powered by FUDForum. Page generated in 0.11266 seconds