Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Remote Application Platform (RAP) » RAP 2.0: Exception at start-up
RAP 2.0: Exception at start-up [message #1008433] Tue, 12 February 2013 13:07 Go to next message
Bernard SARTER is currently offline Bernard SARTER
Messages: 76
Registered: August 2011
Location: Paris, France
Member
Hello,

I'd like to convert a existing RCP app to RAP.

My IDE and my target platform are up-to-date, I'm using latest RAP 2.0, Kepler 4.3 M5a, EMF-RAP 2.9.

I configured the launch configuration as described here: http://help.eclipse.org/juno/index.jsp?topic=%2Forg.eclipse.rap.help%2Fhelp%2Fhtml%2Fgetting-started%2Flauncher.html&cp=52_1_3

With this target platform, the "RAP Mail demo" app is working fine.

But when I start my own application, I get following error:

java.lang.NoSuchMethodException: org.eclipse.e4.ui.css.swt.internal.theme.BootstrapTheme3x.<init>(org.eclipse.swt.widgets.Display)
	at java.lang.Class.getConstructor0(Unknown Source)
	at java.lang.Class.getConstructor(Unknown Source)
	at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2568)
	at org.eclipse.ui.internal.Workbench.access$5(Workbench.java:2530)
	at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:701)
	at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
	at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:684)
	at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:157)
	at my.application.Application.start(Application.java:84)
	at org.eclipse.rap.ui.internal.application.EntryPointApplicationWrapper.createUI(EntryPointApplicationWrapper.java:38)
	at org.eclipse.rap.rwt.internal.lifecycle.RWTLifeCycle.createUI(RWTLifeCycle.java:186)
	at org.eclipse.rap.rwt.internal.lifecycle.RWTLifeCycle$UIThreadController.run(RWTLifeCycle.java:298)
	at java.lang.Thread.run(Unknown Source)
	at org.eclipse.rap.rwt.internal.lifecycle.UIThread.run(UIThread.java:104)


followed by

2013-02-12 11:41:23.248:WARN:oejs.ServletHandler:ERROR:  Error for /myApp
java.lang.LinkageError: loader constraint violation: loader (instance of org/eclipse/osgi/internal/baseadaptor/DefaultClassLoader) previously initiated loading for a different type with name "org/eclipse/swt/widgets/Display"
	at my.application.Application.start(Application.java:94)
	at org.eclipse.rap.ui.internal.application.EntryPointApplicationWrapper.createUI(EntryPointApplicationWrapper.java:38)
	at org.eclipse.rap.rwt.internal.lifecycle.RWTLifeCycle.createUI(RWTLifeCycle.java:186)
	at org.eclipse.rap.rwt.internal.lifecycle.RWTLifeCycle$UIThreadController.run(RWTLifeCycle.java:298)
	at java.lang.Thread.run(Unknown Source)
	at org.eclipse.rap.rwt.internal.lifecycle.UIThread.run(UIThread.java:10


I don't see an obvious difference between the working Mail Demo app, and my own stuff, that could explain this problem ...

Any suggestion welcome,

Thanks,
Bernard.
Re: RAP 2.0: Exception at start-up [message #1008441 is a reply to message #1008433] Tue, 12 February 2013 13:56 Go to previous message
Bernard SARTER is currently offline Bernard SARTER
Messages: 76
Registered: August 2011
Location: Paris, France
Member
Ok, by checking again the launch configuration of my app, I could remove some useless stuff and now it works fine.
Previous Topic:Adding extra HTML attribute to RAP compontents
Next Topic:RAP 2.0 compatibility
Goto Forum:
  


Current Time: Tue Sep 30 15:52:38 GMT 2014

Powered by FUDForum. Page generated in 0.05017 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software