Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » QVT-OML » Property 'ownedPort' is read-only(Failing to port an existing QVTo transform from Eclipse Indigo to Juno)
Property 'ownedPort' is read-only [message #1006495] Thu, 31 January 2013 09:01 Go to next message
Matteo M. is currently offline Matteo M.
Messages: 28
Registered: May 2012
Junior Member
Hi,

I've defined a mapping that takes an "inout cls:Class" as argument and returns an "UML::Port". The mapping contains the following statement:

cls.ownedPort += result;

It works in IndigoSR2 but I cannot get it working in JunoSR1. I get the following error: "Property 'ownedPort' is read-only". How do I fix this issue?

Thanks,

--
Matteo
Re: Property 'ownedPort' is read-only [message #1006502 is a reply to message #1006495] Thu, 31 January 2013 09:17 Go to previous messageGo to next message
Ed Willink is currently offline Ed Willink
Messages: 4026
Registered: July 2009
Senior Member
Hi

Juno introduced UML 2.4.1 support, so you have probably changed UML
versions.

The very detailed
http://wiki.eclipse.org/MDT/UML2/UML2_4.0_Migration_Guide shows that
EncapsulatedClassifier.ownedPort changed to readOnly as a result of OMG
issue http://www.omg.org/issues/uml2-rtf.html#Issue15568.

You should use ownedAttribute instead of ownedPort.

Regards

Ed Willink


On 31/01/2013 14:01, Matteo M. wrote:
> Hi,
>
> I've defined a mapping that takes an "inout cls:Class" as argument and
> returns an "UML::Port". The mapping contains the following statement:
>
> cls.ownedPort += result;
>
> It works in IndigoSR2 but I cannot get it working in JunoSR1. I get
> the following error: "Property 'ownedPort' is read-only". How do I fix
> this issue?
>
> Thanks,
>
> --
> Matteo
Re: Property 'ownedPort' is read-only [message #1006518 is a reply to message #1006502] Thu, 31 January 2013 09:55 Go to previous message
Matteo M. is currently offline Matteo M.
Messages: 28
Registered: May 2012
Junior Member
Quote:

The very detailed
http://wiki.eclipse.org/MDT/UML2/UML2_4.0_Migration_Guide shows that
EncapsulatedClassifier.ownedPort changed to readOnly as a result of OMG
issue http://www.omg.org/issues/uml2-rtf.html#Issue15568.


Yes, I've already read that one.

Quote:

You should use ownedAttribute instead of ownedPort.


I was just not aware of which method I had to call. It worked perfectly.
Thank you,

--
Matteo
Previous Topic:Constant rebuilds
Next Topic:Execution doesn't stop at breakpoint in library
Goto Forum:
  


Current Time: Wed Aug 20 22:28:55 EDT 2014

Powered by FUDForum. Page generated in 0.02900 seconds