Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » Java Development Tools (JDT) » Eclipse 4.2.1 - can't import classes after some time
Eclipse 4.2.1 - can't import classes after some time [message #1005697] Mon, 28 January 2013 05:30
Krzysiek Nazwisko is currently offline Krzysiek Nazwisko
Messages: 1
Registered: January 2013
Junior Member
Hi, I'm Chris - new on this forum, so - once again - Hi! :)

Currently I use Eclipse 4.2.1 (M20120914-1800).
I noticed that under some circumstances (unfortunately, I can't get reproducing path), Eclipse messes up :(
What I mean is:
- in "Open Type" window it can't find some classes (some can, but some no :( But i.ex. "Open Resource" can find this class
- Content Assist (CTRL + space) also can't find some classes (what is weird - "Open Type" can find this class).
If I type this class manually, Eclipse can't import it!:(
- can't finding any references for method (Ctrl+Shift+G on method - 0 matches)


Cleaning and refreshing my project doesn't help it :( BUT helps restarting the IDE. After restarting everything backs to normal.

Of course, I have the "Build Automatically" option checked.
There are no errors in project (in "Problems" view are only Warnings)

Anybody noticed this strange, similar behavior...?
It's very irritating :/

As I said, for now, I can't reproduce it :( It happens averagely once, twice in 8 hours session work.
I have little presumption that it may be connected with saving project with build errors, but I'm not sure so I don't want to show wrong path.


I looked in .log Eclipse file, but I didn't find anything interesting (I'm enclosing the file in post).

Maybe I should look somewhere else...? What can I turn on to give you more informations?


Please, answer.
This bug(?) it's really disturbing the work :/


  • Attachment: .log
    (Size: 1.09KB, Downloaded 52 times)
Previous Topic:Add Interface Type to Class type
Next Topic:TCP/IP Monitor in Eclipse Classic
Goto Forum:
  


Current Time: Wed Aug 27 07:13:25 EDT 2014

Powered by FUDForum. Page generated in 0.01979 seconds