Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » TMF (Xtext) » CSS Validation(extraneous input error on css files)
CSS Validation [message #1005557] Sat, 26 January 2013 17:10 Go to next message
Steven Spungin is currently offline Steven Spungin
Messages: 4
Registered: December 2012
Junior Member
I don't know if this is a bug or configuration issue on my part, but I downloaded the lastest build of xtend yesterday (2.4.0.v201301250856), and I am getting hundreds of this error in all of my CSS files:

extraneous input ' ' expecting RULE_IDENT {...}	Xtext Check (fast)


It seems that any css rules that have '.' in the number cause this error, such as:

	font-size: .9em; 

Furthermore, there does not seem to be a way to turn of the validation on the css files.

Has anybody else seen this issue?
Re: CSS Validation [message #1005610 is a reply to message #1005557] Sun, 27 January 2013 13:16 Go to previous messageGo to next message
Sebastian Zarnekow is currently offline Sebastian Zarnekow
Messages: 2911
Registered: July 2009
Senior Member
Am 26.01.13 18:10, schrieb Steven Spungin:
> I don't know if this is a bug or configuration issue on my part, but I
> downloaded the lastest build of xtend yesterday (2.4.0.v201301250856),
> and I am getting hundreds of this error in all of my CSS files:
>
> extraneous input ' ' expecting RULE_IDENT {...} Xtext Check (fast)
>
> It seems that any css rules that have '.' in the number cause this
> error, such as:
>
> font-size: .9em; Furthermore, there does not seem to be a way to
> turn of the validation on the css files.
>
> Has anybody else seen this issue?

Do you have an Xtext plugin for css installed?

Regards,
Sebastian
--
Looking for professional support for Xtext, Xtend or Eclipse Modeling?
Go visit: http://xtext.itemis.com
Re: CSS Validation [message #1005612 is a reply to message #1005610] Sun, 27 January 2013 14:07 Go to previous messageGo to next message
Steven Spungin is currently offline Steven Spungin
Messages: 4
Registered: December 2012
Junior Member
I do not see any installed plugin with xtext and css in the name. Which feature would have (or should have) installed the css validator?
Re: CSS Validation [message #1005674 is a reply to message #1005612] Mon, 28 January 2013 08:55 Go to previous messageGo to next message
Sebastian Zarnekow is currently offline Sebastian Zarnekow
Messages: 2911
Registered: July 2009
Senior Member
Am 27.01.13 15:07, schrieb Steven Spungin:
> I do not see any installed plugin with xtext and css in the name. Which
> feature would have (or should have) installed the css validator?

Probably e(fx)clipse? I'm not sure - don't know each and every
application of Xtext.

Regards,
Sebastian
--
Looking for professional support for Xtext, Xtend or Eclipse Modeling?
Go visit: http://xtext.itemis.com
Re: CSS Validation [message #1005725 is a reply to message #1005674] Mon, 28 January 2013 12:20 Go to previous messageGo to next message
Thomas Schindl is currently offline Thomas Schindl
Messages: 5433
Registered: July 2009
Senior Member
e(fx)clipse is perfectly happy with .9em and translate it to what it is
0.9em ;-) but I'm running with xtext 2.3.1 have not yet tried 2.4.0.

It could also be the e4 css editor, which is also based on xtext

Tom

Am 28.01.13 09:55, schrieb Sebastian Zarnekow:
> Am 27.01.13 15:07, schrieb Steven Spungin:
>> I do not see any installed plugin with xtext and css in the name. Which
>> feature would have (or should have) installed the css validator?
>
> Probably e(fx)clipse? I'm not sure - don't know each and every
> application of Xtext.
>
> Regards,
> Sebastian
Re: CSS Validation [message #1005727 is a reply to message #1005725] Mon, 28 January 2013 12:31 Go to previous messageGo to next message
Sebastian Zarnekow is currently offline Sebastian Zarnekow
Messages: 2911
Registered: July 2009
Senior Member
Sorry Tom, didn't meant to blame e(fx)clipse for that one. The e4 css
stuff sounds more likely to cause the issue.

Regards,
Sebastian

Am 28.01.13 13:20, schrieb Tom Schindl:
> e(fx)clipse is perfectly happy with .9em and translate it to what it is
> 0.9em ;-) but I'm running with xtext 2.3.1 have not yet tried 2.4.0.
>
> It could also be the e4 css editor, which is also based on xtext
>
> Tom
>
> Am 28.01.13 09:55, schrieb Sebastian Zarnekow:
>> Am 27.01.13 15:07, schrieb Steven Spungin:
>>> I do not see any installed plugin with xtext and css in the name. Which
>>> feature would have (or should have) installed the css validator?
>>
>> Probably e(fx)clipse? I'm not sure - don't know each and every
>> application of Xtext.
>>
>> Regards,
>> Sebastian
>
Re: CSS Validation [message #1005743 is a reply to message #1005727] Mon, 28 January 2013 13:46 Go to previous messageGo to next message
Thomas Schindl is currently offline Thomas Schindl
Messages: 5433
Registered: July 2009
Senior Member
Hi,

No offense taken ;-) - I guess because the parser is generated upgrading
Xtext to 2.4.0 can't lead to such a problem. So if it works with 2.3.1
it will still work with 2.4.0.

Knowing what Steven has installed would help to find out who is the one
to blame.

Tom

Am 28.01.13 13:31, schrieb Sebastian Zarnekow:
> Sorry Tom, didn't meant to blame e(fx)clipse for that one. The e4 css
> stuff sounds more likely to cause the issue.
>
> Regards,
> Sebastian
>
> Am 28.01.13 13:20, schrieb Tom Schindl:
>> e(fx)clipse is perfectly happy with .9em and translate it to what it is
>> 0.9em ;-) but I'm running with xtext 2.3.1 have not yet tried 2.4.0.
>>
>> It could also be the e4 css editor, which is also based on xtext
>>
>> Tom
>>
>> Am 28.01.13 09:55, schrieb Sebastian Zarnekow:
>>> Am 27.01.13 15:07, schrieb Steven Spungin:
>>>> I do not see any installed plugin with xtext and css in the name.
>>>> Which
>>>> feature would have (or should have) installed the css validator?
>>>
>>> Probably e(fx)clipse? I'm not sure - don't know each and every
>>> application of Xtext.
>>>
>>> Regards,
>>> Sebastian
>>
>
>
Re: CSS Validation [message #1005871 is a reply to message #1005743] Tue, 29 January 2013 07:18 Go to previous messageGo to next message
Sebastian Zarnekow is currently offline Sebastian Zarnekow
Messages: 2911
Registered: July 2009
Senior Member
Hi Tom,

yes, upgrading to 2.4.0 but still using e(fx)clipse that was compiled to
2.3.1 will lead to all sorts of problems but not this one :-)

Regards,
Sebastian
--
Looking for professional support for Xtext, Xtend or Eclipse Modeling?
Go visit: http://xtext.itemis.com

Am 28.01.13 14:46, schrieb Tom Schindl:
> Hi,
>
> No offense taken ;-) - I guess because the parser is generated upgrading
> Xtext to 2.4.0 can't lead to such a problem. So if it works with 2.3.1
> it will still work with 2.4.0.
>
> Knowing what Steven has installed would help to find out who is the one
> to blame.
>
> Tom
>
> Am 28.01.13 13:31, schrieb Sebastian Zarnekow:
>> Sorry Tom, didn't meant to blame e(fx)clipse for that one. The e4 css
>> stuff sounds more likely to cause the issue.
>>
>> Regards,
>> Sebastian
>>
>> Am 28.01.13 13:20, schrieb Tom Schindl:
>>> e(fx)clipse is perfectly happy with .9em and translate it to what it is
>>> 0.9em ;-) but I'm running with xtext 2.3.1 have not yet tried 2.4.0.
>>>
>>> It could also be the e4 css editor, which is also based on xtext
>>>
>>> Tom
>>>
>>> Am 28.01.13 09:55, schrieb Sebastian Zarnekow:
>>>> Am 27.01.13 15:07, schrieb Steven Spungin:
>>>>> I do not see any installed plugin with xtext and css in the name.
>>>>> Which
>>>>> feature would have (or should have) installed the css validator?
>>>>
>>>> Probably e(fx)clipse? I'm not sure - don't know each and every
>>>> application of Xtext.
>>>>
>>>> Regards,
>>>> Sebastian
>>>
>>
>>
>
Re: CSS Validation [message #1006721 is a reply to message #1005557] Fri, 01 February 2013 15:10 Go to previous messageGo to next message
Steven Spungin is currently offline Steven Spungin
Messages: 4
Registered: December 2012
Junior Member
It definitely was the e4 CSS editor. I removed it (with xtext and xtend still installed) and the errors stopped.

It's having trouble parsing numbers that start with a '.'

I ran my CSS through lint and there were no errors. So this seems to be due to either the e4 CSS editor grammar, or a configuration issue on my end. Either way, it would be nice to be able suppress the errors.

If anybody has the latest e4 CSS editor installed, please let us know if this causes the error:

.ip-tutorial-info {
	font-size: .9em;
}

Re: CSS Validation [message #1065405 is a reply to message #1005557] Tue, 25 June 2013 15:10 Go to previous messageGo to next message
Youssef Zouhairi is currently offline Youssef Zouhairi
Messages: 1
Registered: June 2013
Junior Member
Hello ,

Thank you for the tip !! it was definitly CSS Validator's problem . I had Papyrus installed on my ecplise , it created the conflict . once I uninstalled it ! it worked !!

Youssef
Re: CSS Validation [message #1067857 is a reply to message #1005557] Wed, 10 July 2013 22:05 Go to previous message
Daniel P is currently offline Daniel P
Messages: 1
Registered: July 2013
Junior Member
I'm a bit confused. Did anyone figure out the problem?

I'm having a very similar issue. With e(fx)clipse installed on Eclipse Java EE. I have tried it with only the "e(fx)clipse - Composite - FX Tooling" and get the same results. It says:
Unknown property: "text-decoration"


for this code:
a:link
{ text-decoration: none; color: #ff0000 }



It seems like it's a problem between the EE css plugin and the fx css plugin. If I uninstall fx, the problem goes away. I have to reopen the .css file because it says:
No editor descriptor for id at.bestsolution.efxclipse.tooling.css.CssDsl


but after I reopen it, everything is back to normal. I can once again view the css file with syntax highlighting. It's just obviously lacking the other great qualities I was hoping to get from e(fx)clipse.
Previous Topic:Problem exporting Eclipse product
Next Topic:Rewrite Action Problem
Goto Forum:
  


Current Time: Thu Oct 30 12:13:18 GMT 2014

Powered by FUDForum. Page generated in 0.03400 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software