Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » C / C++ IDE (CDT) » unresolved #include's(eclipse can't seem to find standard library headers in Xcode)
unresolved #include's [message #1002948] Sat, 19 January 2013 18:14
dan lior is currently offline dan lior
Messages: 4
Registered: October 2012
Junior Member
Apologies.

I realize that my problem is common, but none the the solutions that I found to similar posts seems to help.



I have eclipse juno installed on my mac. I also installed xcode 4.5. I start with the standard hello world program for c. The program works, but there is an error that says that the #include <stdio.h> is unresolved. I searched online and I think that the eclipse environment simply doesn't know where to look for the c header files. I learned where in eclipse I can set the correct path to the header files, but I don't know where they are. Presumably, they are embedded somewhere in the Xcode file system on my computer. I tried to search for stdio.h on my computer, but couldn't find it.

Then I found the following prescription on the net for a seemingly similar problem:

``Likely you are getting bit by the repackaging of everything inside
/Applications/Xcode.app starting with Xcode 4.3. In Unix-like
installations stdlib.h usually lives in /usr/include and your project
likely expects it to be there as it was pre-Xcode 4.3. You can fix
this by installing the command line tools, which includes the tools
and the associated headers and libraries in their standard location.

The easiest way to install the command line tools is from inside
Xcode. In the Xcode Preferences select the "Downloads" pane and then
the "Components" tab. Push the "Install" button next to "Command Line
Tools" ''

I proceeded to install command line tools as specified. As far as I can tell, everything went smoothly with the install. The only problem is that it had no effect on my original situation. The standard includes in the hello world program are still not resolved.

Please help.

dan

Previous Topic:Open Declaration to an empty deleted file...
Next Topic:"Unresolved inclusion: <stdio.h>"
Goto Forum:
  


Current Time: Fri Aug 01 06:09:30 EDT 2014

Powered by FUDForum. Page generated in 0.01429 seconds