Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Graphiti » Linking with my own ecore model
Linking with my own ecore model [message #1001299] Wed, 16 January 2013 07:26 Go to next message
Juliane Mueller is currently offline Juliane Mueller
Messages: 26
Registered: August 2011
Junior Member
Dear all,

I have my own ecore model. Now I want to link this model with my Graphiti-diagram. Where can I define this linking?

I'll be deeply grateful for your answers!

Regards, Juliane.
Re: Linking with my own ecore model [message #1001787 is a reply to message #1001299] Thu, 17 January 2013 06:20 Go to previous messageGo to next message
Michael Wenz is currently offline Michael Wenz
Messages: 1524
Registered: July 2009
Location: Walldorf, Germany
Senior Member
Juliane,

the tutorial explains how to link to Ecore model objects, just by calling
link(pictogram element, domain object) e.g. within your add feature. You can
do just the same with your domain model objects. The only additional thing
compared to the tutorial is that you need to have your model available as a
dependency of yout editor: simply add the model plugin to the required
plugins of your editor plugin.

Michael
Re: Linking with my own ecore model [message #1011989 is a reply to message #1001787] Wed, 20 February 2013 11:29 Go to previous message
sakop qq is currently offline sakop qq
Messages: 29
Registered: January 2013
Junior Member
Thanks´╝ü Your solution also helped me resolve my problem
Previous Topic:Graphiti Diagram doesn't load on startup
Next Topic:Register EPackage before loading the diagram
Goto Forum:
  


Current Time: Wed Apr 16 21:07:36 EDT 2014

Powered by FUDForum. Page generated in 0.01930 seconds