Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Installing EPP PHP Error: Requirement violation
Installing EPP PHP Error: Requirement violation [message #998240] Wed, 09 January 2013 16:24 Go to next message
Stefan Snooc is currently offline Stefan Snooc
Messages: 12
Registered: January 2013
Junior Member
Hey guys!

I have installed Eclipse JEE and I wanted to install the EPP PHP Feature from http://download.eclipse.org/technology/epp/packages/galileo

But when I try to I receive the following error:

Cannot complete the install because one or more required items could not be found.
  Software being installed: EPP PHP Feature 1.2.2.20100216-1730 (org.eclipse.epp.package.php.feature.feature.group 1.2.2.20100216-1730)
  Missing requirement: EPP PHP Feature 1.2.2.20100216-1730 (org.eclipse.epp.package.php.feature.feature.group 1.2.2.20100216-1730) requires 'org.eclipse.platform.feature.group [3.5.2.R35x_v20100210-0800-9hEiFzmFst-TiEn9hNYgDWg1XN8ulH_JvCNGB]' but it could not be found



I have no idea how I can resolve this. A google search brought me to stackoverflow[1], where it's said:

Quote:

Update your plugin. There is a compatibility layer between Eclipse 3.x and 4.x, so you might just need to update the version ranges in your dependency. This assumes you have access to com.Company.engineering.maven.feature.feature.group.


I am sure that this would be the solution to my problem but I don't know what needs to be done here..

Thanks for any help!



[1] stackoverflow.com/questions/10511631/maven-plugin-install-in-eclipse-missing-requirement-org-eclipse-platform-featu
Re: Installing EPP PHP Error: Requirement violation [message #999728 is a reply to message #998240] Sun, 13 January 2013 01:12 Go to previous message
Toshihiro Izumi is currently offline Toshihiro Izumi
Messages: 351
Registered: July 2009
Location: Japan
Senior Member
> Missing requirement: EPP PHP Feature 1.2.2.20100216-1730 (org.eclipse.epp.package.php.feature.feature.group 1.2.2.20100216-1730) requires 'org.eclipse.platform.feature.group [3.5.2.R35x_v20100210-0800-9hEiFzmFst-TiEn9hNYgDWg1XN8ulH_JvCNGB]'
As this message elaborates clearly, you must have Eclipse 3.5.2 installation if you really need EPP PHP Feature of Galileo in the days of 2010.
Previous Topic:Problem in creating new job to hudson
Next Topic:Eclipse broswer applets
Goto Forum:
  


Current Time: Sat Oct 25 12:58:11 GMT 2014

Powered by FUDForum. Page generated in 0.01928 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software