Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » Java Development Tools (JDT) » Content Assist working intermittently(Content-Assist working intermittently)
Content Assist working intermittently [message #997549] Tue, 08 January 2013 04:16
Michael Chan is currently offline Michael Chan
Messages: 1
Registered: January 2013
Junior Member
I have encountered very weird behavior on Eclipse's (both Helios and Juno) content-assist when I was programming for Android. Following capture shows everything smooth when I was still inside that inline method (OnSeekBarChangeListener())

Sorry: cannot post link as I'm a noob Crying or Very Sad

dl.dropbox.com/u/86094078/1-8-2013%203-26-04%20PM.png (use https)

Then once I move further on (just one line forward, declaring an int after the Listener instead of inside , as shown below, content-assist has stopped working! It simply will NOT assist from that point till EOF.

dl.dropbox.com/u/86094078/1-8-2013%203-34-41%20PM.png

Then commenting out the whole listener makes things work again...

dl.dropbox.com/u/86094078/1-8-2013%203-36-52%20PM.png

I tried deleting the whole block of code and hand type them again yet the behavior remains. I have tried cleaning out Eclipse's cahche (-clean), double-checked my content-assist setting (seems to be correct otherwise case #1 & 3 wouldn't have worked)

Strange thing is that I had another inline listener earlier in the file and things were working without any problem.

What can be the problem? (it's almost impossible to write code without content-assist Razz)

Thanks in advance for your assistances.

Michael
Previous Topic:How to call a method from a file .s4j
Next Topic:Code Assist Not Work In Ubuntu 12.04
Goto Forum:
  


Current Time: Thu Aug 21 20:16:04 EDT 2014

Powered by FUDForum. Page generated in 0.01479 seconds