Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Epsilon » [EGL] How to show in a static section different symbols?
[EGL] How to show in a static section different symbols? [message #990592] Thu, 13 December 2012 10:49 Go to next message
Lili R is currently offline Lili R
Messages: 15
Registered: April 2012
Junior Member
Hello,
I am doing an EGL template, and I want to show in static section some rhombus to simulate a list. So, I put it with the alt+260 combination, but when I run the template, appears the following message (see attached image)
My doubt is, is it possible to use these symbols in other way?
Thanks in advance!
Lili
  • Attachment: problem.png
    (Size: 31.65KB, Downloaded 53 times)
Re: [EGL] How to show in a static section different symbols? [message #990686 is a reply to message #990592] Thu, 13 December 2012 19:41 Go to previous messageGo to next message
Louis Rose is currently offline Louis Rose
Messages: 440
Registered: July 2009
Location: York, United Kingdom
Senior Member
Hi Lili,

Hmm, I wonder if there is perhaps something specific we need to do in EGL to support different character encodings. Could you possibly put together a minimal example that I can use to reproduce this problem? (http://www.eclipse.org/epsilon/doc/articles/minimal-examples/)

Thanks,
Louis.
Re: [EGL] How to show in a static section different symbols? [message #990734 is a reply to message #990592] Thu, 13 December 2012 21:55 Go to previous messageGo to next message
Antonio Garcia-Dominguez is currently offline Antonio Garcia-Dominguez
Messages: 309
Registered: January 2010
Senior Member
Have you tried to use UTF-8 encoding in your source file instead of CP1252 (ISO 8859-1)?
Re: [EGL] How to show in a static section different symbols? [message #990786 is a reply to message #990734] Fri, 14 December 2012 09:41 Go to previous messageGo to next message
Lili R is currently offline Lili R
Messages: 15
Registered: April 2012
Junior Member
Hello,
I did it, and still appear the same problem when I want to save the file's changes.
I wonder if I did it in the correct way (see attached figure) Thanks!
Regards,
Lili

P.S. I will provide a minimal example.
Re: [EGL] How to show in a static section different symbols? [message #990843 is a reply to message #990686] Fri, 14 December 2012 12:08 Go to previous messageGo to next message
Lili R is currently offline Lili R
Messages: 15
Registered: April 2012
Junior Member
Hello Louis,
I have attached a minimal example.
Note that in the 17 line y put:
♦ [%="♦"%] [%= factorC.ceoFactor%] in order to try with two possibilities that have the same efect(♦ or [%="♦"%])but this still doesn't work. However, I could run the EGL template, changing the encoding of all the workspace to UTF-8 (as Antonio Garcia suggested).
Thanks in advance!
Lili
Re: [EGL] How to show in a static section different symbols? [message #991494 is a reply to message #990843] Wed, 19 December 2012 14:12 Go to previous message
Dimitris Kolovos is currently offline Dimitris Kolovos
Messages: 866
Registered: July 2009
Senior Member
Hi,

To change the encoding of a single file in your workspace (e.g. a .egl file) you need to right-click it, select Properties->Resource-Text file encoding and choose a different encoding from the drop-down menu after selecting the Other radio button.

Cheers,
Dimitris
Previous Topic:Loading and running a egl on a custom profile in java (standalone)
Next Topic:[EVL] Problem running a evl file
Goto Forum:
  


Current Time: Wed Sep 17 07:34:39 GMT 2014

Powered by FUDForum. Page generated in 0.02013 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software