Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Remote Application Platform (RAP) » RWT Standalone WAR to WebLogic contextDirectory problem(Deploy WAR to WebLogic contextDirectory null problem)
RWT Standalone WAR to WebLogic contextDirectory problem [message #989245] Wed, 05 December 2012 10:50
John Gymer is currently offline John GymerFriend
Messages: 191
Registered: November 2012
Location: UK
Senior Member
REPOST FROM INCORRECT FORUM AREA:

Wonder if anyone can help with a problem deploying an RWT StandAlone application as a WAR into WebLogic...

(Please excuse any lack of knowledge here - it's the first time I've attempted something like this, so learning terminology at the same time!)

So far, I can run my application as a SWT, or as RWT StandAlone through Eclipse (4.2.1) using the built-in infrastructure in Eclipse e.g. Jetty etc.

Now I try to deploy the application as a WAR, which appears to be ok (WAR contains all the components I believe are needed), but on trying to deploy the WAR into Oracle WebLogic (10.3.4.0) I get an error during deploy stating that the contextDirectory must not be null:

An error occurred during activation of changes, please see the log for details.
weblogic.application.ModuleException: 
The parameter 'contextDirectory' must not be null. 
Selected Deployments were updated.


I can provide the full log message if necessary, but this appears to be the most useful part.

Where do I specify the contextDirectory, and how? In my WAR's web.xml? In the WebLogic.xml via the Plan.xml? (these last 2 were automatically created by WebLogic when I first defined and attempted to deploy the application WAR).

Let me know what other information may be useful too?

Would be useful to get some sort of overview of how WAR deploys work in general, as I'm going to have to do the same application deploy also on WebSphere and JBoss later!

Thanks, John


---
Just because you can doesn't mean you should
Previous Topic:Missing SWT Image Constants
Next Topic:Space characters missing in table items in IE 9
Goto Forum:
  


Current Time: Mon Nov 24 21:39:45 GMT 2014

Powered by FUDForum. Page generated in 0.02489 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software