Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Epsilon » [EVL] Quick Fix is disabled(The editor shows the error but the Quick Fix is not enabled)
[EVL] Quick Fix is disabled [message #985696] Thu, 15 November 2012 17:34 Go to next message
Mirco Franzago is currently offline Mirco Franzago
Messages: 12
Registered: November 2012
Junior Member
Hi,
this is my EVL source code:
context View {
  constraint WrongName {
      check : self.name <> 'wrong'
      message : 'the view has a wrong name'
  	  fix {
          title : 'Rename to correct'
          do {
              self.name := 'correct';
          }
      }
  }
}


The editor shows correctly the error in the Problems view
index.php/fa/12345/0/

but I don't know why the Quick Fix is not enabled.
index.php/fa/12346/0/

Something wrong in my EVL source?
Thank you.

PS I'm using this distributions: http://www.eclipse.org/epsilon/download/
  • Attachment: CaptureA.JPG
    (Size: 28.72KB, Downloaded 206 times)
  • Attachment: captureB.jpg
    (Size: 25.24KB, Downloaded 185 times)
Re: [EVL] Quick Fix is disabled [message #985712 is a reply to message #985696] Thu, 15 November 2012 18:31 Go to previous messageGo to next message
Antonio Garcia-Dominguez is currently offline Antonio Garcia-Dominguez
Messages: 309
Registered: January 2010
Senior Member
That *should* work, I think.

I have reproduced the issue using the attached editor and model. I'll look into it a bit. Meanwhile, could you report the bug so we can keep track of it?
Re: [EVL] Quick Fix is disabled [message #985753 is a reply to message #985712] Thu, 15 November 2012 23:14 Go to previous messageGo to next message
Antonio Garcia-Dominguez is currently offline Antonio Garcia-Dominguez
Messages: 309
Registered: January 2010
Senior Member
And it's fixed in SVN r2078. Still, could you please file a bug so we can track this issue for the rest of the users?

Sorry for the trouble! We'll upload distributions with the fix soon.
Re: [EVL] Quick Fix is disabled [message #985754 is a reply to message #985712] Thu, 15 November 2012 23:16 Go to previous messageGo to next message
Mirco Franzago is currently offline Mirco Franzago
Messages: 12
Registered: November 2012
Junior Member
Your attachments reproduce perfectly the issue.

The bug report is here: https://bugs.eclipse.org/bugs/show_bug.cgi?id=394430
Re: [EVL] Quick Fix is disabled [message #985756 is a reply to message #985753] Thu, 15 November 2012 23:21 Go to previous messageGo to next message
Mirco Franzago is currently offline Mirco Franzago
Messages: 12
Registered: November 2012
Junior Member
Ok, thank you very much.
Re: [EVL] Quick Fix is disabled [message #985781 is a reply to message #985756] Fri, 16 November 2012 07:36 Go to previous messageGo to next message
Antonio Garcia-Dominguez is currently offline Antonio Garcia-Dominguez
Messages: 309
Registered: January 2010
Senior Member
After talking with Dimitris, it looks that this isn't a bug. We just forgot to do step 4 in the official docs properly:

http://eclipse.org/epsilon/doc/articles/evl-gmf-integration/

We both missed adding the markerResolution extension with the appropriate markerType to the plugin with the EVL script. Oops Very Happy. Sorry!
Re: [EVL] Quick Fix is disabled [message #985882 is a reply to message #985781] Fri, 16 November 2012 14:48 Go to previous messageGo to next message
Mirco Franzago is currently offline Mirco Franzago
Messages: 12
Registered: November 2012
Junior Member
If it's enough to do copy and paste of the values in the step 4, I DID it. Otherwise, could you tell me where I can take the right values?
Thank you Razz
Re: [EVL] Quick Fix is disabled [message #986010 is a reply to message #985882] Sat, 17 November 2012 13:02 Go to previous messageGo to next message
Antonio Garcia-Dominguez is currently offline Antonio Garcia-Dominguez
Messages: 309
Registered: January 2010
Senior Member
Just copying and pasting the values won't work. There's two markerResolution extensions you need to add:

  • One needs to have the markerType attribute set to "org.eclipse.emf.ecore.diagnostic", which is the usual marker type for Ecore-based models. It's just like step 4 shows.
  • The other needs to have the markerType attribute set to "(your package).diagram.diagnostic". It depends on the Java package of the diagram that you generated using Eugenia. The above guide uses "org.eclipse.epsilon.eugenia.examples.filesystem.diagram.diagnostic", but it will be different in your case. Look in the code that GMF generated for you.
Re: [EVL] Quick Fix is disabled [message #986024 is a reply to message #986010] Sat, 17 November 2012 16:03 Go to previous message
Mirco Franzago is currently offline Mirco Franzago
Messages: 12
Registered: November 2012
Junior Member
It's work, perfect! Thank you very much! Smile
Previous Topic:[EuGENia] Issue with the generated editor
Next Topic:Re-using operations in multiple EGL files
Goto Forum:
  


Current Time: Thu Oct 30 16:15:58 GMT 2014

Powered by FUDForum. Page generated in 0.02834 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software