Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Remote Application Platform (RAP) » Eclipse Juno RAP problem
icon5.gif  Eclipse Juno RAP problem [message #979197] Sat, 10 November 2012 13:18 Go to next message
Felipe Oliveira is currently offline Felipe Oliveira
Messages: 4
Registered: November 2012
Junior Member
Hi people, I just downloaded the last Eclipse for RCP and RAP developers.
I tryed to do the Hello example but it show me a error message when I try to run:

osgi> 2012-11-10 16:08:07.029:WARN:oejs.ServletHandler:ERROR:  /rap
java.lang.IllegalArgumentException: Entry point not found: default


Do I have to set the entrypoint in somewhere ?
My target is RAP 2.0, I didn't choose it.. it just download the "recommended one".

Thanks in advance
Regards
Re: Eclipse Juno RAP problem [message #980013 is a reply to message #979197] Sun, 11 November 2012 04:05 Go to previous messageGo to next message
Ivan Furnadjiev is currently offline Ivan Furnadjiev
Messages: 1691
Registered: July 2009
Senior Member
Hi Felipe,
RAP 2.0 has a lot of breaking changes (see [1]). If your target is
2.0... you need Tools 2.0 as well. Unfortunately, there is a bug [2]
that prevents upgrading of Tools included in Juno "Eclipse for RCP and
RAP developers" package to the latest 2.0 milestone/nightly. You need
Juno Classic SDK package in order to install the latest version of Tools.

[1] http://www.eclipse.org/rap/noteworthy/2.0/migration-guide/
[2] https://bugs.eclipse.org/bugs/show_bug.cgi?id=391336

Best,
Ivan

On 11/11/2012 3:10 AM, Felipe Oliveira wrote:
> Hi people, I just downloaded the last Eclipse for RCP and RAP developers.
> I tryed to do the Hello example but it show me a error message when I
> try to run:
>
> osgi> 2012-11-10 16:08:07.029:WARN:oejs.ServletHandler:ERROR: /rap
> java.lang.IllegalArgumentException: Entry point not found: default
>
> Do I have to set the entrypoint in somewhere ?
> My target is RAP 2.0, I didn't choose it.. it just download the
> "recommended one".
>
> Thanks in advance
> Regards

--
Ivan Furnadjiev

Twitter: @EclipseRAP
Blog: http://eclipsesource.com/blogs/

Professional services for RAP and RCP?
http://eclipsesource.com/services/rap/
Re: Eclipse Juno RAP problem [message #980022 is a reply to message #979197] Sun, 11 November 2012 04:16 Go to previous messageGo to next message
Ivan Furnadjiev is currently offline Ivan Furnadjiev
Messages: 1691
Registered: July 2009
Senior Member
One more hint... In your existing setup you could try to change your
launch configuration. Change the "Servlet Path" field from "/rap" to the
value specified in "Startup parameter" field. Afterwards leave the
"Startup parameter" field empty.
HTH,
Ivan

On 11/11/2012 3:10 AM, Felipe Oliveira wrote:
> Hi people, I just downloaded the last Eclipse for RCP and RAP developers.
> I tryed to do the Hello example but it show me a error message when I
> try to run:
>
> osgi> 2012-11-10 16:08:07.029:WARN:oejs.ServletHandler:ERROR: /rap
> java.lang.IllegalArgumentException: Entry point not found: default
>
> Do I have to set the entrypoint in somewhere ?
> My target is RAP 2.0, I didn't choose it.. it just download the
> "recommended one".
>
> Thanks in advance
> Regards

--
Ivan Furnadjiev

Twitter: @EclipseRAP
Blog: http://eclipsesource.com/blogs/

Professional services for RAP and RCP?
http://eclipsesource.com/services/rap/
Re: Eclipse Juno RAP problem [message #980259 is a reply to message #980022] Sun, 11 November 2012 08:58 Go to previous messageGo to next message
Felipe Oliveira is currently offline Felipe Oliveira
Messages: 4
Registered: November 2012
Junior Member
Hi, thank you for your answer.
I changed the target to RAP 1.5 but got other error message:

org.osgi.framework.BundleException: The bundle "org.eclipse.rap.rwt.testfixture_1.5.1.20120917-1116 [21]" could not be resolved. Reason: Missing Constraint: Import-Package: org.json; version="0.0.0"


I'm use 64 bit eclipse version on Windows 7.

Anyway, I tryed also what you advice me about change the Servlet Path, but my Startup parameter is empty.. so it's does not work. Crying or Very Sad

Any clue Ivan ?
I would like very much to use RAP for my university project.

Thanks
Re: Eclipse Juno RAP problem [message #980330 is a reply to message #980259] Sun, 11 November 2012 10:17 Go to previous messageGo to next message
Ivan Furnadjiev is currently offline Ivan Furnadjiev
Messages: 1691
Registered: July 2009
Senior Member
Hi Felipe,
I would suggest to:
1. Download and install (unzip) "Eclipse for RCP and RAP developers"
Juno SR1.
2. Install and activate the latest released RAP runtime (Target
Components) [1] v1.5.1
3. Use "New Project" wizard to create RAP "Hello World" application.

[1] http://www.eclipse.org/rap/downloads/
PS. The org.eclipse.rap.rwt.testfixture bundle is not needed for normal
application execution, but only for JUnit tests.

HTH,
Ivan

On 11/11/2012 3:58 PM, Felipe Oliveira wrote:
> Hi, thank you for your answer. I changed the target to RAP 1.5 but got
> other error message:
>
> org.osgi.framework.BundleException: The bundle
> "org.eclipse.rap.rwt.testfixture_1.5.1.20120917-1116 [21]" could not
> be resolved. Reason: Missing Constraint: Import-Package: org.json;
> version="0.0.0"
>
> I'm use 64 bit eclipse version on Windows 7.
>
> Anyway, I tryed also what you advice me about change the Servlet Path,
> but my Startup parameter is empty.. so it's does not work. :cry:
> Any clue Ivan ?
> I would like very much to use RAP for my university project.
>
> Thanks

--
Ivan Furnadjiev

Twitter: @EclipseRAP
Blog: http://eclipsesource.com/blogs/

Professional services for RAP and RCP?
http://eclipsesource.com/services/rap/
Re: Eclipse Juno RAP problem [message #980389 is a reply to message #980330] Sun, 11 November 2012 11:32 Go to previous messageGo to next message
Felipe Oliveira is currently offline Felipe Oliveira
Messages: 4
Registered: November 2012
Junior Member
Hi Ivan.. I already tryed to do exactly what you said before.
And now I tryed again from the start but when I try to install target 1.5 it can't even install, I get a message:

Problems occurred while resolving the target contents
Error reading manifest for C:\ProjetosOSGI\workspace\.metadata\.plugins\org.eclipse.pde.core\.bundle_pool\plugins\org.eclipse.rap.ui.source_1.5.1.20120917-1116.jar
error in opening zip file

I'm out of luck I think.. since nobody seams to get this errors. It's a little deceiving.. I can't even get the hello world. Sad

Regards
Re: Eclipse Juno RAP problem [message #980471 is a reply to message #980389] Sun, 11 November 2012 13:02 Go to previous messageGo to next message
Ivan Furnadjiev is currently offline Ivan Furnadjiev
Messages: 1691
Registered: July 2009
Senior Member
Hi Felipe,
RAP runtime (Target Component) must not be installed into the IDE. Open
Eclipse IDE menu: Window -> Preferences -> Plug-in Development -> Target
Platform and set it there (add new from update site).
HTH,
Ivan

On 11/11/2012 6:32 PM, Felipe Oliveira wrote:
> Hi Ivan.. I already tryed to do exactly what you said before.
> And now I tryed again from the start but when I try to install target
> 1.5 it can't even install, I get a message:
>
> Problems occurred while resolving the target contents
> Error reading manifest for
> C:\ProjetosOSGI\workspace\.metadata\.plugins\org.eclipse.pde.core\.bundle_pool\plugins\org.eclipse.rap.ui.source_1.5.1.20120917-1116.jar
> error in opening zip file
>
> I'm out of luck I think.. since nobody seams to get this errors. It's
> a little deceiving.. I can't even get the hello world. :(
>
> Regards

--
Ivan Furnadjiev

Twitter: @EclipseRAP
Blog: http://eclipsesource.com/blogs/

Professional services for RAP and RCP?
http://eclipsesource.com/services/rap/
Re: Eclipse Juno RAP problem [message #980516 is a reply to message #980471] Sun, 11 November 2012 14:00 Go to previous messageGo to next message
Felipe Oliveira is currently offline Felipe Oliveira
Messages: 4
Registered: November 2012
Junior Member
Hi Ivan.. I tryed this way also and got same error:

Problems occurred while resolving the target contents
Error reading manifest for C:\ProjetosOSGI\workspace\.metadata\.plugins\org.eclipse.pde.core\.bundle_pool\plugins\org.eclipse.rap.ui.source_1.5.1.20120917-1116.jar
error in opening zip file

Do you think RAP is ready for use in Eclipse ? If yes I would like if you give me a closer support as I see you offer professional services.
Maybe we can chat on gtalk or skype if you don't mind. My skype is felipe.oliveira.alert and gtalk felipe.bit@gmail.com

Thank you

Regards
Re: Eclipse Juno RAP problem [message #981185 is a reply to message #980516] Mon, 12 November 2012 03:12 Go to previous message
Ivan Furnadjiev is currently offline Ivan Furnadjiev
Messages: 1691
Registered: July 2009
Senior Member
Hi Felipe,
RAP project is 6 years old project and it is included in all latest
simultaneous releases on Eclipse. Yes, it's ready to be used in Eclipse.
Just installed the latest RAP release (target platform) from the
following update site [1] without problem. For professional support look
here:
http://eclipsesource.com/services/rap/

[1] http://download.eclipse.org/rt/rap/1.5/runtime
Best,
Ivan


On 11/11/2012 9:00 PM, Felipe Oliveira wrote:
> Hi Ivan.. I tryed this way also and got same error:
>
> Problems occurred while resolving the target contents
> Error reading manifest for
> C:\ProjetosOSGI\workspace\.metadata\.plugins\org.eclipse.pde.core\.bundle_pool\plugins\org.eclipse.rap.ui.source_1.5.1.20120917-1116.jar
> error in opening zip file
>
> Do you think RAP is ready for use in Eclipse ? If yes I would like if
> you give me a closer support as I see you offer professional services.
> Maybe we can chat on gtalk or skype if you don't mind. My skype is
> felipe.oliveira.alert and gtalk mailto:felipe.bit@xxxxxxxx
>
> Thank you
>
> Regards

--
Ivan Furnadjiev

Twitter: @EclipseRAP
Blog: http://eclipsesource.com/blogs/

Professional services for RAP and RCP?
http://eclipsesource.com/services/rap/
Previous Topic:GUI Testing in RAP
Next Topic:Problem with RWT-OSGi integration bundle on JBoss 7.2
Goto Forum:
  


Current Time: Thu Apr 17 17:48:20 EDT 2014

Powered by FUDForum. Page generated in 0.02312 seconds