Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse 4 » Cannot open .e4xmi in 4.2.1
Cannot open .e4xmi in 4.2.1 [message #973877] Tue, 06 November 2012 17:43 Go to next message
Dave Duggan is currently offline Dave DugganFriend
Messages: 2
Registered: November 2012
Junior Member
Having upgraded to Eclipse 4.2.1, I can no longer open my .e4xmi files.
Help | About reports
Eclipse SDK

Version: 4.2.1
Build id: M20120914-1800

I have installed the e4 tooling components.

The error when trying to open the e4xmi file is:
org.eclipse.e4.core.di.InjectionException: Could not find satisfiable constructor in org.eclipse.e4.tools.services.impl.ResourceService$ResourcePool
at org.eclipse.e4.core.internal.di.InjectorImpl.internalMake(InjectorImpl.java:328)
at org.eclipse.e4.core.internal.di.InjectorImpl.make(InjectorImpl.java:240)
at org.eclipse.e4.core.contexts.ContextInjectionFactory.make(ContextInjectionFactory.java:161)
at org.eclipse.e4.tools.services.impl.ResourcePoolFactory.compute(ResourcePoolFactory.java:23)



Any ideas as to what the problem is?
Re: Cannot open .e4xmi in 4.2.1 [message #973974 is a reply to message #973877] Tue, 06 November 2012 19:17 Go to previous messageGo to next message
Thomas Schindl is currently offline Thomas SchindlFriend
Messages: 5487
Registered: July 2009
Senior Member
Which tooling did you install the exception looks very much like
https://bugs.eclipse.org/bugs/show_bug.cgi?id=371989

Tom

Am 06.11.12 20:10, schrieb Dave Duggan:
> Having upgraded to Eclipse 4.2.1, I can no longer open my .e4xmi files.
> Help | About reports
> Eclipse SDK
>
> Version: 4.2.1
> Build id: M20120914-1800
>
> I have installed the e4 tooling components.
>
> The error when trying to open the e4xmi file is:
> org.eclipse.e4.core.di.InjectionException: Could not find satisfiable
> constructor in
> org.eclipse.e4.tools.services.impl.ResourceService$ResourcePool
> at
> org.eclipse.e4.core.internal.di.InjectorImpl.internalMake(InjectorImpl.java:328)
>
> at
> org.eclipse.e4.core.internal.di.InjectorImpl.make(InjectorImpl.java:240)
> at
> org.eclipse.e4.core.contexts.ContextInjectionFactory.make(ContextInjectionFactory.java:161)
>
> at
> org.eclipse.e4.tools.services.impl.ResourcePoolFactory.compute(ResourcePoolFactory.java:23)
>
>
>
> Any ideas as to what the problem is?
Re: Cannot open .e4xmi in 4.2.1 [message #976126 is a reply to message #973974] Thu, 08 November 2012 10:31 Go to previous message
Dave Duggan is currently offline Dave DugganFriend
Messages: 2
Registered: November 2012
Junior Member
Having looked at that bug report and doing some checking I had installed the wrong version of the tooling. I had used download.eclipse.org/e4/updates. I have now got the tooling from download.eclipse.org/e4/updates/0.12 and it works correctly.

Thanks for the help.
Previous Topic:Apply Settings of Application Model
Next Topic:Reusing e4 Buttons, like min-max.
Goto Forum:
  


Current Time: Thu Dec 18 05:46:15 GMT 2014

Powered by FUDForum. Page generated in 0.09251 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software