Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Local Client Problem(Client app run locally not working)
Local Client Problem [message #973844] Tue, 06 November 2012 12:14 Go to next message
Alan Farroll is currently offline Alan Farroll
Messages: 50
Registered: June 2012
Member
Hello all,

I inherited a fairly complex Java project developed on Eclipse from a colleague who left and I am fairly new to both Java and Eclipse.

The project runs Tomcat and uses a WSDL for web service calls. A client was created to simulate external calls to the web service and the URL can be edited to use the local Tomcat web service or a server one. When debugging and using the Tomcat webservice on the server it runs fine but when I attempt to debug using the Tomcat web sevice on my local machine it fails. The first fault message provided is "faultString: java.net.ConnectException: Connection refused: connect"

I have checked that the port number specified is correct. I have checked that the web service URL is correct. I have checked that the WSDL is the same using a comparison tool. Lastly I have checked Tomcat is running because I can see the Tomcat home page running locally on my browser.

Why is this failing?

Thanks in advance

Regards

AJF
Re: Local Client Problem [message #973892 is a reply to message #973844] Tue, 06 November 2012 12:52 Go to previous messageGo to next message
Russell Bateman is currently offline Russell Bateman
Messages: 3146
Registered: July 2009
Location: Provo, Utah, USA
Senior Member

On 11/6/2012 10:14 AM, Alan Farroll wrote:
> Hello all,
>
> I inherited a fairly complex Java project developed on Eclipse from a
> colleague who left and I am fairly new to both Java and Eclipse.
>
> The project runs Tomcat and uses a WSDL for web service calls. A client
> was created to simulate external calls to the web service and the URL
> can be edited to use the local Tomcat web service or a server one. When
> debugging and using the Tomcat webservice on the server it runs fine but
> when I attempt to debug using the Tomcat web sevice on my local machine
> it fails. The first fault message provided is "faultString:
> java.net.ConnectException: Connection refused: connect"
>
> I have checked that the port number specified is correct. I have
> checked that the web service URL is correct. I have checked that the
> WSDL is the same using a comparison tool. Lastly I have checked Tomcat
> is running because I can see the Tomcat home page running locally on my
> browser.
>
> Why is this failing?
>
> Thanks in advance
>
> Regards
>
> AJF
Alan,

These are web application questions. The specific expertise lies in the
Eclipse web tools platform forum. Many here, like myself, know something
about web application programming and Eclipse, but everyone in the other
forum is an expert. I suggest you ask there.
Re: Local Client Problem [message #976192 is a reply to message #973892] Thu, 08 November 2012 06:36 Go to previous messageGo to next message
Alan Farroll is currently offline Alan Farroll
Messages: 50
Registered: June 2012
Member
Hi again Russell,

Thanks for the guidance. I will get to grips with this yet.

Regards

AJF
Re: Local Client Problem [message #976207 is a reply to message #973892] Thu, 08 November 2012 06:52 Go to previous message
Alan Farroll is currently offline Alan Farroll
Messages: 50
Registered: June 2012
Member
Hi Russell,

I could not find the web tools platform forum, found the "Web tools project" so posted the question there and also in the Java Development Tools foum.

Thanks again.

Regards

AJF
Previous Topic:Problem with Photran
Next Topic:HelloWorldSWT
Goto Forum:
  


Current Time: Thu Aug 21 10:21:50 EDT 2014

Powered by FUDForum. Page generated in 0.03169 seconds