Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Test and Performance Tools Platform (TPTP) » Missing entry point in AgentBase.dll
Missing entry point in AgentBase.dll [message #139480] Mon, 12 January 2009 22:18 Go to next message
Gabriel Valencia is currently offline Gabriel ValenciaFriend
Messages: 16
Registered: July 2009
Junior Member
Hello all

I am trying to start up a Java app using the -agentlib option. I have the
Agent Controller stuff in the path, but I get this error at startup:

The procedure entry point ?asyncRegisterAgent@BaseAgentImpl@@QAEHXZ could
not be located in the dynamic link library AgentBase.dll.

After closing the error dialog, the following error appears in stdout and
then the JVM just quits:

[Error: FATAL ERROR: JPIAgent can't load ACCollector]

I am using AC v 4.5.0 on WinXP SP2 with the following args:

-agentlib:JPIBootLoader=JPIAgent:server=enabled;CGProf:execd etails=true

Running on IBM JVM 1.5.0 SR7.

Could there be other DLLs in the path that are getting in the way? Any
help would be appreciated.
Re: Missing entry point in AgentBase.dll [message #139493 is a reply to message #139480] Mon, 12 January 2009 22:23 Go to previous message
Gabriel Valencia is currently offline Gabriel ValenciaFriend
Messages: 16
Registered: July 2009
Junior Member
Nevermind, just as I suspected. Had an agent controller from a Rational
product in the path first.
Previous Topic:Strange ordinal 48 error when trying to profile
Next Topic:Profiling a JNI invocation API-based application using TPTP 4.2
Goto Forum:
  


Current Time: Sun Dec 21 16:43:26 GMT 2014

Powered by FUDForum. Page generated in 0.01537 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software