Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse 4 » Using Babel to translate default dialogs in a e4 Application.
Using Babel to translate default dialogs in a e4 Application. [message #972504] Mon, 05 November 2012 17:25 Go to next message
Alex Kipling is currently offline Alex Kipling
Messages: 257
Registered: July 2012
Senior Member
I am trying to import Babel Project bundles into my e4 application,

What i did was:

importing the babel german-package into my target platform:
<location includeAllPlatforms="false" includeConfigurePhase="false" includeMode="planner" includeSource="true" type="InstallableUnit">
<unit id="org.eclipse.babel.nls_datatools_de.feature.group" version="4.2.0.v20120721043402"/>
<unit id="org.eclipse.babel.nls_eclipse_de.feature.group" version="4.2.0.v20120721043402"/>
<unit id="org.eclipse.babel.nls_modeling.emf_de.feature.group" version="4.2.0.v20120721043402"/>
<unit id="org.eclipse.babel.nls_modeling.emf.cdo_de.feature.group" version="4.2.0.v20120721043402"/>
<unit id="org.eclipse.babel.nls_modeling.gmp.gmf-tooling_de.feature.group" version="4.2.0.v20120721043402"/>
<unit id="org.eclipse.babel.nls_mylyn_de.feature.group" version="4.2.0.v20120721043402"/>
<unit id="org.eclipse.babel.nls_technology.actf_de.feature.group" version="4.2.0.v20120721043402"/>
<unit id="org.eclipse.babel.nls_technology.koneki_de.feature.group" version="4.2.0.v20120721043402"/>
<unit id="org.eclipse.babel.nls_technology.packaging.mpc_de.feature.group" version="4.2.0.v20120721043402"/>
<unit id="org.eclipse.babel.nls_technology.subversive_de.feature.group" version="4.2.0.v20120721043402"/>
<unit id="org.eclipse.babel.nls_tools.cdt_de.feature.group" version="4.2.0.v20120721043402"/>
<unit id="org.eclipse.babel.nls_tools.cdt.tcf_de.feature.group" version="4.2.0.v20120721043402"/>
<unit id="org.eclipse.babel.nls_tools.gef_de.feature.group" version="4.2.0.v20120721043402"/>
<unit id="org.eclipse.babel.nls_tools.pdt_de.feature.group" version="4.2.0.v20120721043402"/>
<unit id="org.eclipse.babel.nls_tools.tm_de.feature.group" version="4.2.0.v20120721043402"/>
<unit id="org.eclipse.babel.nls_webtools_de.feature.group" version="4.2.0.v20120721043402"/>
<repository location="http://download.eclipse.org/technology/babel/update-site/R0.10.0/juno"/>


Unfortunately there are some plugins missing:
http://i.imgur.com/nX79I.png


Question:
Where can I find the missing plugins?
Is loading the language packages - all I need to use the translations from Babel project? is there some customization to do?
Re: Using Babel to translate default dialogs in a e4 Application. [message #972783 is a reply to message #972504] Mon, 05 November 2012 22:21 Go to previous message
Wim Jongman is currently offline Wim Jongman
Messages: 280
Registered: July 2009
Senior Member

Hi Alex,

Did you try the babel newsgroup?

Regards,

Wim
Previous Topic:Adding 3.x ViewParts to E4XMI
Next Topic:Update site from archive over http
Goto Forum:
  


Current Time: Thu Oct 30 13:45:46 GMT 2014

Powered by FUDForum. Page generated in 0.06713 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software