Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Eclipse changes my code(When I type in code and reload it, it is messed up.)
Eclipse changes my code [message #962331] Mon, 29 October 2012 02:08 Go to next message
MIchael Y is currently offline MIchael Y
Messages: 1
Registered: October 2012
Junior Member
Hello,

I am kind of new to eclipse. I Just recently had this problem. When I type in code save my session and exit out. After opening uup eclipse again and opening the same project, A rectangle with 2 dots in it takes it place. I have to press spacebar to get rid of it. But it gets annoying cause after every new block of code it makes a rectangle.

Please help,
Michael

PS: I posted a picture as an attachment
Re: Eclipse changes my code [message #962471 is a reply to message #962331] Mon, 29 October 2012 04:47 Go to previous messageGo to next message
Russell Bateman is currently offline Russell Bateman
Messages: 3223
Registered: July 2009
Location: Provo, Utah, USA
Senior Member

On 10/28/2012 08:21 PM, MIchael Y wrote:
> Hello,
>
> I am kind of new to eclipse. I Just recently had this problem. When I type in code save my session and exit out. After opening uup eclipse again and opening the same project, A rectangle with 2 dots in it takes it place. I have to press spacebar to get rid of it. But it gets annoying cause after every new block of code it makes a rectangle.
>
> Please help,
> Michael
>
> PS: I posted a picture as an attachment

Do you not have Collapse All as the default for every file you open?
Re: Eclipse changes my code [message #962813 is a reply to message #962471] Mon, 29 October 2012 10:53 Go to previous message
Nitin Dahyabhai is currently offline Nitin Dahyabhai
Messages: 2310
Registered: July 2009
Senior Member
Specifically, the options here (not sure which one applies):

http://i.imgur.com/9zeYf.png


---
Nitin Dahyabhai
Eclipse WTP, IBM

[Updated on: Mon, 29 October 2012 10:54]

Report message to a moderator

Previous Topic:Problem with "-Dline.separator"
Next Topic:Eclipse Juno: "Not Responding" occasionally
Goto Forum:
  


Current Time: Fri Oct 24 20:37:32 GMT 2014

Powered by FUDForum. Page generated in 0.01579 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software