Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » IAM (Eclipse Integration for Apache Maven) » Error installing q4e plugin on Eclipse 3.4
Error installing q4e plugin on Eclipse 3.4 [message #12503] Thu, 24 July 2008 18:13 Go to next message
Eclipse UserFriend
Originally posted by: joe.chambers.cox.com

I get the following error when I try to install q4e on the Eclipse 3.4
application:

Cannot complete the request. See the details.
Eclipse Modeling Framework (EMF) - org.eclipse.emf.common will be ignored
because a newer version is already installed.
Eclipse Modeling Framework (EMF) - org.eclipse.emf.common.ui will be ignored
because a newer version is already installed.
Eclipse Modeling Framework (EMF) - org.eclipse.emf.ecore will be ignored
because a newer version is already installed.
Eclipse Modeling Framework (EMF) - org.eclipse.emf.ecore.edit will be
ignored because a newer version is already installed.
Eclipse Modeling Framework (EMF) - org.eclipse.emf.edit will be ignored
because a newer version is already installed.
Eclipse Modeling Framework (EMF) - org.eclipse.emf.edit.ui will be ignored
because a newer version is already installed.
Eclipse XML Editors and Tools will be ignored because a newer version is
already installed.
Graphical Editing Framework will be ignored because a newer version is
already installed.
WST Common Core will be ignored because a newer version is already
installed.
WST Common UI will be ignored because a newer version is already installed.
WST XML Core will be ignored because a newer version is already installed.
WST XML User Documentation will be ignored because a newer version is
already installed.
XML Schema Infoset Model (XSD) - org.eclipse.xsd will be ignored because a
newer version is already installed.
XML Schema Infoset Model (XSD) - org.eclipse.xsd.edit will be ignored
because a newer version is already installed.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.zest.layouts/[1.0.0.v2 0080226,1.0.0.v20080226]]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.zest.layouts/[1.0.0.v2 0080115,1.0.0.v20080115]]
can be satisfied.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.zest.layouts/[1.0.0.v2 0080226,1.0.0.v20080226]]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.zest.layouts/[1.0.0.v2 0080115,1.0.0.v20080115]]
can be satisfied.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.zest.layouts/[1.0.0.v2 0080226,1.0.0.v20080226]]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.zest.layouts/[1.0.0.v2 0080115,1.0.0.v20080115]]
can be satisfied.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.zest.layouts/[1.0.0.v2 0080226,1.0.0.v20080226]]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.zest.layouts/[1.0.0.v2 0080115,1.0.0.v20080115]]
can be satisfied.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.zest.layouts/[1.0.0.v2 0080226,1.0.0.v20080226]]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.zest.layouts/[1.0.0.v2 0080115,1.0.0.v20080115]]
can be satisfied.


Any help would be appreciated.

Thanks,

Joe
Re: Error installing q4e plugin on Eclipse 3.4 [message #12526 is a reply to message #12503] Mon, 28 July 2008 18:26 Go to previous messageGo to next message
Carlos Sanchez is currently offline Carlos SanchezFriend
Messages: 40
Registered: July 2009
Member
Have you selected the Dependency Viewer feature?

In 3.3 at least it complains if you don't have all requirements selected

Joe Chambers wrote:
> I get the following error when I try to install q4e on the Eclipse 3.4
> application:
>
> Cannot complete the request. See the details.
> Eclipse Modeling Framework (EMF) - org.eclipse.emf.common will be ignored
> because a newer version is already installed.
> Eclipse Modeling Framework (EMF) - org.eclipse.emf.common.ui will be ignored
> because a newer version is already installed.
> Eclipse Modeling Framework (EMF) - org.eclipse.emf.ecore will be ignored
> because a newer version is already installed.
> Eclipse Modeling Framework (EMF) - org.eclipse.emf.ecore.edit will be
> ignored because a newer version is already installed.
> Eclipse Modeling Framework (EMF) - org.eclipse.emf.edit will be ignored
> because a newer version is already installed.
> Eclipse Modeling Framework (EMF) - org.eclipse.emf.edit.ui will be ignored
> because a newer version is already installed.
> Eclipse XML Editors and Tools will be ignored because a newer version is
> already installed.
> Graphical Editing Framework will be ignored because a newer version is
> already installed.
> WST Common Core will be ignored because a newer version is already
> installed.
> WST Common UI will be ignored because a newer version is already installed.
> WST XML Core will be ignored because a newer version is already installed.
> WST XML User Documentation will be ignored because a newer version is
> already installed.
> XML Schema Infoset Model (XSD) - org.eclipse.xsd will be ignored because a
> newer version is already installed.
> XML Schema Infoset Model (XSD) - org.eclipse.xsd.edit will be ignored
> because a newer version is already installed.
> Cannot find a solution where both Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.zest.layouts/[1.0.0.v2 0080226,1.0.0.v20080226]]
> and Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.zest.layouts/[1.0.0.v2 0080115,1.0.0.v20080115]]
> can be satisfied.
> Cannot find a solution where both Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.zest.layouts/[1.0.0.v2 0080226,1.0.0.v20080226]]
> and Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.zest.layouts/[1.0.0.v2 0080115,1.0.0.v20080115]]
> can be satisfied.
> Cannot find a solution where both Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.zest.layouts/[1.0.0.v2 0080226,1.0.0.v20080226]]
> and Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.zest.layouts/[1.0.0.v2 0080115,1.0.0.v20080115]]
> can be satisfied.
> Cannot find a solution where both Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.zest.layouts/[1.0.0.v2 0080226,1.0.0.v20080226]]
> and Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.zest.layouts/[1.0.0.v2 0080115,1.0.0.v20080115]]
> can be satisfied.
> Cannot find a solution where both Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.zest.layouts/[1.0.0.v2 0080226,1.0.0.v20080226]]
> and Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.zest.layouts/[1.0.0.v2 0080115,1.0.0.v20080115]]
> can be satisfied.
>
>
> Any help would be appreciated.
>
> Thanks,
>
> Joe
>
>
Re: Error installing q4e plugin on Eclipse 3.4 [message #12547 is a reply to message #12503] Mon, 28 July 2008 18:27 Go to previous messageGo to next message
Carlos Sanchez is currently offline Carlos SanchezFriend
Messages: 40
Registered: July 2009
Member
Have you selected the Dependency Viewer feature?

In 3.3 at least it complains if you don't have all requirements selected

Joe Chambers wrote:
> I get the following error when I try to install q4e on the Eclipse 3.4
> application:
>
> Cannot complete the request. See the details.
> Eclipse Modeling Framework (EMF) - org.eclipse.emf.common will be ignored
> because a newer version is already installed.
> Eclipse Modeling Framework (EMF) - org.eclipse.emf.common.ui will be ignored
> because a newer version is already installed.
> Eclipse Modeling Framework (EMF) - org.eclipse.emf.ecore will be ignored
> because a newer version is already installed.
> Eclipse Modeling Framework (EMF) - org.eclipse.emf.ecore.edit will be
> ignored because a newer version is already installed.
> Eclipse Modeling Framework (EMF) - org.eclipse.emf.edit will be ignored
> because a newer version is already installed.
> Eclipse Modeling Framework (EMF) - org.eclipse.emf.edit.ui will be ignored
> because a newer version is already installed.
> Eclipse XML Editors and Tools will be ignored because a newer version is
> already installed.
> Graphical Editing Framework will be ignored because a newer version is
> already installed.
> WST Common Core will be ignored because a newer version is already
> installed.
> WST Common UI will be ignored because a newer version is already installed.
> WST XML Core will be ignored because a newer version is already installed.
> WST XML User Documentation will be ignored because a newer version is
> already installed.
> XML Schema Infoset Model (XSD) - org.eclipse.xsd will be ignored because a
> newer version is already installed.
> XML Schema Infoset Model (XSD) - org.eclipse.xsd.edit will be ignored
> because a newer version is already installed.
> Cannot find a solution where both Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.zest.layouts/[1.0.0.v2 0080226,1.0.0.v20080226]]
> and Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.zest.layouts/[1.0.0.v2 0080115,1.0.0.v20080115]]
> can be satisfied.
> Cannot find a solution where both Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.zest.layouts/[1.0.0.v2 0080226,1.0.0.v20080226]]
> and Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.zest.layouts/[1.0.0.v2 0080115,1.0.0.v20080115]]
> can be satisfied.
> Cannot find a solution where both Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.zest.layouts/[1.0.0.v2 0080226,1.0.0.v20080226]]
> and Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.zest.layouts/[1.0.0.v2 0080115,1.0.0.v20080115]]
> can be satisfied.
> Cannot find a solution where both Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.zest.layouts/[1.0.0.v2 0080226,1.0.0.v20080226]]
> and Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.zest.layouts/[1.0.0.v2 0080115,1.0.0.v20080115]]
> can be satisfied.
> Cannot find a solution where both Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.zest.layouts/[1.0.0.v2 0080226,1.0.0.v20080226]]
> and Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.zest.layouts/[1.0.0.v2 0080115,1.0.0.v20080115]]
> can be satisfied.
>
>
> Any help would be appreciated.
>
> Thanks,
>
> Joe
>
>
Re: Error installing q4e plugin on Eclipse 3.4 [message #12652 is a reply to message #12503] Wed, 13 August 2008 14:31 Go to previous messageGo to next message
Brian Bonner is currently offline Brian BonnerFriend
Messages: 12
Registered: July 2009
Junior Member
Hi Joe, I'm experiencing the same problem. I looked at q4e.googlecode.com
and didn't see anything about Ganymede support. Is there any news about
this?

Brian
Re: Error installing q4e plugin on Eclipse 3.4 [message #12673 is a reply to message #12652] Fri, 15 August 2008 15:38 Go to previous message
Abel Mui is currently offline Abel MuiFriend
Messages: 247
Registered: July 2009
Senior Member
Q4E can be installed on Eclipse 3.4, even when the update site does not
contain p2-specific metadata.

For helping you, we'll need to know which version of q4e are you
installing and which update site (releases or dev) are you using.

Thanks!
Abel Muiño
Re: Error installing q4e plugin on Eclipse 3.4 [message #566810 is a reply to message #12503] Mon, 28 July 2008 18:26 Go to previous message
Carlos Sanchez is currently offline Carlos SanchezFriend
Messages: 40
Registered: July 2009
Member
Have you selected the Dependency Viewer feature?

In 3.3 at least it complains if you don't have all requirements selected

Joe Chambers wrote:
> I get the following error when I try to install q4e on the Eclipse 3.4
> application:
>
> Cannot complete the request. See the details.
> Eclipse Modeling Framework (EMF) - org.eclipse.emf.common will be ignored
> because a newer version is already installed.
> Eclipse Modeling Framework (EMF) - org.eclipse.emf.common.ui will be ignored
> because a newer version is already installed.
> Eclipse Modeling Framework (EMF) - org.eclipse.emf.ecore will be ignored
> because a newer version is already installed.
> Eclipse Modeling Framework (EMF) - org.eclipse.emf.ecore.edit will be
> ignored because a newer version is already installed.
> Eclipse Modeling Framework (EMF) - org.eclipse.emf.edit will be ignored
> because a newer version is already installed.
> Eclipse Modeling Framework (EMF) - org.eclipse.emf.edit.ui will be ignored
> because a newer version is already installed.
> Eclipse XML Editors and Tools will be ignored because a newer version is
> already installed.
> Graphical Editing Framework will be ignored because a newer version is
> already installed.
> WST Common Core will be ignored because a newer version is already
> installed.
> WST Common UI will be ignored because a newer version is already installed.
> WST XML Core will be ignored because a newer version is already installed.
> WST XML User Documentation will be ignored because a newer version is
> already installed.
> XML Schema Infoset Model (XSD) - org.eclipse.xsd will be ignored because a
> newer version is already installed.
> XML Schema Infoset Model (XSD) - org.eclipse.xsd.edit will be ignored
> because a newer version is already installed.
> Cannot find a solution where both Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.zest.layouts/[1.0.0.v2 0080226,1.0.0.v20080226]]
> and Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.zest.layouts/[1.0.0.v2 0080115,1.0.0.v20080115]]
> can be satisfied.
> Cannot find a solution where both Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.zest.layouts/[1.0.0.v2 0080226,1.0.0.v20080226]]
> and Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.zest.layouts/[1.0.0.v2 0080115,1.0.0.v20080115]]
> can be satisfied.
> Cannot find a solution where both Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.zest.layouts/[1.0.0.v2 0080226,1.0.0.v20080226]]
> and Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.zest.layouts/[1.0.0.v2 0080115,1.0.0.v20080115]]
> can be satisfied.
> Cannot find a solution where both Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.zest.layouts/[1.0.0.v2 0080226,1.0.0.v20080226]]
> and Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.zest.layouts/[1.0.0.v2 0080115,1.0.0.v20080115]]
> can be satisfied.
> Cannot find a solution where both Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.zest.layouts/[1.0.0.v2 0080226,1.0.0.v20080226]]
> and Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.zest.layouts/[1.0.0.v2 0080115,1.0.0.v20080115]]
> can be satisfied.
>
>
> Any help would be appreciated.
>
> Thanks,
>
> Joe
>
>
Re: Error installing q4e plugin on Eclipse 3.4 [message #566832 is a reply to message #12503] Mon, 28 July 2008 18:27 Go to previous message
Carlos Sanchez is currently offline Carlos SanchezFriend
Messages: 40
Registered: July 2009
Member
Have you selected the Dependency Viewer feature?

In 3.3 at least it complains if you don't have all requirements selected

Joe Chambers wrote:
> I get the following error when I try to install q4e on the Eclipse 3.4
> application:
>
> Cannot complete the request. See the details.
> Eclipse Modeling Framework (EMF) - org.eclipse.emf.common will be ignored
> because a newer version is already installed.
> Eclipse Modeling Framework (EMF) - org.eclipse.emf.common.ui will be ignored
> because a newer version is already installed.
> Eclipse Modeling Framework (EMF) - org.eclipse.emf.ecore will be ignored
> because a newer version is already installed.
> Eclipse Modeling Framework (EMF) - org.eclipse.emf.ecore.edit will be
> ignored because a newer version is already installed.
> Eclipse Modeling Framework (EMF) - org.eclipse.emf.edit will be ignored
> because a newer version is already installed.
> Eclipse Modeling Framework (EMF) - org.eclipse.emf.edit.ui will be ignored
> because a newer version is already installed.
> Eclipse XML Editors and Tools will be ignored because a newer version is
> already installed.
> Graphical Editing Framework will be ignored because a newer version is
> already installed.
> WST Common Core will be ignored because a newer version is already
> installed.
> WST Common UI will be ignored because a newer version is already installed.
> WST XML Core will be ignored because a newer version is already installed.
> WST XML User Documentation will be ignored because a newer version is
> already installed.
> XML Schema Infoset Model (XSD) - org.eclipse.xsd will be ignored because a
> newer version is already installed.
> XML Schema Infoset Model (XSD) - org.eclipse.xsd.edit will be ignored
> because a newer version is already installed.
> Cannot find a solution where both Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.zest.layouts/[1.0.0.v2 0080226,1.0.0.v20080226]]
> and Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.zest.layouts/[1.0.0.v2 0080115,1.0.0.v20080115]]
> can be satisfied.
> Cannot find a solution where both Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.zest.layouts/[1.0.0.v2 0080226,1.0.0.v20080226]]
> and Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.zest.layouts/[1.0.0.v2 0080115,1.0.0.v20080115]]
> can be satisfied.
> Cannot find a solution where both Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.zest.layouts/[1.0.0.v2 0080226,1.0.0.v20080226]]
> and Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.zest.layouts/[1.0.0.v2 0080115,1.0.0.v20080115]]
> can be satisfied.
> Cannot find a solution where both Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.zest.layouts/[1.0.0.v2 0080226,1.0.0.v20080226]]
> and Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.zest.layouts/[1.0.0.v2 0080115,1.0.0.v20080115]]
> can be satisfied.
> Cannot find a solution where both Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.zest.layouts/[1.0.0.v2 0080226,1.0.0.v20080226]]
> and Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.zest.layouts/[1.0.0.v2 0080115,1.0.0.v20080115]]
> can be satisfied.
>
>
> Any help would be appreciated.
>
> Thanks,
>
> Joe
>
>
Re: Error installing q4e plugin on Eclipse 3.4 [message #566950 is a reply to message #12503] Wed, 13 August 2008 14:31 Go to previous message
Brian Bonner is currently offline Brian BonnerFriend
Messages: 12
Registered: July 2009
Junior Member
Hi Joe, I'm experiencing the same problem. I looked at q4e.googlecode.com
and didn't see anything about Ganymede support. Is there any news about
this?

Brian
Re: Error installing q4e plugin on Eclipse 3.4 [message #566966 is a reply to message #12652] Fri, 15 August 2008 15:38 Go to previous message
Abel Mui is currently offline Abel MuiFriend
Messages: 247
Registered: July 2009
Senior Member
Q4E can be installed on Eclipse 3.4, even when the update site does not
contain p2-specific metadata.

For helping you, we'll need to know which version of q4e are you
installing and which update site (releases or dev) are you using.

Thanks!
Abel Muiño
Previous Topic:Eclipse IAM project plan
Next Topic:Preparing for q4e 0.6.0
Goto Forum:
  


Current Time: Thu Dec 18 10:47:19 GMT 2014

Powered by FUDForum. Page generated in 0.06041 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software