Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Subversive » Bad problems creating tags
Bad problems creating tags [message #12432] Thu, 31 January 2008 08:12 Go to next message
Eclipse User
Originally posted by: list.stolsvik.com

Eclipse Build id: M20071023-1652

---------

1. Select the project node, where it for me states something like
"projectname || 98 [example.com reponame trunk: trunk]".
2. Right click, Team -> Tag...
3. Get the tag dialog, try to write a tag name TestTagWithSubversive2, as
indicated clearly in the documentation, both online and when accessing
through Eclipse.

This fails, it states:
"Field 'location' contains malformed URL: 'no protocol:
TestTagWithSubversive2"

So, I hit button "Browse".

There i get the *content of trunk* as root nodes, with a different styled
folder named ROOT on the same level (root). Opening this, I find the
'projectname' folder. Opening this, I find 'trunk', 'branches', 'tags'.

I select 'tags'.

I now get https://example.com/svn/reponame/projectname/tags in the
location field.

However, the dialog now marks error, stating
"'https://example.com/svn/reponame/projectname/tags' location does not
correspond the 'https://example.com/svn/reponame/projectname/trunk'
location."

This seems *really* weird, but I change it to the "suggested" path.

It then flags a new error, stating "Input the tag name. It should be typed
at the end of the tag location URL.".

I append "TestTagWithSubversive2" to it.

The OK button now appears, and I fill a comment, and hit OK.

This is what appears in the console. I use "Default SVNKit (SVNKit 1.1.4
(http://svnkit.com/) r3484)" as SVN Client.

--------------------
*** Tag
svn mkdir
" https://example.com/svn/reponame/projectname/trunk/TestTagWi thSubversive2"
-m "comment" --username "endre"
Committed revision 99
svn copy "C:/java/eclipse-workspace/projectname"
" https://example.com/svn/reponame/projectname/trunk/TestTagWi thSubversive2/trunk"
-r WORKING -m "comment" --username "endre"
A C:/java/eclipse-workspace/projectname
Committed revision 100
--------------------

Notice the two revisions - but that's probably normal?

When now updating, I get exactly the expected: a full copy of the project
within the project! Luckily it doesn't recurse, I guess, as the copy
wasn't there when the copy was made. It would maybe be interesting to see
what happened if I tried to make another tag.


So, what have I done wrong? I envision it might have something to do with
the original checkout - but what?
Re: Bad problems creating tags [message #12866 is a reply to message #12432] Thu, 31 January 2008 10:45 Go to previous messageGo to next message
Eclipse User
Originally posted by: list.stolsvik.com

> So, what have I done wrong? I envision it might have something to do with
> the original checkout - but what?

Answering my own question: That I used
https://example.com/svn/reponame/projectname/trunk/ as URL for the
repository location. Note the "trunk/" at the end.

This has actually worked perfectly well, until now when I wanted to tag.

This is my first time using Subversive. I've used both CVS and SVN, CLI
clients and CVS integration and Subclipse before, so I feel at least
somewhat versed in the notion of a VC system.
I do feel slightly pissed now that Subversive didn't warn me pretty
intensely when I tried to create the repository, like "WARNING: Dude,
there's "trunk" ("tags"/"branches") at the end of your URL - this,
according to my understanding of project layout, isn't the top of the
repository".
Furthermore, when Subversive realizes that the project I'm trying out
doesn't live up to its expectations AT ALL (that all of
"trunk/tags/branches" are missing, although I've stated that I use this
layout), it had a new opportunity to notify me about this.

When recreating the project with correct path to the top of the repo,
suddenly things work. In the Tag dialog, I don't have to input an URL in
the "Location" field, which now incidentally is named "Tag" instead, and
when hitting [Browse], I just get the existing Tags up instead. Also here
there was an opportunity to help me out: "WARNING: This dialog is put into
special condition X53/J due to the fact that your project layout doesn't
conform to the trunk/tags/branches layout - blah blah..".

How that dialog behaved (read above post) didn't make sense at any rate
given the error I had done.

Take-home message: assuming that there might be other brain dead people
like me out there, picking the "trunk" as the repository location (a level
into the repository), they will get utterly stuck. Given that subversive
demands that tags and branches shall reside _beneath_ the project
directory, it doesn't make sense to let the user pick _the_ project
directory as starting point - this will make the tags appear in the
"working set", with the obvious recursion this entails. THUS, the
restraints given one place (the Tag-dialog) doesn't make sense with the
leniency allowed previously (creating the repository entity together with
the checkout procedure).
Re: Bad problems creating tags [message #12957 is a reply to message #12866] Mon, 04 February 2008 09:25 Go to previous message
Eclipse User
Originally posted by: alexander.gurov.polarion.org

Hi Endre,


Thank you for sharing your opinion. Really the warning already exists but
due to error in the plug-in code it fails to be shown when URL ends with
"/" character. Moreover corresponding code will propose to change
repository location root to project URL automatically. So, this issue will
be fixed in the next Subversive build.
Previous Topic:FastTrack and Subversive 0.7
Next Topic:how to avoid accidental commits to tags
Goto Forum:
  


Current Time: Mon Jul 28 18:48:04 EDT 2014

Powered by FUDForum. Page generated in 0.02131 seconds