Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Test and Performance Tools Platform (TPTP) » IAC not working on Ganymede
IAC not working on Ganymede [message #132321] Wed, 09 July 2008 08:19 Go to next message
Anindya Mukherjee is currently offline Anindya MukherjeeFriend
Messages: 3
Registered: July 2009
Junior Member
Hi,
I have a fresh installation of Ganymede on Linux i386. I have used the
software installer from the Eclipse menu to install TPTP. The problem is
that I cannot get the IAC to start during profiling. I think the
installer automatically installs TPTP 4.5. I understand from the
documentation that this is supposed to work out of the box; well, it does
not. I tried on another Linux machine with the same result. Any help
would be greatly appreciated.

Anindya
Re: IAC not working on Ganymede [message #132394 is a reply to message #132321] Wed, 09 July 2008 19:47 Go to previous messageGo to next message
Anindya Mukherjee is currently offline Anindya MukherjeeFriend
Messages: 3
Registered: July 2009
Junior Member
Hi,
Here is a bit more info in my system. I am using Ubuntu 7.10 32 bit
on an Intel Core 2 Duo CPU. The Ganymede installation is the 164 MB JEE
release from the Eclipse project site. Apart from the dependencies for
TPTP I have only Visual Editor 1.3 installed via the "dropins" folder.
Everything except the profiling is working perfectly.

regards,
Anindya


On Wed, 2008-07-09 at 01:19 -0700, Anindya wrote:
> Hi,
> I have a fresh installation of Ganymede on Linux i386. I have used the
> software installer from the Eclipse menu to install TPTP. The problem is
> that I cannot get the IAC to start during profiling. I think the
> installer automatically installs TPTP 4.5. I understand from the
> documentation that this is supposed to work out of the box; well, it does
> not. I tried on another Linux machine with the same result. Any help
> would be greatly appreciated.
>
> Anindya
Re: IAC not working on Ganymede [message #132559 is a reply to message #132394] Fri, 11 July 2008 14:33 Go to previous messageGo to next message
Eugene Chan is currently offline Eugene ChanFriend
Messages: 287
Registered: July 2009
Senior Member
Hi Anindya,

Would you please try the following and see if you can start the IAC
manually? I suspect that IAC failed to start due to a problem on Ubuntu that
is currently under investigation.

1. Could you try go to the following directory under your eclipse download
folder:
%eclipse_install%/dropins/eclipse
/plugins/org.eclipse.tptp.platform.ac.linux_ia21_4.4.1.v2008 0617132/agent_controller/bin
2. try run ./SetConfig.sh, before you do this, make sure you shut down
Eclipse and no java.exe is running on your machine.
you can leave all the default setting unless you want to change your JVM
setting of the IAC.
3. try run ./RAStart.sh
Do you see any error reported when run RAStart.sh?

Eugene


"Anindya" <anindya49@hotmail.com> wrote in message
news:1215632825.29813.3.camel@hal...
> Hi,
> Here is a bit more info in my system. I am using Ubuntu 7.10 32 bit
> on an Intel Core 2 Duo CPU. The Ganymede installation is the 164 MB JEE
> release from the Eclipse project site. Apart from the dependencies for
> TPTP I have only Visual Editor 1.3 installed via the "dropins" folder.
> Everything except the profiling is working perfectly.
>
> regards,
> Anindya
>
>
> On Wed, 2008-07-09 at 01:19 -0700, Anindya wrote:
>> Hi,
>> I have a fresh installation of Ganymede on Linux i386. I have used the
>> software installer from the Eclipse menu to install TPTP. The problem is
>> that I cannot get the IAC to start during profiling. I think the
>> installer automatically installs TPTP 4.5. I understand from the
>> documentation that this is supposed to work out of the box; well, it does
>> not. I tried on another Linux machine with the same result. Any help
>> would be greatly appreciated.
>>
>> Anindya
>
Re: IAC not working on Ganymede [message #132597 is a reply to message #132559] Fri, 11 July 2008 19:50 Go to previous messageGo to next message
Anindya Mukherjee is currently offline Anindya MukherjeeFriend
Messages: 3
Registered: July 2009
Junior Member
Hi Eugene,
Thanks for replying. I think I know now what the problem is, at least
in my case. I started eclipse with the -consoleLog command line option
which shows the standard output on the terminal. It appears that the
ACServer binary which is being called by ACStart.sh is compiled against
gcc 2.95 and thus needs a really old version of libstdc++. All new Linux
distros ship with gcc 4 (and maybe 3) libraries installed, but not the
older version. In Ubuntu, it is still available on the repository,
however. I installed this, and immediately the IAC started working (I
didn't even need to restart eclipse, probably because IAC is launched
externally using a script). I have not checked all profiling options
yet, but execution time analysis at least is working, which is what I
needed.
Maybe it will be possible for the Eclipse team to compile the Agent
Controller against a newer version of gcc? Just a suggestion. The
problem is that the error message from Eclipse gives you no clue as to
what went wrong with the IAC. Thanks again for your reply.

regards,
Anindya

On Fri, 2008-07-11 at 10:33 -0400, Eugene Chan wrote:
> Hi Anindya,
>
> Would you please try the following and see if you can start the IAC
> manually? I suspect that IAC failed to start due to a problem on Ubuntu that
> is currently under investigation.
>
> 1. Could you try go to the following directory under your eclipse download
> folder:
> %eclipse_install%/dropins/eclipse
> /plugins/org.eclipse.tptp.platform.ac.linux_ia21_4.4.1.v2008 0617132/agent_controller/bin
> 2. try run ./SetConfig.sh, before you do this, make sure you shut down
> Eclipse and no java.exe is running on your machine.
> you can leave all the default setting unless you want to change your JVM
> setting of the IAC.
> 3. try run ./RAStart.sh
> Do you see any error reported when run RAStart.sh?
>
> Eugene
>
>
> "Anindya" <anindya49@hotmail.com> wrote in message
> news:1215632825.29813.3.camel@hal...
> > Hi,
> > Here is a bit more info in my system. I am using Ubuntu 7.10 32 bit
> > on an Intel Core 2 Duo CPU. The Ganymede installation is the 164 MB JEE
> > release from the Eclipse project site. Apart from the dependencies for
> > TPTP I have only Visual Editor 1.3 installed via the "dropins" folder.
> > Everything except the profiling is working perfectly.
> >
> > regards,
> > Anindya
> >
> >
> > On Wed, 2008-07-09 at 01:19 -0700, Anindya wrote:
> >> Hi,
> >> I have a fresh installation of Ganymede on Linux i386. I have used the
> >> software installer from the Eclipse menu to install TPTP. The problem is
> >> that I cannot get the IAC to start during profiling. I think the
> >> installer automatically installs TPTP 4.5. I understand from the
> >> documentation that this is supposed to work out of the box; well, it does
> >> not. I tried on another Linux machine with the same result. Any help
> >> would be greatly appreciated.
> >>
> >> Anindya
> >
>
>
Re: IAC not working on Ganymede [message #132675 is a reply to message #132597] Mon, 14 July 2008 13:53 Go to previous message
Eugene Chan is currently offline Eugene ChanFriend
Messages: 287
Registered: July 2009
Senior Member
Hi Anindya.

It's good to know that things are working for you now.I have opened Bug
240677 to address the issue you saw, please feel free to add yourself to the
bug entry to monitor and provide more feedback as appropriate.

Eugene

"Anindya" <anindya49@hotmail.com> wrote in message
news:1215805828.1565.13.camel@hal...
> Hi Eugene,
> Thanks for replying. I think I know now what the problem is, at least
> in my case. I started eclipse with the -consoleLog command line option
> which shows the standard output on the terminal. It appears that the
> ACServer binary which is being called by ACStart.sh is compiled against
> gcc 2.95 and thus needs a really old version of libstdc++. All new Linux
> distros ship with gcc 4 (and maybe 3) libraries installed, but not the
> older version. In Ubuntu, it is still available on the repository,
> however. I installed this, and immediately the IAC started working (I
> didn't even need to restart eclipse, probably because IAC is launched
> externally using a script). I have not checked all profiling options
> yet, but execution time analysis at least is working, which is what I
> needed.
> Maybe it will be possible for the Eclipse team to compile the Agent
> Controller against a newer version of gcc? Just a suggestion. The
> problem is that the error message from Eclipse gives you no clue as to
> what went wrong with the IAC. Thanks again for your reply.
>
> regards,
> Anindya
>
> On Fri, 2008-07-11 at 10:33 -0400, Eugene Chan wrote:
>> Hi Anindya,
>>
>> Would you please try the following and see if you can start the IAC
>> manually? I suspect that IAC failed to start due to a problem on Ubuntu
>> that
>> is currently under investigation.
>>
>> 1. Could you try go to the following directory under your eclipse
>> download
>> folder:
>> %eclipse_install%/dropins/eclipse
>> /plugins/org.eclipse.tptp.platform.ac.linux_ia21_4.4.1.v2008 0617132/agent_controller/bin
>> 2. try run ./SetConfig.sh, before you do this, make sure you shut down
>> Eclipse and no java.exe is running on your machine.
>> you can leave all the default setting unless you want to change your
>> JVM
>> setting of the IAC.
>> 3. try run ./RAStart.sh
>> Do you see any error reported when run RAStart.sh?
>>
>> Eugene
>>
>>
>> "Anindya" <anindya49@hotmail.com> wrote in message
>> news:1215632825.29813.3.camel@hal...
>> > Hi,
>> > Here is a bit more info in my system. I am using Ubuntu 7.10 32 bit
>> > on an Intel Core 2 Duo CPU. The Ganymede installation is the 164 MB JEE
>> > release from the Eclipse project site. Apart from the dependencies for
>> > TPTP I have only Visual Editor 1.3 installed via the "dropins" folder.
>> > Everything except the profiling is working perfectly.
>> >
>> > regards,
>> > Anindya
>> >
>> >
>> > On Wed, 2008-07-09 at 01:19 -0700, Anindya wrote:
>> >> Hi,
>> >> I have a fresh installation of Ganymede on Linux i386. I have used
>> >> the
>> >> software installer from the Eclipse menu to install TPTP. The problem
>> >> is
>> >> that I cannot get the IAC to start during profiling. I think the
>> >> installer automatically installs TPTP 4.5. I understand from the
>> >> documentation that this is supposed to work out of the box; well, it
>> >> does
>> >> not. I tried on another Linux machine with the same result. Any help
>> >> would be greatly appreciated.
>> >>
>> >> Anindya
>> >
>>
>>
>
Previous Topic:Suggestions for behavior tab in testsuite
Next Topic:Ganymede TPTP 4.5 - Call Tree shows only thread level
Goto Forum:
  


Current Time: Mon Dec 22 05:51:06 GMT 2014

Powered by FUDForum. Page generated in 0.01788 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software