Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Orbit » javax.xml api versions
javax.xml api versions [message #11976] Fri, 11 April 2008 14:12 Go to next message
Paul Gardiner is currently offline Paul Gardiner
Messages: 94
Registered: July 2009
Member
The javax.xml bundle has a bundle version (1.3.4), but no api versions, many
of which are different from the budle version, so automatic association
won't work. In cases where other bundles use versions on their import
package headers, such as org.xml.sax;version="2.0.2", they won't resolve.
I think the versions are as follows (used this to fix my issues):

Export-Package: javax.xml;version="1.3.4",
javax.xml.datatype;version="1.3.4",
javax.xml.namespace;version="1.3.4",
javax.xml.parsers;version="1.3.4",
javax.xml.transform;version="1.3.4",
javax.xml.transform.dom;version="1.3.4",
javax.xml.transform.sax;version="1.3.4",
javax.xml.transform.stream;version="1.3.4",
javax.xml.validation;version="1.3.4",
javax.xml.xpath;version="1.3.4",
org.apache.xmlcommons;version="1.3.4",
org.w3c.dom;version="1.0",
org.w3c.dom.bootstrap;version="1.0",
org.w3c.dom.css;version="1.0",
org.w3c.dom.events;version="1.0",
org.w3c.dom.html;version="1.0",
org.w3c.dom.ls;version="1.0",
org.w3c.dom.ranges;version="1.0",
org.w3c.dom.stylesheets;version="1.0",
org.w3c.dom.traversal;version="1.0",
org.w3c.dom.views;version="1.0",
org.w3c.dom.xpath;version="1.0",
org.xml.sax;version="2.0.2",
org.xml.sax.ext;version="2.0.2",
org.xml.sax.helpers;version="2.0.2"

Thanks,
Paul
Re: javax.xml api versions [message #12013 is a reply to message #11976] Tue, 15 April 2008 16:26 Go to previous messageGo to next message
David Williams is currently offline David Williams
Messages: 696
Registered: July 2009
Senior Member
On Fri, 11 Apr 2008 10:12:39 -0400, Paul Gardiner <pgardiner@syntellect.=
com> wrote:


Good suggestion. I suggest you open a bug report in orbit,
https://bugs.eclipse.org/bugs/enter_bug.cgi?product=3DOrbit
as that's the official way to suggest changes and improvements.
and perhaps even provide a patch?

Also, you're suggesting this on just 'exports' right? And, it's your own=
plugin that does the import-package with version constraints? Or, ... a=
re you saying we should use import-package in the rest of the xerces "fa=
mily" (which, I'd see as a bit more "risky" to change at this point).

Thanks!
Re: javax.xml api versions [message #12086 is a reply to message #12013] Wed, 16 April 2008 16:30 Go to previous messageGo to next message
Paul Gardiner is currently offline Paul Gardiner
Messages: 94
Registered: July 2009
Member
Sure, I'll open a bug report.

Yes, I'm just suggesting this for exports. In most cases, the api version
is the same as the bundle version, but in this case there are a few
versions, and that's what caused the problem. It wasn't my own plugin that
had the constraint, it was a plugin from Knopflerfish. Since our product is
Equinox based, I try to use the Orbit plugins wherever possible, but in this
case (axis2), Knopflerfish had what I needed, and I want it to work with the
parser bundle from Orbit.

As for the imports, yes, it would be nice if the Require-Bundle's were
changed to Import-Package, but in this case, it would likely, as you pointed
out, cause problems somewhere.

"David Williams" <david_williams@us.ibm.com> wrote in message
news:op.t9nulzfeac05ss@dmw2t23.ibm.com...
On Fri, 11 Apr 2008 10:12:39 -0400, Paul Gardiner <pgardiner@syntellect.com>
wrote:


Good suggestion. I suggest you open a bug report in orbit,
https://bugs.eclipse.org/bugs/enter_bug.cgi?product=Orbit
as that's the official way to suggest changes and improvements.
and perhaps even provide a patch?

Also, you're suggesting this on just 'exports' right? And, it's your own
plugin that does the import-package with version constraints? Or, ... are
you saying we should use import-package in the rest of the xerces "family"
(which, I'd see as a bit more "risky" to change at this point).

Thanks!
Re: javax.xml api versions [message #12099 is a reply to message #12013] Wed, 16 April 2008 17:46 Go to previous message
Paul Gardiner is currently offline Paul Gardiner
Messages: 94
Registered: July 2009
Member
Here's the bug report: https://bugs.eclipse.org/bugs/show_bug.cgi?id=227388



"David Williams" <david_williams@us.ibm.com> wrote in message
news:op.t9nulzfeac05ss@dmw2t23.ibm.com...
On Fri, 11 Apr 2008 10:12:39 -0400, Paul Gardiner <pgardiner@syntellect.com>
wrote:


Good suggestion. I suggest you open a bug report in orbit,
https://bugs.eclipse.org/bugs/enter_bug.cgi?product=Orbit
as that's the official way to suggest changes and improvements.
and perhaps even provide a patch?

Also, you're suggesting this on just 'exports' right? And, it's your own
plugin that does the import-package with version constraints? Or, ... are
you saying we should use import-package in the rest of the xerces "family"
(which, I'd see as a bit more "risky" to change at this point).

Thanks!
Re: javax.xml api versions [message #563296 is a reply to message #11976] Tue, 15 April 2008 16:26 Go to previous message
David Williams is currently offline David Williams
Messages: 696
Registered: July 2009
Senior Member
On Fri, 11 Apr 2008 10:12:39 -0400, Paul Gardiner <pgardiner@syntellect.=
com> wrote:


Good suggestion. I suggest you open a bug report in orbit,
https://bugs.eclipse.org/bugs/enter_bug.cgi?product=3DOrbit
as that's the official way to suggest changes and improvements.
and perhaps even provide a patch?

Also, you're suggesting this on just 'exports' right? And, it's your own=
plugin that does the import-package with version constraints? Or, ... a=
re you saying we should use import-package in the rest of the xerces "fa=
mily" (which, I'd see as a bit more "risky" to change at this point).

Thanks!
Re: javax.xml api versions [message #563417 is a reply to message #12013] Wed, 16 April 2008 16:30 Go to previous message
Paul Gardiner is currently offline Paul Gardiner
Messages: 94
Registered: July 2009
Member
Sure, I'll open a bug report.

Yes, I'm just suggesting this for exports. In most cases, the api version
is the same as the bundle version, but in this case there are a few
versions, and that's what caused the problem. It wasn't my own plugin that
had the constraint, it was a plugin from Knopflerfish. Since our product is
Equinox based, I try to use the Orbit plugins wherever possible, but in this
case (axis2), Knopflerfish had what I needed, and I want it to work with the
parser bundle from Orbit.

As for the imports, yes, it would be nice if the Require-Bundle's were
changed to Import-Package, but in this case, it would likely, as you pointed
out, cause problems somewhere.

"David Williams" <david_williams@us.ibm.com> wrote in message
news:op.t9nulzfeac05ss@dmw2t23.ibm.com...
On Fri, 11 Apr 2008 10:12:39 -0400, Paul Gardiner <pgardiner@syntellect.com>
wrote:


Good suggestion. I suggest you open a bug report in orbit,
https://bugs.eclipse.org/bugs/enter_bug.cgi?product=Orbit
as that's the official way to suggest changes and improvements.
and perhaps even provide a patch?

Also, you're suggesting this on just 'exports' right? And, it's your own
plugin that does the import-package with version constraints? Or, ... are
you saying we should use import-package in the rest of the xerces "family"
(which, I'd see as a bit more "risky" to change at this point).

Thanks!
Re: javax.xml api versions [message #563430 is a reply to message #12013] Wed, 16 April 2008 17:46 Go to previous message
Paul Gardiner is currently offline Paul Gardiner
Messages: 94
Registered: July 2009
Member
Here's the bug report: https://bugs.eclipse.org/bugs/show_bug.cgi?id=227388



"David Williams" <david_williams@us.ibm.com> wrote in message
news:op.t9nulzfeac05ss@dmw2t23.ibm.com...
On Fri, 11 Apr 2008 10:12:39 -0400, Paul Gardiner <pgardiner@syntellect.com>
wrote:


Good suggestion. I suggest you open a bug report in orbit,
https://bugs.eclipse.org/bugs/enter_bug.cgi?product=Orbit
as that's the official way to suggest changes and improvements.
and perhaps even provide a patch?

Also, you're suggesting this on just 'exports' right? And, it's your own
plugin that does the import-package with version constraints? Or, ... are
you saying we should use import-package in the rest of the xerces "family"
(which, I'd see as a bit more "risky" to change at this point).

Thanks!
Previous Topic:org.apache.commons.discovery has dependeny on org.apache.commons.logging
Next Topic:Orbit and Software Updates on Eclipse 3.4 M6
Goto Forum:
  


Current Time: Mon Oct 20 08:06:40 GMT 2014

Powered by FUDForum. Page generated in 0.03104 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software