Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Orbit » xalan and serializer
xalan and serializer [message #11928] Mon, 07 April 2008 14:39 Go to next message
Paul Gardiner is currently offline Paul Gardiner
Messages: 94
Registered: July 2009
Member
I have been having a problem where I get a NoClassDefFoundError from
org.apache.xalan:

java.lang.NoClassDefFoundError: org/apache/xml/serializer/TreeWalker
at
org.apache.xalan.processor.TransformerFactoryImpl.newTransfo rmer(TransformerFactoryImpl.java:823)
at
org.apache.ws.commons.schema.XmlSchema.serialize_internal(Xm lSchema.java:264)
.. . .

I fixed it by adding an import package for org.apache.xml.serializer to the
xalan (2.7.1) bundle's manifest, and adding the serializer bundle from
orbit. Could there be another problem, or should the manifest be changed?
Re: xalan and serializer [message #11939 is a reply to message #11928] Tue, 08 April 2008 19:47 Go to previous messageGo to next message
David Williams is currently offline David Williams
Messages: 696
Registered: July 2009
Senior Member
On Mon, 07 Apr 2008 14:39:32 -0400, Paul Gardiner <pgardiner@syntellect.=
com> wrote:

> Could there be another problem, or should the manifest be changed?

Yes, this is a bug, and I'm so embarrased about it, I opened it myself, =
instead of asking you to do it :)

https://bugs.eclipse.org/bugs/show_bug.cgi?id=3D226213
Re: xalan and serializer [message #11963 is a reply to message #11939] Fri, 11 April 2008 09:22 Go to previous message
Paul Gardiner is currently offline Paul Gardiner
Messages: 94
Registered: July 2009
Member
Thanks. I grabbed the latest, and it's working fine now.

"David Williams" <david_williams@us.ibm.com> wrote in message
news:op.t9bgczrpac05ss@dmw2t23.ibm.com...
On Mon, 07 Apr 2008 14:39:32 -0400, Paul Gardiner <pgardiner@syntellect.com>
wrote:

> Could there be another problem, or should the manifest be changed?

Yes, this is a bug, and I'm so embarrased about it, I opened it myself,
instead of asking you to do it :)

https://bugs.eclipse.org/bugs/show_bug.cgi?id=226213
Re: xalan and serializer [message #563148 is a reply to message #11928] Tue, 08 April 2008 19:47 Go to previous message
David Williams is currently offline David Williams
Messages: 696
Registered: July 2009
Senior Member
On Mon, 07 Apr 2008 14:39:32 -0400, Paul Gardiner <pgardiner@syntellect.=
com> wrote:

> Could there be another problem, or should the manifest be changed?

Yes, this is a bug, and I'm so embarrased about it, I opened it myself, =
instead of asking you to do it :)

https://bugs.eclipse.org/bugs/show_bug.cgi?id=3D226213
Re: xalan and serializer [message #563197 is a reply to message #11939] Fri, 11 April 2008 09:22 Go to previous message
Paul Gardiner is currently offline Paul Gardiner
Messages: 94
Registered: July 2009
Member
Thanks. I grabbed the latest, and it's working fine now.

"David Williams" <david_williams@us.ibm.com> wrote in message
news:op.t9bgczrpac05ss@dmw2t23.ibm.com...
On Mon, 07 Apr 2008 14:39:32 -0400, Paul Gardiner <pgardiner@syntellect.com>
wrote:

> Could there be another problem, or should the manifest be changed?

Yes, this is a bug, and I'm so embarrased about it, I opened it myself,
instead of asking you to do it :)

https://bugs.eclipse.org/bugs/show_bug.cgi?id=226213
Previous Topic:dom4j and some other libraries
Next Topic:javax.xml api versions
Goto Forum:
  


Current Time: Fri Aug 01 10:02:42 EDT 2014

Powered by FUDForum. Page generated in 0.01617 seconds