Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Papyrus » New release: Papyrus 0.9.1/0.9.1a
New release: Papyrus 0.9.1/0.9.1a [message #938032] Tue, 09 October 2012 09:43 Go to next message
Camille Letavernier is currently offline Camille Letavernier
Messages: 444
Registered: February 2011
Senior Member
Hello all,

The Service Release 1 of Papyrus 0.9 (Eclipse Juno) has been released on Friday 09/28. However, there's a critical bug on the Activity Diagram on this version, which prevents from moving any element:

390093: [Activity Diagram] StackOverFlow when moving an element in the Activity Diagram
https://bugs.eclipse.org/bugs/show_bug.cgi?id=390093

This bug has been fixed, and we're now releasing a maintenance build (0.9.1a). You can use the following update site to install it:

http://download.eclipse.org/modeling/mdt/papyrus/updates/releases/maintenance/juno


Regards,
Camille


Camille Letavernier
Papyrus developer
Re: New release: Papyrus 0.9.1/0.9.1a [message #989845 is a reply to message #938032] Sat, 08 December 2012 07:28 Go to previous messageGo to next message
Stefan Mijatov is currently offline Stefan Mijatov
Messages: 44
Registered: March 2010
Location: Vienna, Austria
Member
I have tried to install this on clean Eclipse Juno, and also after installing Papyrus from 'Install Modeling Components' feature. Neither works.

I get lots of errors that some dependencies are not satisfied.
Do I need some other plugins to install before installing Papyrus?

I tried all other Eclipse versions and corresponding Papyrus plugins,
but they either don't work, or they seem to lack the activity diagram editor..

I would appreciate any help.

Best,
Stefan
Re: New release: Papyrus 0.9.1/0.9.1a [message #989854 is a reply to message #989845] Sat, 08 December 2012 09:33 Go to previous messageGo to next message
Stefan Mijatov is currently offline Stefan Mijatov
Messages: 44
Registered: March 2010
Location: Vienna, Austria
Member
Indigo version seems to be working without activity diagram bug.
Problem installing Re: New release: Papyrus 0.9.1/0.9.1a [message #991411 is a reply to message #938032] Tue, 18 December 2012 18:45 Go to previous messageGo to next message
Michael Kerstetter is currently offline Michael Kerstetter
Messages: 1
Registered: December 2012
Junior Member
Camille,

I have Eclipse IDE for Java Developers, Juno Service Release 1. I am trying (and failing) to install Papyrus via Help>Install New Software from the recommended update site: http://download.eclipse.org/modeling/mdt/papyrus/updates/releases/maintenance/juno.

However, if fails with the following details:

Cannot complete the install because one or more required items could not be found.
Software being installed: Papyrus Extra Feature (Incubation) 0.9.1.v201210191332 (org.eclipse.papyrus.extra.feature.feature.group 0.9.1.v201210191332)
Missing requirement: Papyrus Compare UML File (Incubation) 0.9.1.v201210191332 (org.eclipse.papyrus.uml.compare.file 0.9.1.v201210191332) requires 'bundle org.eclipse.emf.compare.uml2 0.0.0' but it could not be found
Cannot satisfy dependency:
From: Papyrus Extra Feature (Incubation) 0.9.1.v201210191332 (org.eclipse.papyrus.extra.feature.feature.group 0.9.1.v201210191332)
To: org.eclipse.papyrus.extra.uml.compare.feature.feature.group [0.9.1.v201210191332]
Cannot satisfy dependency:
From: Papyrus UML Compare Feature (Incubation) 0.9.1.v201210191332 (org.eclipse.papyrus.extra.uml.compare.feature.feature.group 0.9.1.v201210191332)
To: org.eclipse.papyrus.uml.compare.file [0.9.1.v201210191332]

I have searched the Forum for a solution and while I've found some similar posts, the solutions, when there was one, didn't work either.

I'm totally stumped. Can you tell me what is wrong?

Thanks for your time,

Mike
Re: Problem installing Re: New release: Papyrus 0.9.1/0.9.1a [message #991450 is a reply to message #991411] Wed, 19 December 2012 03:36 Go to previous messageGo to next message
Camille Letavernier is currently offline Camille Letavernier
Messages: 444
Registered: February 2011
Senior Member
Hello Michael,

This update site contains both the main Papyrus components and the Papyrus extra components. If you simply install the main components (Papyrus SDK), the installation will work fine. However, if you also want to install all the extra components (Papyrus Extra), you will need an additionnal update site (We have a dependency on EMF/UML Compare, which is not released into Juno):

http://download.eclipse.org/modeling/emf/compare/updates/releases/1.3


Regards,
Camille


Camille Letavernier
Papyrus developer
Re: Problem installing Re: New release: Papyrus 0.9.1/0.9.1a [message #994624 is a reply to message #991450] Thu, 27 December 2012 16:45 Go to previous messageGo to next message
joe fessler is currently offline joe fessler
Messages: 4
Registered: December 2012
Junior Member
Please pardon my confusion, Camille. I've got the Papyrus SDK Binaries 0.9.1.v201209190809 loaded and have used the http://download.eclipse.org/modeling/emf/compare/updates/releases/1.3 site to update. Still, while attempting to load the Papyrus "extras", I get the error below. Are you saying this 0.9 version does not work with Juno, or that there is some other updates/components needed?

I'm kind of lost in the blur of version numbers.

Thanks.



Cannot complete the install because one or more required items could not be found.
Software being installed: Java code generator for Papyrus 1.3.3.200911231214 (com.cea.papyrus.gen.java.feature.group 1.3.3.200911231214)
Missing requirement: Java code generator for Papyrus 1.3.3.200911231214 (com.cea.papyrus.gen.java.feature.group 1.3.3.200911231214) requires 'com.cea.papyrus.feature.feature.group 1.9.0' but it could not be found
Re: Problem installing Re: New release: Papyrus 0.9.1/0.9.1a [message #997372 is a reply to message #994624] Mon, 07 January 2013 03:56 Go to previous messageGo to next message
Camille Letavernier is currently offline Camille Letavernier
Messages: 444
Registered: February 2011
Senior Member
Hello Joe,


Quote:
Cannot complete the install because one or more required items could not be found.
Software being installed: Java code generator for Papyrus 1.3.3.200911231214 (com.cea.papyrus.gen.java.feature.group 1.3.3.200911231214)
Missing requirement: Java code generator for Papyrus 1.3.3.200911231214 (com.cea.papyrus.gen.java.feature.group 1.3.3.200911231214) requires 'com.cea.papyrus.feature.feature.group 1.9.0' but it could not be found


This is not part of the Papyrus release, nor of the extra components. All "com.cea.papyrus.*" plug-ins/features are deprecated and cannot be installed on the current version of Papyrus. Which update site(s) are you using?


Regards,
Camille


Camille Letavernier
Papyrus developer
Re: Problem installing Re: New release: Papyrus 0.9.1/0.9.1a [message #1005690 is a reply to message #997372] Mon, 28 January 2013 04:57 Go to previous messageGo to next message
Carlos Gomez is currently offline Carlos Gomez
Messages: 22
Registered: October 2010
Junior Member
Hello everybody,

I have a similar problem with the extra packages of Papyrus nightly installation. I have the following dependency problem:

Cannot complete the install because one or more required items could not be found.
Software being installed: Papyrus Extra Feature (Incubation) 0.9.2.v201301280618 (org.eclipse.papyrus.extra.feature.feature.group 0.9.2.v201301280618)
Missing requirement: Papyrus extra: Tracing support for Qompass designer (Incubation) 0.9.2.v201301280618 (org.eclipse.papyrus.extra.qompass.designer.tracing.feature.feature.group 0.9.2.v201301280618) requires 'org.eclipse.papyrus.qompass.designer.feature.basic.feature.group 0.0.0' but it could not be found

Cordially,

CarlosG
Re: Problem installing Re: New release: Papyrus 0.9.1/0.9.1a [message #1005691 is a reply to message #1005690] Mon, 28 January 2013 05:00 Go to previous messageGo to next message
Camille Letavernier is currently offline Camille Letavernier
Messages: 444
Registered: February 2011
Senior Member
Hello Carlos,

I'm working on this issue right now. We've added new components to our extra build, but the build isn't totally stable yet.

However, you should not try to install Papyrus 0.9.2 nightly over Eclipse Juno SR1. It won't work, as we have a dependency to Eclipse Juno SR2 (Which hasn't been released yet...). I'll also try to remove this dependency, but until then, Papyrus 0.9.2 nightly can only work with Eclipse Juno SR2-RC1.

The first issue should be fixed today, but I don't know if I'll have enough time to fix the second one.


Regards,
Camille


Camille Letavernier
Papyrus developer
Re: Problem installing Re: New release: Papyrus 0.9.1/0.9.1a [message #1005740 is a reply to message #1005691] Mon, 28 January 2013 08:42 Go to previous messageGo to next message
Camille Letavernier is currently offline Camille Letavernier
Messages: 444
Registered: February 2011
Senior Member
Hello,

Both issues have been fixed. The nightly build of Papyrus-Juno (0.9.2 nightly) should now install and run on the following platforms:

- Eclipse 3.8.X (Juno)
- Eclipse 4.2.X (Juno)

Regards,
Camille


Camille Letavernier
Papyrus developer
Re: Problem installing Re: New release: Papyrus 0.9.1/0.9.1a [message #1005756 is a reply to message #1005740] Mon, 28 January 2013 10:12 Go to previous messageGo to next message
Carlos Gomez is currently offline Carlos Gomez
Messages: 22
Registered: October 2010
Junior Member
Hello Camille,

Thank you for your answer. I installed Eclipse Juno SR2-RC1 with EMF/UML Compare (from http://download.eclipse.org/modeling/emf/compare/updates/releases/1.3) and Papyrus Nightly works!!!!

Thank you so much!!!

Cordially,

CarlosG
Re: New release: Papyrus 0.9.1/0.9.1a [message #1024507 is a reply to message #938032] Tue, 26 March 2013 04:20 Go to previous message
Léo Martel is currently offline Léo Martel
Messages: 1
Registered: March 2013
Junior Member
Hello everybody,

I am trying to intsall the java code generator for papyrus from the papyrusuml updatepage (through the "install new softwares" button in eclipse "help" menu).

It raises the following error :

Cannot complete the install because one or more required items could not be found.
  Software being installed: Java code generator for Papyrus 1.3.3.200911231214 (com.cea.papyrus.gen.java.feature.group 1.3.3.200911231214)
  Missing requirement: Java code generator for Papyrus 1.3.3.200911231214 (com.cea.papyrus.gen.java.feature.group 1.3.3.200911231214) requires 'com.cea.papyrus.feature.feature.group 1.9.0' but it could not be found


I am confused because I thought that versions 1.x where deprecated. Please could you tell me if this feature is still supported and where i can find it.

Best reguards
Léo
Previous Topic:How to correctly import the ARINC653 Library from MARTE in papyrus (topcased)?
Next Topic:Operations compartment of a class in Composite Structure Diagrams
Goto Forum:
  


Current Time: Tue Sep 02 07:58:37 EDT 2014

Powered by FUDForum. Page generated in 0.04638 seconds