Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » C / C++ IDE (CDT) » wrench icon decoration "stuck" on some resources
wrench icon decoration "stuck" on some resources [message #915228] Sun, 16 September 2012 17:42 Go to next message
Thomas McLeod is currently offline Thomas McLeod
Messages: 5
Registered: September 2012
Junior Member
I don't know how I got the wrench on some of my files. I've tried reseting the resource. I've tried deleting the elements for the resources in the .cproject files. I've tried looking in the resource property indexes. I even tried deleting the files and reimporting them. No matter what I do the wrench, is stuck to some files. There is no apparent reason. I can change any other resource and reset set it again to make the wrench disappear. Major annoyance.
Re: wrench icon decoration "stuck" on some resources [message #915519 is a reply to message #915228] Mon, 17 September 2012 08:56 Go to previous messageGo to next message
Axel Mueller is currently offline Axel Mueller
Messages: 1927
Registered: July 2009
Senior Member
http://www.eclipse.org/forums/index.php/m/899917/?srch=pin#msg_899917

Before you ask
- search this forum
- see the FAQ http://wiki.eclipse.org/CDT/User/FAQ
- google
Re: wrench icon decoration "stuck" on some resources [message #915537 is a reply to message #915228] Mon, 17 September 2012 09:32 Go to previous messageGo to next message
Andrew Gvozdev is currently offline Andrew Gvozdev
Messages: 253
Registered: July 2009
Senior Member
Thomas McLeod wrote on Sun, 16 September 2012 17:42
I don't know how I got the wrench on some of my files. I've tried reseting the resource. I've tried deleting the elements for the resources in the .cproject files. I've tried looking in the resource property indexes. I even tried deleting the files and reimporting them. No matter what I do the wrench, is stuck to some files. There is no apparent reason. I can change any other resource and reset set it again to make the wrench disappear. Major annoyance.

Did you try right-click-on-resource->Resource Configurations->Reset to Default?
The wrench would appear if the resource uses customized (different from parent resource) "Language settings", such as include paths or macros. That can happen if those are changed by user in properties of the resource or maybe compiler options -I or -D picked by build output parser during the build.

Andrew
Re: wrench icon decoration "stuck" on some resources [message #915571 is a reply to message #915537] Mon, 17 September 2012 10:51 Go to previous message
Thomas McLeod is currently offline Thomas McLeod
Messages: 5
Registered: September 2012
Junior Member
Yes, as I've said, I tried "Reset to Default" numerous times. There should be nothing different about these files than any of the dozens of other files that don't have the wrench on them.

Is there a way to verify that indeed there are resource specific settings on them?
Previous Topic:Variadic template bug?
Next Topic:C++ Project Cannot Have Makefile Generated Automatically?
Goto Forum:
  


Current Time: Fri Apr 18 16:48:01 EDT 2014

Powered by FUDForum. Page generated in 0.02095 seconds