Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » TMF (Xtext) » xtext + tycho + xtext-utils unit testing fails(How to get them working together...?)
xtext + tycho + xtext-utils unit testing fails [message #915227] Sun, 16 September 2012 21:41
Scott Finnie is currently offline Scott FinnieFriend
Messages: 91
Registered: October 2011
Having some problems running tests that use xtext-utils. Runs fine from the IDE but from maven it's not finding any of the test input files. Error is:

testAssociation(org.domainmodels.Ooa.integrationtest.TestOoaStructure): java.lang.IllegalStateException: Couldn't find resource on classpath. URI was 'classpath:/TestOoaStructure/AssociationTest.ooa'

Found this post which covers the same topic:

Tried to make some changes as per the spray tests ( however mine still fail.

Complete newbie to maven & tycho which doesn't help. So it's quite possible I've missed some of the 'magic sauce' in changing my setup to reflect Spray.

So: is there a more up-to-date fix than the one in the post linked above? If not, any more specific pointers to changes I need to make?

If someone could explain why the test files aren't being found - even though they're on the classpath (as far as I can tell) - that would also be very useful.


Previous Topic:semantic quick fixes and commens
Goto Forum:

Current Time: Tue Dec 01 00:29:53 GMT 2015

Powered by FUDForum. Page generated in 0.04110 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software