Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » Java Development Tools (JDT) » activePerspective in workbench.xml not starting(How to active plugin for activePerspective on startup)
activePerspective in workbench.xml not starting [message #902260] Thu, 16 August 2012 15:30 Go to next message
Carl Goode is currently offline Carl Goode
Messages: 1
Registered: August 2012
Junior Member
Not sure how to handle this. I have a perspective that I've created, and all it does is display other views from other plugins AND set up services that I need. If I close eclipse with this perspective open, how do I get eclipse to start the Activator of my plugin so that the same services are started when I launch eclipse?

The workbench.xml file shows that my perspective is the activePerspective, yet since I'm not asking for any classes to be loaded, the bundle is not activated.

Thanks,
Carl
Re: activePerspective in workbench.xml not starting [message #902313 is a reply to message #902260] Fri, 17 August 2012 00:34 Go to previous messageGo to next message
David Wegener is currently offline David Wegener
Messages: 1341
Registered: July 2009
Senior Member
On 08/16/2012 10:30 AM, Carl Goode wrote:
> Not sure how to handle this. I have a perspective that I've created,
> and all it does is display other views from other plugins AND set up
> services that I need. If I close eclipse with this perspective open,
> how do I get eclipse to start the Activator of my plugin so that the
> same services are started when I launch eclipse?
>
> The workbench.xml file shows that my perspective is the
> activePerspective, yet since I'm not asking for any classes to be
> loaded, the bundle is not activated.
>
> Thanks,
> Carl
You probably should ask on the Platform or RCP newsgroup. This forum is
for questions pertaining to the Eclipse Java tools not plugin questions.
Re: activePerspective in workbench.xml not starting [message #902334 is a reply to message #902313] Fri, 17 August 2012 06:36 Go to previous message
Thomas Schindl is currently offline Thomas Schindl
Messages: 5331
Registered: July 2009
Senior Member
Dave is right you should have asked at the Platform newsgroup (even
better probably equinox) but your real problem is that Eclipse starts
bundles lazy! You need to make it start yours by default instead of lazy
this way your activator is called all the time no matter if a class is
loaded or not.

Tom

Am 17.08.12 02:34, schrieb David Wegener:
> On 08/16/2012 10:30 AM, Carl Goode wrote:
>> Not sure how to handle this. I have a perspective that I've created,
>> and all it does is display other views from other plugins AND set up
>> services that I need. If I close eclipse with this perspective open,
>> how do I get eclipse to start the Activator of my plugin so that the
>> same services are started when I launch eclipse?
>>
>> The workbench.xml file shows that my perspective is the
>> activePerspective, yet since I'm not asking for any classes to be
>> loaded, the bundle is not activated.
>>
>> Thanks,
>> Carl
> You probably should ask on the Platform or RCP newsgroup. This forum is
> for questions pertaining to the Eclipse Java tools not plugin questions.
Previous Topic:How can I use eclipse default package explorer to create my own package explorer
Next Topic:Newbie: how to make a project questions
Goto Forum:
  


Current Time: Mon Sep 22 18:20:30 GMT 2014

Powered by FUDForum. Page generated in 0.01707 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software